<!DOCTYPE html>
<html lang="en-GB" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#">
<head>

<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="6a9e0b5d-495a-45f8-95da-3962f059fa4e"></script>
<script type="text/javascript">
function OptanonWrapper() { }
</script>

<meta property="fb:pages" content="161755108961" />
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.criticalhit.net/xmlrpc.php" />

<meta name="google-site-verification" content="1vFejJFCT-gTHbz4YXtJrlWGHn4iBz-VmX1lyaF2QQ4" />

<title>Watch a Santa Stan beg for a PS5 in this hilarious SNL sketch</title>
<meta name="description" content="Besides the fact that it has been sold out, procuring a PS5 when it’s in stock this year involves dealing with armies of bots, filthy scalpers and preparing your elbows for a bloody war at the few stores that will sell you a console in person. What’s a fan to do? Why go full Stan and write to Santa of course." />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/" />
<meta property="og:locale" content="en_GB">
<meta property="og:type" content="article">
<meta property="og:title" content="Watch a Santa Stan beg for a PS5 in this hilarious SNL sketch">
<meta property="og:description" content="Besides the fact that it has been sold out, procuring a PS5 when it’s in stock this year involves dealing with armies of bots, filthy scalpers and preparing your elbows for a bloody war at the few stores that will sell you a console in person. What’s a fan to do? Why go full Stan and write to Santa of course.">
<meta property="og:url" content="https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/">
<meta property="og:site_name" content="Critical Hit">
<meta property="article:publisher" content="https://facebook.com/criticalhit.net">
<meta property="article:tag" content="gaming">
<meta property="article:tag" content="Jason Bateman">
<meta property="article:tag" content="Pete Davidson">
<meta property="article:tag" content="Playstation">
<meta property="article:tag" content="PS5">
<meta property="article:tag" content="SNL">
<meta property="article:tag" content="TimesLive">
<meta property="article:section" content="Gaming">
<meta property="og:updated_time" content="2020-12-07T07:57:43+02:00">
<meta property="og:image" content="https://i1.wp.com/media.criticalhit.net//2020/12/Dear-Santa.jpg">
<meta property="og:image:secure_url" content="https://i1.wp.com/media.criticalhit.net//2020/12/Dear-Santa.jpg">
<meta property="og:image:width" content="850">
<meta property="og:image:height" content="478">
<meta property="og:image:alt" content="Watch a Santa Stan beg for a PS5 in this hilarious SNL sketch">
<meta property="og:image:type" content="image/jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Watch a Santa Stan beg for a PS5 in this hilarious SNL sketch">
<meta name="twitter:description" content="Besides the fact that it has been sold out, procuring a PS5 when it’s in stock this year involves dealing with armies of bots, filthy scalpers and preparing your elbows for a bloody war at the few stores that will sell you a console in person. What’s a fan to do? Why go full Stan and write to Santa of course.">
<meta name="twitter:site" content="@CriticalHitNet">
<meta name="twitter:creator" content="@CriticalHitNet">
<meta name="twitter:image" content="https://i1.wp.com/media.criticalhit.net//2020/12/Dear-Santa.jpg">
<script type="application/ld+json" class="rank-math-schema">{
    "@context": "https://schema.org",
    "@graph": [
        {
            "@type": "Organization",
            "@id": "https://www.criticalhit.net/#organization",
            "name": "Critical Hit",
            "url": "https://www.criticalhit.net",
            "email": "info@criticalhit.net",
            "logo": {
                "@type": "ImageObject",
                "url": "https://media.criticalhit.net//2019/03/Critical_Hit-Logo-Icon.png"
            }
        },
        {
            "@type": "WebSite",
            "@id": "https://www.criticalhit.net/#website",
            "url": "https://www.criticalhit.net",
            "name": "Critical Hit",
            "publisher": {
                "@id": "https://www.criticalhit.net/#organization"
            },
            "inLanguage": "en-GB",
            "potentialAction": {
                "@type": "SearchAction",
                "target": "https://www.criticalhit.net/?s={search_term_string}",
                "query-input": "required name=search_term_string"
            }
        },
        {
            "@type": "ImageObject",
            "@id": "https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/#primaryImage",
            "url": "https://i1.wp.com/media.criticalhit.net//2020/12/Dear-Santa.jpg?fit=850%2C478&ssl=1",
            "width": 850,
            "height": 478
        },
        {
            "@type": "WebPage",
            "@id": "https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/#webpage",
            "url": "https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/",
            "name": "Watch a Santa Stan beg for a PS5 in this hilarious SNL sketch",
            "datePublished": "2020-12-07T09:00:00+02:00",
            "dateModified": "2020-12-07T07:57:43+02:00",
            "isPartOf": {
                "@id": "https://www.criticalhit.net/#website"
            },
            "primaryImageOfPage": {
                "@id": "https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/#primaryImage"
            },
            "inLanguage": "en-GB"
        },
        {
            "@type": "NewsArticle",
            "headline": "Watch a Santa Stan beg for a PS5 in this hilarious SNL sketch",
            "datePublished": "2020-12-07T09:00:00+02:00",
            "dateModified": "2020-12-07T07:57:43+02:00",
            "author": {
                "@type": "Person",
                "name": "Darryn Bonthuys"
            },
            "publisher": {
                "@id": "https://www.criticalhit.net/#organization"
            },
            "description": "Besides the fact that it has been sold out, procuring a PS5 when it\u2019s in stock this year involves dealing with armies of bots, filthy scalpers and preparing your elbows for a bloody war at the few stores that will sell you a console in person. What\u2019s a fan to do? Why go full Stan and write to Santa of course.",
            "@id": "https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/#richSnippet",
            "isPartOf": {
                "@id": "https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/#webpage"
            },
            "image": {
                "@id": "https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/#primaryImage"
            },
            "inLanguage": "en-GB",
            "mainEntityOfPage": {
                "@id": "https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/#webpage"
            }
        }
    ]
}</script>

<link rel='dns-prefetch' href='//www.criticalhit.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; Feed" href="https://www.criticalhit.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; Comments Feed" href="https://www.criticalhit.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; Watch a Santa Stan beg for a PS5 in this hilarious SNL sketch Comments Feed" href="https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.criticalhit.net\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='bdaia_shorty-style-css' href='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='formidable-css' href='https://www.criticalhit.net/wp-content/plugins/formidable/css/formidableforms.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.5.3/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://c0.wp.com/c/5.5.3/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='bdaia_shorty_stylesheet-css' href='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/shortcodes.css' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='theme-child-style-css' href='https://www.criticalhit.net/wp-content/themes/woohoo-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='woohoo-google-fonts-css' href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C300%2C700%7CLato%3A400%2C300%2C700%2C900%7CWork+Sans%3A400%2C300%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C600%2C700%2C800%7CPlayfair+Display%3A400%2C700%2C900%2C400italic%7CRaleway%3A400%2C300%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A400%2C300%2C100%2C700%7CMontserrat%3A400%2C700&#038;subset=latin%2Cgreek%2Cgreek-ext%2Cvietnamese%2Ccyrillic-ext%2Clatin-ext%2Ccyrillic' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css' href='https://www.criticalhit.net/wp-content/plugins/easy-table/themes/default/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='woohoo-default-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/style.css' type='text/css' media='all' />
<style id='woohoo-default-inline-css' type='text/css'>
body.category-41989 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-5 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-33983 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-41988 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-34107 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-58 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-41990 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-38 div.bdaia-blocks div.bdaia-post-view{display: none !important;}
</style>
<link rel='stylesheet' id='wooohoo-ilightbox-skin-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='wooohoo-ilightbox-skin-black-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/ilightbox/metro-black-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://c0.wp.com/p/jetpack/9.2/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/9.2/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' id='jquery-core-js-extra'>
/* <![CDATA[ */
var bd_w_blocks = {"bdaia_w_ajax_url":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","bdaia_w_ajax_nonce":"64e2472aef"};
var bd_blocks = {"bdaia_ajax_url":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","bdaia_ajaxnonce":"64e2472aef"};
var bd_script = {"post_id":"1116745","ajaxurl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/jquery/jquery.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/js/scripts.js' id='bdaia_shorty_scripts-js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/js/shorty-min.js' id='bdaia_shorty_min-js'></script>
<link rel="https://api.w.org/" href="https://www.criticalhit.net/wp-json/" /><link rel="alternate" type="application/json" href="https://www.criticalhit.net/wp-json/wp/v2/posts/1116745" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.criticalhit.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.criticalhit.net/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='https://www.criticalhit.net/?p=1116745' />
<link rel="alternate" type="application/json+oembed" href="https://www.criticalhit.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fwatch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.criticalhit.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fwatch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style> <script type="text/javascript">
            /* <![CDATA[ */
            var sf_position = '0';
            var sf_templates = "<a href=\"{search_url_escaped}\"><span class=\"sf_text\">View All Results<\/span><\/a>";
            var sf_input = '.search-live';
            jQuery(document).ready(function(){
                jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/www.criticalhit.net\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","rtl":0});
                jQuery(".live-search_ajaxy-selective-input").keyup(function() {
                    var width = jQuery(this).val().length * 8;
                    if(width < 50) {
                        width = 50;
                    }
                    jQuery(this).width(width);
                });
                jQuery(".live-search_ajaxy-selective-search").click(function() {
                    jQuery(this).find(".live-search_ajaxy-selective-input").focus();
                });
                jQuery(".live-search_ajaxy-selective-close").click(function() {
                    jQuery(this).parent().remove();
                });
            });
            /* ]]> */
        </script>
<link rel="shortcut icon" href="https://media.criticalhit.net/2018/12/favicon.png" type="image/x-icon" /><script data-ad-client="ca-pub-1473612930314813" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5GNB24P');</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<style>

@media all and (min-device-width: 700px) and (max-device-width: 728px) {#leaderboard-pixfuture {transform: scale(0.9);}} @media all and (min-device-width: 671px) and (max-device-width: 699px) {#leaderboard-pixfuture {transform: scale(0.9);transform-origin: 0 0;}} @media all and (min-device-width: 651px) and (max-device-width: 670px) {#leaderboard-pixfuture {transform: scale(0.88);transform-origin: 0 0;}} @media all and (min-device-width: 631px) and (max-device-width: 650px) {#leaderboard-pixfuture {transform: scale(0.85);transform-origin: 0 0;}} @media all and (min-device-width: 601px) and (max-device-width: 630px) {#leaderboard-pixfuture {transform: scale(0.8);transform-origin: 0 0;}} @media all and (min-device-width: 601px) and (max-device-width: 630px) {#leaderboard-pixfuture {transform: scale(0.8);transform-origin: 0 0;}} @media all and (min-device-width: 560px) and (max-device-width: 600px) {#leaderboard-pixfuture {transform: scale(0.75);transform-origin: 0 0;}} @media all and (min-device-width: 520px) and (max-device-width: 559px) {#leaderboard-pixfuture {transform: scale(0.7);transform-origin: 0 0;}} @media all and (min-device-width: 491px) and (max-device-width: 519px) {#leaderboard-pixfuture {transform: scale(0.65);transform-origin: 0 0;}} @media all and (min-device-width: 451px) and (max-device-width: 490px) {#leaderboard-pixfuture {transform: scale(0.6);transform-origin: 0 0;}} @media all and (min-device-width: 401px) and (max-device-width: 450px) {#leaderboard-pixfuture {transform: scale(0.55);transform-origin: 0 0;}} @media all and (min-device-width: 371px) and (max-device-width: 400px) {#leaderboard-pixfuture {transform: scale(0.5);transform-origin: 0 0;}} @media all and (min-device-width: 341px) and (max-device-width: 370px) {#leaderboard-pixfuture {transform: scale(0.46);transform-origin: 0 0;}} @media all and (min-device-width: 301px) and (max-device-width: 340px) {#leaderboard-pixfuture {transform: scale(0.42);transform-origin: 0 0;}} @media all and (max-device-width: 300px) {#leaderboard-pixfuture {transform: scale(0.4);transform-origin: 0 0;}}

</style>
<script type="text/javascript">
/* <![CDATA[ */
var userRating = {"ajaxurl":"https://www.criticalhit.net/wp-admin/admin-ajax.php" , "your_rating":"" , "nonce":"64e2472aef"};
var userLike = {"ajaxurl":"https://www.criticalhit.net/wp-admin/admin-ajax.php" , "nonce":"64e2472aef"};
/* ]]> */
var bdaia_theme_uri = 'https://www.criticalhit.net/wp-content/themes/woohoo';
</script>
<style type="text/css">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</style><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=270%2C270&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">
				.bdaia-post-content blockquote p,
blockquote p  {
  font-size: 20px !important;
  background: #f9f9f9 !important;
  border-left: 10px solid #ccc !important;
  margin: .5em 10px !important;
  padding: 0 10px !important;
  quotes: "\201C""\201D""\2018""\2019" !important;
  padding: 10px 20px !important;
  line-height: 1.4 !important;
	text-transform: none !important;
	color: grey  !important;
	text-align: left !important;
	font-weight: 300 !important;
}

.bdaia-post-content blockquote, blockquote {
    margin: 20px 5px 10px 0px !important;
	    padding-left: 0px !important;
    border-left: none !important;
}

.wp-block-jetpack-gif .wp-block-jetpack-gif-caption {
    color: #ffffff !important;
    font-weight: bold;
}			</style>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<meta name="msvalidate.01" content="2408EBF25A6FABECCCF3EC45230C1258" />
<script>
!function(a){var b=/iPhone/i,c=/iPod/i,d=/iPad/i,e=/(?=.*\bAndroid\b)(?=.*\bMobile\b)/i,f=/Android/i,g=/(?=.*\bAndroid\b)(?=.*\bSD4930UR\b)/i,h=/(?=.*\bAndroid\b)(?=.*\b(?:KFOT|KFTT|KFJWI|KFJWA|KFSOWI|KFTHWI|KFTHWA|KFAPWI|KFAPWA|KFARWI|KFASWI|KFSAWI|KFSAWA)\b)/i,i=/IEMobile/i,j=/(?=.*\bWindows\b)(?=.*\bARM\b)/i,k=/BlackBerry/i,l=/BB10/i,m=/Opera Mini/i,n=/(CriOS|Chrome)(?=.*\bMobile\b)/i,o=/(?=.*\bFirefox\b)(?=.*\bMobile\b)/i,p=new RegExp("(?:Nexus 7|BNTV250|Kindle Fire|Silk|GT-P1000)","i"),q=function(a,b){return a.test(b)},r=function(a){var r=a||navigator.userAgent,s=r.split("[FBAN");return"undefined"!=typeof s[1]&&(r=s[0]),s=r.split("Twitter"),"undefined"!=typeof s[1]&&(r=s[0]),this.apple={phone:q(b,r),ipod:q(c,r),tablet:!q(b,r)&&q(d,r),device:q(b,r)||q(c,r)||q(d,r)},this.amazon={phone:q(g,r),tablet:!q(g,r)&&q(h,r),device:q(g,r)||q(h,r)},this.android={phone:q(g,r)||q(e,r),tablet:!q(g,r)&&!q(e,r)&&(q(h,r)||q(f,r)),device:q(g,r)||q(h,r)||q(e,r)||q(f,r)},this.windows={phone:q(i,r),tablet:q(j,r),device:q(i,r)||q(j,r)},this.other={blackberry:q(k,r),blackberry10:q(l,r),opera:q(m,r),firefox:q(o,r),chrome:q(n,r),device:q(k,r)||q(l,r)||q(m,r)||q(o,r)||q(n,r)},this.seven_inch=q(p,r),this.any=this.apple.device||this.android.device||this.windows.device||this.other.device||this.seven_inch,this.phone=this.apple.phone||this.android.phone||this.windows.phone,this.tablet=this.apple.tablet||this.android.tablet||this.windows.tablet,"undefined"==typeof window?this:void 0},s=function(){var a=new r;return a.Class=r,a};"undefined"!=typeof module&&module.exports&&"undefined"==typeof window?module.exports=r:"undefined"!=typeof module&&module.exports&&"undefined"!=typeof window?module.exports=s():"function"==typeof define&&define.amd?define("isMobile",[],a.isMobile=s()):a.isMobile=s()}(this);
  googletag.cmd.push(function() {
	if(isMobile.any) {
	googletag.defineSlot('/55341649/300250MidarticleMobile', [300, 250],
		'div-gpt-ad-1540807120663-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/300x250ACmobile', [300, 250],
	    'div-gpt-ad-1540807963183-0').addService(googletag.pubads());
			googletag.defineSlot('/55341649/MastheadTop', [728, 90],
			'div-gpt-ad-1542102676397-0').addService(googletag.pubads());

	} else {
	googletag.defineSlot('/55341649/MastheadTop', [728, 90],
	'div-gpt-ad-1542102676397-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/728MidArticle', [728, 90],
			'div-gpt-ad-1540806613519-0').addService(googletag.pubads());
  googletag.defineSlot('/55341649/728Comments', [728, 90],
	    'div-gpt-ad-1540808126586-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/Background', [1, 1],
		'div-gpt-ad-1540376831756-0').addService(googletag.pubads());

    }
	googletag.enableServices();
  });
</script>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "WebSite",
  "url": "https://www.criticalhit.net/",
  "name": "Critical Hit",
  "description": "Critical Hit is a website built on the idea that we are more than one thing. Writers, writing about the things they love; games, film, TV, technology and more.",
  "publisher": "Critical Hit",
  "potentialAction": {
    "@type": "SearchAction",
    "target": "https://www.criticalhit.net/?s={search_term}",
    "query-input": "required name=search_term" }
    }
</script>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "Organization",
  "url": "https://www.criticalhit.net",
  "logo": "https://www.criticalhit.net/images/Icon.png"
}
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-1473612930314813",
          enable_page_level_ads: false
     });
</script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.flexslider-min.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.eislideshow.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.placeholder.min.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.fitvids.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/modernizr.js"></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/criticalhit/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
</head>
<body class="post-template-default single single-post postid-1116745 single-format-standard wp-embed-responsive bdaia-boxed  of-new-article  has-lazy-load" itemscope itemtype="http://schema.org/WebPage">
<div class="page-outer bdaia-header-default bdaia-lazyload  sticky-nav-on  bdaia-post-template-default  bdaia-sidebar-right ">
<div class="bg-cover"></div>
<aside id="bd-MobileSiderbar">
<div id="mobile-menu"></div>
<div class="widget-social-links bdaia-social-io-colored">
<div class="sl-widget-inner">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class=" bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class=" bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class=" bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class=" bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class=" bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</aside>

<div id='div-gpt-ad-1540376831756-0' style='height:1px; width:1px;'>
<script>
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540376831756-0'); });
	</script>
</div>
<div id="page">
<div class="inner-wrapper">
<div id="warp" class="clearfix  bdaia-sidebar-right ">
<div class="header-wrapper">
<div class="bdayh-click-open">
<div class="bd-ClickOpen bd-ClickAOpen">
<span></span>
</div>
</div>
<header class="header-container">
<div class="bd-container">
<div class="logo site--logo">
<h2 class="site-title"> <a href="https://www.criticalhit.net/" rel="home" title="Critical Hit">
<img src="https://media.criticalhit.net/2016/12/Critical_Hit-Logo-Gaming.png" alt="Critical Hit" />
</a>
</h2> </div>
<div class="bdaia-header-e3-desktop"><div class="bdaia-e3-container"> <div id="leaderboard-pixfuture" style="width:728px; margin:0 auto;">
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<div id="gpt-passback">
<script>
    window.googletag = window.googletag || {cmd: []};
    googletag.cmd.push(function() {
    googletag.defineSlot('/55341649/MastheadTop', [728, 90], 'gpt-passback').addService(googletag.pubads());
    googletag.enableServices();
    googletag.display('gpt-passback');
    });
  </script>
</div>
</div></div></div>
</div>
</header>
<div class="cfix"></div>
<nav id="navigation" class="">
<div class="navigation-wrapper">
<div class="bd-container">
<div class="primary-menu">
<a class="nav-logo" title="Critical Hit" href="https://www.criticalhit.net/">
<img src="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-Text-Only.png" width="195" height="48" alt="Critical Hit" />
</a>
<ul id="menu-primary">
<li id="menu-item-526858" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/gaming/"> <i class="fa fa fa-gamepad"></i> <span class="menu-label" style="">Games</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526854" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/entertainment/"> <i class="fa fa fa-film"></i> <span class="menu-label" style="">Entertainment</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526870" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/technology/"> <i class="fa fa fa-power-off"></i> <span class="menu-label" style="">Tech</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526876" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/comics-toys/"> <i class="fa fa fa-comment-o"></i> <span class="menu-label" style="">Comics</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526860" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/lifestyle/"> <i class="fa fa fa-heart"></i> <span class="menu-label" style="">Lifestyle</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-726070" class=" menu-item menu-item-type-post_type menu-item-object-page bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/esports/"> <i class="fa fa fa-users"></i> <span class="menu-label" style="">esports</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-881926" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/review/"> <i class="fa fa fa-book"></i> <span class="menu-label" style="">Reviews</span></a>
<div class="mega-menu-content">
</div> </ul>
</div>
<div class="nav-right-area">
<div class="bdaia-nav-search">
<span class="bdaia-ns-btn bdaia-io bdaia-io-search"></span>
<div class="bdaia-ns-wrap">
<div class="bdaia-ns-content">
<div class="bdaia-ns-inner">
<form method="get" id="searchform" action="https://www.criticalhit.net/">
<input type="text" class="bbd-search-field search-live" id="s" name="s" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}" />
<button type="submit" class="bbd-search-btn"><span class="bdaia-io bdaia-io-search"></span></button>
</form>
</div>
</div>
</div>
</div>
</div>
<div class="cfix"></div>
</div>
</div>
</nav>
<div class="cfix"></div>
</div>
<div class="bdMain">
<div class="bd-container bdaia-post-template">
<div class="bd-main bdaia-site-content" id="bdaia-primary">
<div id="content" role="main">
<div class="bdaia-crumb-container"><span><a class="crumbs-home" href="https://www.criticalhit.net">Home</a></span> <span class="delimiter"><span class="bdaia-io bdaia-io-angle-double-right"></span></span> <span><a href="https://www.criticalhit.net/category/gaming/">Gaming</a></span> <span class="delimiter"><span class="bdaia-io bdaia-io-angle-double-right"></span></span> <span class="current">Watch a Santa Stan beg for a PS5 in this hilarious SNL sketch</span></div><div class="bdayh-clearfix"></div>
<article id="post-1116745" class="hentry post-1116745 post type-post status-publish format-standard has-post-thumbnail category-gaming tag-gaming tag-jason-bateman tag-pete-davidson tag-playstation tag-ps5 tag-snl tag-timeslive" itemscope itemtype="https://schema.org/Article">
<header class="bdaia-post-header">
<div class="bdaia-post-title">
<h1 class="post-title entry-title"><span>Watch a Santa Stan beg for a PS5 in this hilarious SNL sketch</span></h1>
</div>

<div class="bdaia-meta-info">
<div class="bdaia-post-author-name">
By <a href="https://www.criticalhit.net/author/dbonthuys/" title="">Darryn Bonthuys </a>
</div>
<div class="bdaia-post-date"><span class='bdaia-io bdaia-io-calendar'></span>Posted on&nbsp;<span class="bdayh-date">17 hours ago</span></div>
<div class="bdaia-post-time-read"><span class='bdaia-io bdaia-io-clock'></span>2&nbsp;min read</div>
<div class="bdaia-post-comment"><span class='bdaia-io bdaia-io-bubbles4'></span><a href="https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/#comments"><span class="dsq-postid" data-dsqidentifier="1116745 https://www.criticalhit.net/?p=1116745">1</span></a></div>
</div>

</header>
<div class="bdaia-post-sharing bdaia-post-sharing-top">
<ul>
<li class="facebook">
<a title="facebook" onClick="window.open('http://www.facebook.com/sharer.php?u=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/">
<span class="bdaia-io bdaia-io-facebook"></span>
<span>Share on Facebook</span>
</a>
</li>
<li class="twitter">
<a title="twitter" onClick="window.open('http://twitter.com/share?url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/&amp;text=Watch%20a%20Santa%20Stan%20beg%20for%20a%20PS5%20in%20this%20hilarious%20SNL%20sketch','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/&amp;text=Watch%20a%20Santa%20Stan%20beg%20for%20a%20PS5%20in%20this%20hilarious%20SNL%20sketch">
<span class="bdaia-io bdaia-io-twitter"></span>
<span>Share on Twitter</span>
</a>
</li>
<li class="google">
<a title="google" onClick="window.open('https://plus.google.com/share?url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/">
<span class="bdaia-io bdaia-io-google-plus"></span>
<span>Share on Google+</span>
</a>
</li>
<li class="reddit">
<a title="reddit" onClick="window.open('http://reddit.com/submit?url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/&amp;title=Watch%20a%20Santa%20Stan%20beg%20for%20a%20PS5%20in%20this%20hilarious%20SNL%20sketch','Reddit','width=617,height=514,left='+(screen.availWidth/2-308)+',top='+(screen.availHeight/2-257)+''); return false;" href="https://reddit.com/submit?url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/&amp;title=Watch%20a%20Santa%20Stan%20beg%20for%20a%20PS5%20in%20this%20hilarious%20SNL%20sketch">
<span class="bdaia-io bdaia-io-reddit"></span>
<span>Share on Reddit</span>
</a>
</li>
<li class="pinterest">
<a title="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fwatch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch%2F&amp;description=Watch+a+Santa+Stan+beg+for+a+PS5+in+this+hilarious+SNL+sketch&amp;media=https%3A%2F%2Fi1.wp.com%2Fmedia.criticalhit.net%2F%2F2020%2F12%2FDear-Santa.jpg%3Ffit%3D850%252C478%26ssl%3D1">
<span class="bdaia-io bdaia-io-social-pinterest"></span>
<span>Share on Pinterest</span>
</a>
</li>
<li class="linkedin">
<a title="linkedin" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/">
<span class="bdaia-io bdaia-io-linkedin2"></span>
<span>Share on Linkedin</span>
</a>
</li>
<li class="tumblr">
<a title="tumblr" onClick="window.open('http://www.tumblr.com/share/link?url=www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/&amp;name=Watch%20a%20Santa%20Stan%20beg%20for%20a%20PS5%20in%20this%20hilarious%20SNL%20sketch','Tumblr','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.tumblr.com/share/link?url=www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/&amp;name=Watch%20a%20Santa%20Stan%20beg%20for%20a%20PS5%20in%20this%20hilarious%20SNL%20sketch">
<span class="bdaia-io bdaia-io-tumblr"></span>
<span>Share on Tumblr</span>
</a>
</li>
<li class="whatsapp">
<a href="whatsapp://send?text=Besides+the+fact+that+it+has+been+sold+out%2C+procuring+a+PS5+when+it%E2%80%99s+in+stock+this+year+involves+dealing+with+armies+of+bots%2C+filthy+scalpers+and+preparing+your+elbows+for+a+bloody+war+at+the+few+stores+that+will+sell+you+a+console+in+person.+What%E2%80%99s+a+fan+to+do%3F+Why+go+full+Stan+and+write+to+Santa+of+course.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fwatch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch%2F"><span class="bdaia-io bdaia-io-whatsapp"></span></a> </li>
<li class="telegram">
<a href="tg://msg?text=Besides+the+fact+that+it+has+been+sold+out%2C+procuring+a+PS5+when+it%E2%80%99s+in+stock+this+year+involves+dealing+with+armies+of+bots%2C+filthy+scalpers+and+preparing+your+elbows+for+a+bloody+war+at+the+few+stores+that+will+sell+you+a+console+in+person.+What%E2%80%99s+a+fan+to+do%3F+Why+go+full+Stan+and+write+to+Santa+of+course.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fwatch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch%2F"><span class="bdaia-io bdaia-io-telegram"></span></a> </li>
</ul>
</div>

<div class="bdaia-post-content">
<figure class="wp-block-image"><img src="https://i1.wp.com/media.criticalhit.net//2020/12/Dear-Santa.jpg?w=850&#038;ssl=1" alt="Dear-Santa" title="Dear-Santa" data-recalc-dims="1" /></figure>
<p>Tis’ the season, in which people all over the world attempt to buy the love of their family with the most expensive of gifts. When you think about it, the whole process of buying gifts for Xmas is nothing short of mad unless you’re rich. You’re dropping a massive chunk of coin once a year, leaving yourself near the point of bankruptcy all so that you can receive in return something that you probably don’t want.</p>
<p>Anyway, if you’ve got a child/man-child in the house then they probably want the hottest item of this merrily maniacal season: A PlayStation 5 console. Good luck though! Besides the fact that it has been sold out, procuring a PS5 when it’s in stock this year involves dealing with armies of bots, filthy scalpers, and preparing your elbows for a bloody war at the few stores that will sell you a console in person.</p>
<p>What’s a fan to do? Why go full Stan and write to Santa of course:</p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Holy shit. 😂 <a href="https://twitter.com/hashtag/SNL?src=hash&amp;ref_src=twsrc%5Etfw" target="_blank" rel="noopener">#SNL</a> <a href="https://t.co/EI0B6JYVfm" target="_blank">pic.twitter.com/EI0B6JYVfm</a></p>&mdash; kayla marie wants a hippo for 🎄 (@maria__giesela) <a href="https://twitter.com/maria__giesela/status/1335461582684483584?ref_src=twsrc%5Etfw" target="_blank" rel="noopener">December 6, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>
<p>Sorry for the lack of YouTube, but there’s nothing I hate more than “The uploader has not made this video available in your country”. If only there was some vast world-spanning information highway service wherein content could be streamed to other devices without the need to show a passport at each border. IF ONLY.</p><div class="bjqdn5fcebfeb90ed9"><div id='div-gpt-ad-1540806613519-0' style='width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540806613519-0'); });
</script>
</div>
<div id='div-gpt-ad-1540807120663-0' tyle='margin:auto; width:320px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540807120663-0'); });
</script>
</div>
</div><style type="text/css">
.bjqdn5fcebfeb90ed9 {
margin: 5px; padding: 0px;
}
@media screen and (min-width: 1201px) {
.bjqdn5fcebfeb90ed9 {
display: block;
}
}
@media screen and (min-width: 993px) and (max-width: 1200px) {
.bjqdn5fcebfeb90ed9 {
display: block;
}
}
@media screen and (min-width: 769px) and (max-width: 992px) {
.bjqdn5fcebfeb90ed9 {
display: block;
}
}
@media screen and (min-width: 768px) and (max-width: 768px) {
.bjqdn5fcebfeb90ed9 {
display: block;
}
}
@media screen and (max-width: 767px) {
.bjqdn5fcebfeb90ed9 {
display: block;
}
}
</style>
<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' width='850' height='479' src='https://www.youtube.com/embed/gOMhN-hfMtY?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-GB&#038;autohide=2&#038;wmode=transparent' allowfullscreen='true' style='border:0;' sandbox='allow-scripts allow-same-origin allow-popups allow-presentation'></iframe></span>
</div></figure>
<p>For those of you unaware or born after 2003, the video above is a parody of Eminem’s “Stan,” and goes the whole ten yards by including a fake Dido, the infamous letter-writing rant from the video, and Jason Bateman in Santa drag. And Elton John, because why not.</p>
<p>including ranting letters, fake Dido, and Elton John&#8230; okay, maybe some of this wasn’t in the original song. Like the PS5! It’s all Stu, played by Pete Davidson, wants from Santa, played by guest star Jason Bateman. He just wants to play <a href="https://kotaku.com/assassins-creed-valhalla-the-kotaku-review-1845615415" target="_blank" rel="noopener"><em>Assassin’s Creed: Valhalla.</em></a></p>
<p>Last Updated: <span class="updated">December 7, 2020</span></p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-1116745" class="share-twitter sd-button share-icon" href="https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-1116745" class="share-facebook sd-button share-icon" href="https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-end"></li></ul></div></div></div>
</div>
<footer>
<div class="bdaia-post-sharing bdaia-post-sharing-bottom">
<ul>
<li class="facebook">
<a title="facebook" onClick="window.open('http://www.facebook.com/sharer.php?u=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/">
<span class="bdaia-io bdaia-io-facebook"></span>
<span>Share on Facebook</span>
</a>
</li>
<li class="twitter">
<a title="twitter" onClick="window.open('http://twitter.com/share?url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/&amp;text=Watch%20a%20Santa%20Stan%20beg%20for%20a%20PS5%20in%20this%20hilarious%20SNL%20sketch','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/&amp;text=Watch%20a%20Santa%20Stan%20beg%20for%20a%20PS5%20in%20this%20hilarious%20SNL%20sketch">
<span class="bdaia-io bdaia-io-twitter"></span>
<span>Share on Twitter</span>
</a>
</li>
<li class="google">
<a title="google" onClick="window.open('https://plus.google.com/share?url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/">
<span class="bdaia-io bdaia-io-google-plus"></span>
<span>Share on Google+</span>
</a>
</li>
<li class="reddit">
<a title="reddit" onClick="window.open('http://reddit.com/submit?url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/&amp;title=Watch%20a%20Santa%20Stan%20beg%20for%20a%20PS5%20in%20this%20hilarious%20SNL%20sketch','Reddit','width=617,height=514,left='+(screen.availWidth/2-308)+',top='+(screen.availHeight/2-257)+''); return false;" href="https://reddit.com/submit?url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/&amp;title=Watch%20a%20Santa%20Stan%20beg%20for%20a%20PS5%20in%20this%20hilarious%20SNL%20sketch">
<span class="bdaia-io bdaia-io-reddit"></span>
<span>Share on Reddit</span>
</a>
</li>
<li class="pinterest">
<a title="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fwatch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch%2F&amp;description=Watch+a+Santa+Stan+beg+for+a+PS5+in+this+hilarious+SNL+sketch&amp;media=https%3A%2F%2Fi1.wp.com%2Fmedia.criticalhit.net%2F%2F2020%2F12%2FDear-Santa.jpg%3Ffit%3D850%252C478%26ssl%3D1">
<span class="bdaia-io bdaia-io-social-pinterest"></span>
<span>Share on Pinterest</span>
</a>
</li>
<li class="linkedin">
<a title="linkedin" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/">
<span class="bdaia-io bdaia-io-linkedin2"></span>
<span>Share on Linkedin</span>
</a>
</li>
<li class="tumblr">
<a title="tumblr" onClick="window.open('http://www.tumblr.com/share/link?url=www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/&amp;name=Watch%20a%20Santa%20Stan%20beg%20for%20a%20PS5%20in%20this%20hilarious%20SNL%20sketch','Tumblr','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.tumblr.com/share/link?url=www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/&amp;name=Watch%20a%20Santa%20Stan%20beg%20for%20a%20PS5%20in%20this%20hilarious%20SNL%20sketch">
<span class="bdaia-io bdaia-io-tumblr"></span>
<span>Share on Tumblr</span>
</a>
</li>
<li class="whatsapp">
<a href="whatsapp://send?text=Besides+the+fact+that+it+has+been+sold+out%2C+procuring+a+PS5+when+it%E2%80%99s+in+stock+this+year+involves+dealing+with+armies+of+bots%2C+filthy+scalpers+and+preparing+your+elbows+for+a+bloody+war+at+the+few+stores+that+will+sell+you+a+console+in+person.+What%E2%80%99s+a+fan+to+do%3F+Why+go+full+Stan+and+write+to+Santa+of+course.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fwatch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch%2F"><span class="bdaia-io bdaia-io-whatsapp"></span></a> </li>
<li class="telegram">
<a href="tg://msg?text=Besides+the+fact+that+it+has+been+sold+out%2C+procuring+a+PS5+when+it%E2%80%99s+in+stock+this+year+involves+dealing+with+armies+of+bots%2C+filthy+scalpers+and+preparing+your+elbows+for+a+bloody+war+at+the+few+stores+that+will+sell+you+a+console+in+person.+What%E2%80%99s+a+fan+to+do%3F+Why+go+full+Stan+and+write+to+Santa+of+course.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fwatch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch%2F"><span class="bdaia-io bdaia-io-telegram"></span></a> </li>
</ul>
</div>

<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'alternating-thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>
<div class="bdaia-post-next-prev">
<div class="bdaia-post-prev-post">
<a href="https://www.criticalhit.net/entertainment/monster-hunter-pulled-from-chinese-cinemas-over-racist-joke/" rel="prev"><span>Previous article</span> Monster Hunter pulled from Chinese cinemas over &#8220;racist&#8221; joke</a> </div>
<div class="bdaia-post-next-post">
<a href="https://www.criticalhit.net/entertainment/oscar-isaac-to-star-in-metal-gear-solid-live-action-film/" rel="next"><span>Next article</span> Oscar Isaac to star in Metal Gear Solid live-action film</a> </div>
</div>

<div class="bdaia-author-box">
<div class="authorBlock-avatar">
<a href="https://www.criticalhit.net/author/dbonthuys/"><img src="https://secure.gravatar.com/avatar/f29c2b82775c8feedeae3045ca4a11c8?s=150&#038;d=mm&#038;r=pg" width="150" height="150" alt="Avatar" class="avatar avatar-150 wp-user-avatar wp-user-avatar-150 photo avatar-default" /></a>
</div>
<div class="authorBlock-header">
<h3 class="authorBlock-header-title">
<a href="https://www.criticalhit.net/author/dbonthuys/">Darryn Bonthuys </h3>
<p class="authorBlock-header-bio">
Word-slinger at Critical Hit. Inventor of the macho Swiss gym chocolate known as Testoblerone. That's...that's about it really. </p>
<div class="authorBlock-meta bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-32">
</div>
</div>
</div>
</div>
 </footer>
<span style=display:none itemprop=author itemscope itemtype="https://schema.org/Person">
<meta itemprop=name content="Darryn Bonthuys">
</span>
<meta itemprop=interactionCount content="UserComments:1">
<meta itemprop=datePublished content="2020-12-07T09:00:00+00:00">
<meta itemprop=dateModified content="2020-12-07T09:00:00+00:00">
<meta itemscope itemprop=mainEntityOfPage itemtype="https://schema.org/WebPage" itemid="https://www.criticalhit.net/gaming/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch/">
<span style=display:none itemprop=publisher itemscope itemtype="https://schema.org/Organization">
<span style=display:none itemprop=logo itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-Main.png">
</span>
<meta itemprop=name content="Critical Hit">
</span>
<meta itemprop=headline content="Watch a Santa Stan beg for a PS5 in this hilarious SNL sketch">
<span style=display:none itemprop=image itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop=url content="https://i1.wp.com/media.criticalhit.net//2020/12/Dear-Santa.jpg?fit=850%2C478&#038;ssl=1">
<meta itemprop=width content=1240>
<meta itemprop=height content=540>
</span>
</article>
<div id="disqus_thread"></div>
<section id="bdCheckAlso" class="bdCheckAlso-right">
<h4 class="block-title">
<span>Check Also</span>
<a href="#" id="check-also-close"><span class="bdaia-io bdaia-io-cross"></span></a>
</h4>
<div class="check-also-post">
<figure class="check-also-thumb" style="background-image:url(https://i0.wp.com/media.criticalhit.net//2020/12/Blast-from-the-past.jpg?resize=320%2C220&ssl=1);"></figure>
<h2 class="post-title"><a href="https://www.criticalhit.net/gaming/critical-hit-game-awards-2020-best-blast-from-the-past/" rel="bookmark">Critical Hit Game Awards 2020: Best blast from the past</a></h2>
<p>Never underestimate the power of nostalgia. While 2020 has been a fantastic year that has &#8230;</p>
</div>
</section>
</div>
</div>
<div class="bd-sidebar theia_sticky">
<div class="cfix"></div>
<div class="theiaStickySidebar">
<div id="bdaia-widget-e3-2" class="widget bdaia-widget bdaia-widget-e3 e3-trans"><div class="widget-inner">
<div class="e3-inner"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/300x250ATF', [300, 250]).display();
</script></div></div>
</div><div id="bdaia-social-links-3" class="widget bdaia-widget bdaia-social-links">
<h4 class="block-title"><span>Social</span></h4>
<div class="widget-inner">
<div class="widget-social-links bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class="none bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class="none bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class="none bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class="none bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class="none bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</div><div id="bdaia-widget-box6-2" class="widget bdaia-widget bdaia-box6"><h4 class="block-title"><span>Latest Reviews</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb6 bdaia-wb-idTmMOz bdaia-ajax-pagination-next_prev" data-box_nu="wb6" data-box_id="bdaia-wb-idTmMOz" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="5" data-tag_slug="" data-cat_uid="58" data-cat_uids="" data-max_nu="680" data-total_posts_num="3398" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="true" data-date_meta="true" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-bigsh bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/fitness-boxing-2-rhythm-exercise-review-glass-flaw/" class="bdaia-text-gradient">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="Fitness Boxing 2: Rhythm &amp; Exercise Review &ndash; Glass flaw 1" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2020/12/Fitness-Boxing-2-4.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1116954" data-permalink="https://www.criticalhit.net/gaming/fitness-boxing-2-rhythm-exercise-review-glass-flaw/attachment/fitness-boxing-2-4-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/12/Fitness-Boxing-2-4.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Fitness-Boxing-2-4.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/12/Fitness-Boxing-2-4.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/12/Fitness-Boxing-2-4.jpg?fit=850%2C478&amp;ssl=1" title="Fitness Boxing 2: Rhythm &amp; Exercise Review &ndash; Glass flaw 1"> </a>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/fitness-boxing-2-rhythm-exercise-review-glass-flaw/"><span>Fitness Boxing 2: Rhythm &amp; Exercise Review &ndash; Glass flaw</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">12 hours ago</span></div>
</footer>
</div>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/asus-tuf-vg27w-monitor-review-sharp-but-not-exactly-very-bright/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Asus TUF VG27W Monitor Review &ndash; Sharp but not exactly very bright 2" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2020/12/Asus-feature-header.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1116079" data-permalink="https://www.criticalhit.net/gaming/asus-tuf-vg27w-monitor-review-sharp-but-not-exactly-very-bright/attachment/asus-feature-header-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/12/Asus-feature-header.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Asus-feature-header.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/12/Asus-feature-header.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/12/Asus-feature-header.jpg?fit=850%2C478&amp;ssl=1" title="Asus TUF VG27W Monitor Review &ndash; Sharp but not exactly very bright 2"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/asus-tuf-vg27w-monitor-review-sharp-but-not-exactly-very-bright/"><span>Asus TUF VG27W Monitor Review &ndash; Sharp but not exactly very bright</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">4 days ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/cook-serve-delicious-3-review-the-food-prep-sim-thats-what-you-make-of-it/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Cook, Serve, Delicious! 3?! review – The food prep sim that’s what you make of it 3" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2020/12/cookservedelic_850.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1115950" data-permalink="https://www.criticalhit.net/cookservedelic_850/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/12/cookservedelic_850.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="cookservedelic_850" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/12/cookservedelic_850.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/12/cookservedelic_850.jpg?fit=850%2C478&amp;ssl=1" title="Cook, Serve, Delicious! 3?! review – The food prep sim that’s what you make of it 3"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/cook-serve-delicious-3-review-the-food-prep-sim-thats-what-you-make-of-it/"><span>Cook, Serve, Delicious! 3?! review – The food prep sim that’s what you make of it</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/pfangirl/" title="Posts by Noelle Adams" rel="author">Noelle Adams</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">4 days ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/chronos-before-the-ashes-review-pasture-prime/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Chronos: Before the Ashes Review &ndash; Pasture prime 4" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2020/12/Chronos_Before_the_Ashes_3.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1115855" data-permalink="https://www.criticalhit.net/gaming/chronos-before-the-ashes-review-pasture-prime/attachment/chronos_before_the_ashes_3-jpg/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/12/Chronos_Before_the_Ashes_3.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Chronos_Before_the_Ashes_3.jpg" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/12/Chronos_Before_the_Ashes_3.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/12/Chronos_Before_the_Ashes_3.jpg?fit=850%2C478&amp;ssl=1" title="Chronos: Before the Ashes Review &ndash; Pasture prime 4"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/chronos-before-the-ashes-review-pasture-prime/"><span>Chronos: Before the Ashes Review &ndash; Pasture prime</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">5 days ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/logitech-g-pro-x-superlight-review-zero-resistance-is-not-futile/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Logitech G Pro X Superlight Review &ndash; Zero resistance is not futile 5" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2020/12/Superlight-7.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1115583" data-permalink="https://www.criticalhit.net/gaming/logitech-g-pro-x-superlight-review-zero-resistance-is-not-futile/attachment/superlight-7-jpg/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/12/Superlight-7.jpg?fit=849%2C478&amp;ssl=1" data-orig-size="849,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Superlight-7.jpg" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/12/Superlight-7.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/12/Superlight-7.jpg?fit=849%2C478&amp;ssl=1" title="Logitech G Pro X Superlight Review &ndash; Zero resistance is not futile 5"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/logitech-g-pro-x-superlight-review-zero-resistance-is-not-futile/"><span>Logitech G Pro X Superlight Review &ndash; Zero resistance is not futile</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">7 days ago</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-idTmMOz .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'TmMOz', 'next' );
						});
						jQuery('.bdaia-wb-idTmMOz .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'TmMOz', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-e3-11" class="widget bdaia-widget bdaia-widget-e3 "><h4 class="block-title"><span>Advert</span></h4>
<div class="widget-inner">
<div class="e3-inner"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/300600mid', [300, 600]).display();
</script></div></div>
</div><div id="bdaia-widget-html-4" class="widget bdaia-widget bdaia-widget-html "><h4 class="block-title"><span>Recent Comments</span></h4>
<div class="widget-inner">
<div id="recentcomments" class="dsq-widget"><script type="text/javascript" src="https://critical-hit-net.disqus.com/recent_comments_widget.js?num_items=5&hide_avatars=1&avatar_size=0&excerpt_length=200"></script></div><a href="https://disqus.com/">Powered by Disqus</a></div>
</div><div id="bdaia-widget-box2-4" class="widget bdaia-widget bdaia-box2"><h4 class="block-title"><span>Latest Posts </span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb2 bdaia-wb-idn4T26 bdaia-ajax-pagination-next_prev" data-box_nu="wb2" data-box_id="bdaia-wb-idn4T26" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="5" data-tag_slug="" data-cat_uid="" data-cat_uids="" data-max_nu="12773" data-total_posts_num="63864" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-big bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/technology/apple-now-allowing-developers-to-share-in-app-purchases-with-their-families/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="Apple now allowing developers to share in-app purchases with their families 6" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2020/12/Share_new_subscriptions_toggle.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1116921" data-permalink="https://www.criticalhit.net/technology/apple-now-allowing-developers-to-share-in-app-purchases-with-their-families/attachment/share_new_subscriptions_toggle/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/12/Share_new_subscriptions_toggle.jpg?fit=800%2C457&amp;ssl=1" data-orig-size="800,457" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1568033714&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Share_new_subscriptions_toggle" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/12/Share_new_subscriptions_toggle.jpg?fit=300%2C171&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/12/Share_new_subscriptions_toggle.jpg?fit=800%2C457&amp;ssl=1" title="Apple now allowing developers to share in-app purchases with their families 6"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/technology/apple-now-allowing-developers-to-share-in-app-purchases-with-their-families/"><span>Apple now allowing developers to share in-app purchases with their families</span></a></h3>
</header>
<footer>
</footer>
<p class="block-exb">While there are many great apps to use on mobile devices, nothing beats a program that you can share and use with your family members. Especially if you’re using one with in-app purchases or a subscription that you can then pass around rather than repurchase services across multiple devices to get the same experience.</p>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-7-december-2020/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Best comic book covers of the week - 7 December 2020 7" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2020/12/BCBC-December-07.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1117008" data-permalink="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-7-december-2020/attachment/bcbc-december-07/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/12/BCBC-December-07.jpg?fit=850%2C479&amp;ssl=1" data-orig-size="850,479" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BCBC-December-07" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/12/BCBC-December-07.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/12/BCBC-December-07.jpg?fit=850%2C479&amp;ssl=1" title="Best comic book covers of the week - 7 December 2020 7"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-7-december-2020/"><span>Best comic book covers of the week &#8211; 7 December 2020</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/liam-neeson-takes-a-young-boy-under-his-wing-in-the-action-thriller-the-marksman/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Liam Neeson takes a young boy under his wing in the action thriller The Marksman 8" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2020/12/The-Marksman-2.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1116930" data-permalink="https://www.criticalhit.net/entertainment/liam-neeson-takes-a-young-boy-under-his-wing-in-the-action-thriller-the-marksman/attachment/the-marksman-2/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/12/The-Marksman-2.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="The Marksman 2" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/12/The-Marksman-2.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/12/The-Marksman-2.jpg?fit=850%2C478&amp;ssl=1" title="Liam Neeson takes a young boy under his wing in the action thriller The Marksman 8"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/liam-neeson-takes-a-young-boy-under-his-wing-in-the-action-thriller-the-marksman/"><span>Liam Neeson takes a young boy under his wing in the action thriller The Marksman</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/epic-cancels-all-in-person-fortnite-events-well-into-2021/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Fortnite events will be digital-only in 2021 9" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2020/12/fortnite-season-4-ftr_1agcwe7t3405x13mi09bjlruql.png?resize=104%2C74&amp;ssl=1" data-attachment-id="1116753" data-permalink="https://www.criticalhit.net/gaming/epic-cancels-all-in-person-fortnite-events-well-into-2021/attachment/fortnite-season-4-ftr_1agcwe7t3405x13mi09bjlruql-png/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/12/fortnite-season-4-ftr_1agcwe7t3405x13mi09bjlruql.png?fit=918%2C516&amp;ssl=1" data-orig-size="918,516" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="fortnite-season-4-ftr_1agcwe7t3405x13mi09bjlruql.png" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/12/fortnite-season-4-ftr_1agcwe7t3405x13mi09bjlruql.png?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/12/fortnite-season-4-ftr_1agcwe7t3405x13mi09bjlruql.png?fit=850%2C478&amp;ssl=1" title="Fortnite events will be digital-only in 2021 9"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/epic-cancels-all-in-person-fortnite-events-well-into-2021/"><span>Fortnite events will be digital-only in 2021</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/warner-bros-developing-a-female-led-movie-adaptation-of-dc-comics-hero-plastic-man/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Warner Bros. developing a female-led movie adaptation of DC Comics hero Plastic Man 10" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2020/12/plastic-man-dc.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1116915" data-permalink="https://www.criticalhit.net/entertainment/warner-bros-developing-a-female-led-movie-adaptation-of-dc-comics-hero-plastic-man/attachment/plastic-man-dc/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/12/plastic-man-dc.jpg?fit=850%2C567&amp;ssl=1" data-orig-size="850,567" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="plastic-man-dc" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/12/plastic-man-dc.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/12/plastic-man-dc.jpg?fit=850%2C567&amp;ssl=1" title="Warner Bros. developing a female-led movie adaptation of DC Comics hero Plastic Man 10"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/warner-bros-developing-a-female-led-movie-adaptation-of-dc-comics-hero-plastic-man/"><span>Warner Bros. developing a female-led movie adaptation of DC Comics hero Plastic Man</span></a></h3>
</header>
<footer>
</footer>
 </div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-idn4T26 .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'n4T26', 'next' );
						});
						jQuery('.bdaia-wb-idn4T26 .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'n4T26', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-box2-2" class="widget bdaia-widget bdaia-box2"><h4 class="block-title"><span>Competitions </span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb2 bdaia-wb-idYhZQi bdaia-ajax-pagination-" data-box_nu="wb2" data-box_id="bdaia-wb-idYhZQi" data-paged="1" data-sort_order="" data-ajax_pagination="" data-num_posts="4" data-tag_slug="" data-cat_uid="34345" data-cat_uids="" data-max_nu="60" data-total_posts_num="238" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="true" data-review="">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-big bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/win-a-copy-of-devil-may-cry-5-special-edition/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="Win a copy of Devil May Cry 5: Special Edition! 11" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2019/12/Devil-May-Cry-V.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1032800" data-permalink="https://www.criticalhit.net/gaming/the-critical-hit-best-of-the-year-awards-2019-game-of-the-year/attachment/devil-may-cry-v-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2019/12/Devil-May-Cry-V.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Devil-May-Cry-V.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2019/12/Devil-May-Cry-V.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2019/12/Devil-May-Cry-V.jpg?fit=850%2C478&amp;ssl=1" title="Win a copy of Devil May Cry 5: Special Edition! 11"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/win-a-copy-of-devil-may-cry-5-special-edition/"><span>Win a copy of Devil May Cry 5: Special Edition!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">5 days ago</span></div>
</footer>
<p class="block-exb">One of 2019’s best video games is now one of the best of 2020. Capcom hit the jackpot with Devil May Cry 5 last year, and with a new generation of consoles having landed, it’s heralding in that age of bleeding edge hardware with an S-Rank upgrade to the original game. Devil May Cry 5 with new graphical enhancements and the inclusion of fan-favourite bad brother Vergil? That’s just makes for a brilliant game.</p>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/competitions/win-one-of-five-cadbury-tastetheaction-football-hampers/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Win one of five Cadbury #TasteTheAction football hampers! 12" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2020/10/Cadbury-1.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1105975" data-permalink="https://www.criticalhit.net/competitions/win-one-of-five-cadbury-tastetheaction-football-hampers/attachment/cadbury-1-jpg/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/10/Cadbury-1.jpg?fit=850%2C638&amp;ssl=1" data-orig-size="850,638" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Cadbury-1.jpg" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/10/Cadbury-1.jpg?fit=300%2C225&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/10/Cadbury-1.jpg?fit=850%2C638&amp;ssl=1" title="Win one of five Cadbury #TasteTheAction football hampers! 12"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/competitions/win-one-of-five-cadbury-tastetheaction-football-hampers/"><span>Win one of five Cadbury #TasteTheAction football hampers!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">October 20, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/win-minecraft-dungeons-on-ps4/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Win Minecraft Dungeons on PS4! 13" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2020/09/Minecraft-Dungeons.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1101004" data-permalink="https://www.criticalhit.net/gaming/win-minecraft-dungeons-on-ps4/attachment/minecraft-dungeons-jpg/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/09/Minecraft-Dungeons.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Minecraft-Dungeons.jpg" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/09/Minecraft-Dungeons.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/09/Minecraft-Dungeons.jpg?fit=850%2C478&amp;ssl=1" title="Win Minecraft Dungeons on PS4! 13"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/win-minecraft-dungeons-on-ps4/"><span>Win Minecraft Dungeons on PS4!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">September 29, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/win-a-marvels-avengers-ps4-collectors-edition/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Win a Marvel&rsquo;s Avengers PS4 collector&rsquo;s edition! 14" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2020/09/Avengers.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1097733" data-permalink="https://www.criticalhit.net/gaming/win-a-marvels-avengers-ps4-collectors-edition/attachment/avengers-jpg-3/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/09/Avengers.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Avengers.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/09/Avengers.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/09/Avengers.jpg?fit=850%2C478&amp;ssl=1" title="Win a Marvel&rsquo;s Avengers PS4 collector&rsquo;s edition! 14"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/win-a-marvels-avengers-ps4-collectors-edition/"><span>Win a Marvel&rsquo;s Avengers PS4 collector&rsquo;s edition!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">September 16, 2020</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
</div>
<style type="text/css">#bdaia-widget-box2-2 .entry-title a:hover{color:#e90d8c !important;}#bdaia-widget-box2-2 .sk-circle .sk-child:before{background:#e90d8c !important;}#bdaia-widget-box2-2 .bdaia-wb-mb-inner{background:#e90d8c !important;}#bdaia-widget-box2-2 h4.block-title:before{background:#e90d8c !important;}#bdaia-widget-box2-2 h4.block-title span, #bdaia-widget-box2-2 h4.block-title a{color:#e90d8c !important;}</style></div></div><div id="bdaia-widget-box3-2" class="widget bdaia-widget bdaia-box3"><h4 class="block-title"><span>Features</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb3 bdaia-wb-idQJSeR bdaia-ajax-pagination-next_prev" data-box_nu="wb3" data-box_id="bdaia-wb-idQJSeR" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="4" data-tag_slug="" data-cat_uid="48449" data-cat_uids="" data-max_nu="306" data-total_posts_num="1222" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="" data-review="">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-box-row">
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/fitness-boxing-2-rhythm-exercise-review-glass-flaw/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="Fitness Boxing 2: Rhythm &amp; Exercise Review &ndash; Glass flaw 15" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2020/12/Fitness-Boxing-2-4.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1116954" data-permalink="https://www.criticalhit.net/gaming/fitness-boxing-2-rhythm-exercise-review-glass-flaw/attachment/fitness-boxing-2-4-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/12/Fitness-Boxing-2-4.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Fitness-Boxing-2-4.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/12/Fitness-Boxing-2-4.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/12/Fitness-Boxing-2-4.jpg?fit=850%2C478&amp;ssl=1" title="Fitness Boxing 2: Rhythm &amp; Exercise Review &ndash; Glass flaw 15"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/fitness-boxing-2-rhythm-exercise-review-glass-flaw/"><span>Fitness Boxing 2: Rhythm &amp; Exercise Review &ndash; Glass flaw</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/critical-hit-game-awards-2020-best-art-direction/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="Critical Hit Game Awards 2020: Best Art Direction 16" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2020/12/Crit-best-art-direction.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1116450" data-permalink="https://www.criticalhit.net/gaming/critical-hit-game-awards-2020-best-art-direction/attachment/crit-best-art-direction-jpg/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/12/Crit-best-art-direction.jpg?fit=849%2C478&amp;ssl=1" data-orig-size="849,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Crit-best-art-direction.jpg" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/12/Crit-best-art-direction.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/12/Crit-best-art-direction.jpg?fit=849%2C478&amp;ssl=1" title="Critical Hit Game Awards 2020: Best Art Direction 16"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/critical-hit-game-awards-2020-best-art-direction/"><span>Critical Hit Game Awards 2020: Best Art Direction</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
<div class="bdaia-box-row">
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/asus-tuf-vg27w-monitor-review-sharp-but-not-exactly-very-bright/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="Asus TUF VG27W Monitor Review &ndash; Sharp but not exactly very bright 17" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2020/12/Asus-feature-header.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1116079" data-permalink="https://www.criticalhit.net/gaming/asus-tuf-vg27w-monitor-review-sharp-but-not-exactly-very-bright/attachment/asus-feature-header-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/12/Asus-feature-header.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Asus-feature-header.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/12/Asus-feature-header.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/12/Asus-feature-header.jpg?fit=850%2C478&amp;ssl=1" title="Asus TUF VG27W Monitor Review &ndash; Sharp but not exactly very bright 17"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/asus-tuf-vg27w-monitor-review-sharp-but-not-exactly-very-bright/"><span>Asus TUF VG27W Monitor Review &ndash; Sharp but not exactly very bright</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/critical-hit-awards-2020-best-action-game/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="Critical Hit Game Awards 2020 &ndash; Best Action Game 18" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2020/12/Best-Action-Game-2020.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1116150" data-permalink="https://www.criticalhit.net/gaming/critical-hit-awards-2020-best-action-game/attachment/best-action-game-2020-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/12/Best-Action-Game-2020.jpg?fit=849%2C478&amp;ssl=1" data-orig-size="849,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Best-Action-Game-2020.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/12/Best-Action-Game-2020.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/12/Best-Action-Game-2020.jpg?fit=849%2C478&amp;ssl=1" title="Critical Hit Game Awards 2020 &ndash; Best Action Game 18"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/critical-hit-awards-2020-best-action-game/"><span>Critical Hit Game Awards 2020 &ndash; Best Action Game</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-idQJSeR .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'QJSeR', 'next' );
						});
						jQuery('.bdaia-wb-idQJSeR .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'QJSeR', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-e3-13" class="widget bdaia-widget bdaia-widget-e3 "><div class="widget-inner">
<div class="e3-inner"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/CH300BTF', [300, 250]).display();
</script></div></div>
</div><div id="bdaia-widget-box6-6" class="widget bdaia-widget bdaia-box6"><h4 class="block-title"><span>Most Recent</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb6 bdaia-wb-idgg4xh bdaia-ajax-pagination-load_more" data-box_nu="wb6" data-box_id="bdaia-wb-idgg4xh" data-paged="1" data-sort_order="" data-ajax_pagination="load_more" data-num_posts="3" data-tag_slug="" data-cat_uid="" data-cat_uids="" data-max_nu="21288" data-total_posts_num="63864" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="true" data-date_meta="true" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-bigsh bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/technology/apple-now-allowing-developers-to-share-in-app-purchases-with-their-families/" class="bdaia-text-gradient">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="Apple now allowing developers to share in-app purchases with their families 19" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2020/12/Share_new_subscriptions_toggle.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1116921" data-permalink="https://www.criticalhit.net/technology/apple-now-allowing-developers-to-share-in-app-purchases-with-their-families/attachment/share_new_subscriptions_toggle/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/12/Share_new_subscriptions_toggle.jpg?fit=800%2C457&amp;ssl=1" data-orig-size="800,457" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1568033714&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Share_new_subscriptions_toggle" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/12/Share_new_subscriptions_toggle.jpg?fit=300%2C171&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/12/Share_new_subscriptions_toggle.jpg?fit=800%2C457&amp;ssl=1" title="Apple now allowing developers to share in-app purchases with their families 19"> </a>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/technology/apple-now-allowing-developers-to-share-in-app-purchases-with-their-families/"><span>Apple now allowing developers to share in-app purchases with their families</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/craigrisi/" title="Posts by Craig Risi" rel="author">Craig Risi</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">9 hours ago</span></div>
</footer>
</div>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-7-december-2020/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Best comic book covers of the week - 7 December 2020 20" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2020/12/BCBC-December-07.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1117008" data-permalink="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-7-december-2020/attachment/bcbc-december-07/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/12/BCBC-December-07.jpg?fit=850%2C479&amp;ssl=1" data-orig-size="850,479" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BCBC-December-07" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/12/BCBC-December-07.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/12/BCBC-December-07.jpg?fit=850%2C479&amp;ssl=1" title="Best comic book covers of the week - 7 December 2020 20"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-7-december-2020/"><span>Best comic book covers of the week &#8211; 7 December 2020</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">10 hours ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/liam-neeson-takes-a-young-boy-under-his-wing-in-the-action-thriller-the-marksman/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Liam Neeson takes a young boy under his wing in the action thriller The Marksman 21" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2020/12/The-Marksman-2.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1116930" data-permalink="https://www.criticalhit.net/entertainment/liam-neeson-takes-a-young-boy-under-his-wing-in-the-action-thriller-the-marksman/attachment/the-marksman-2/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/12/The-Marksman-2.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="The Marksman 2" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/12/The-Marksman-2.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/12/The-Marksman-2.jpg?fit=850%2C478&amp;ssl=1" title="Liam Neeson takes a young boy under his wing in the action thriller The Marksman 21"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/liam-neeson-takes-a-young-boy-under-his-wing-in-the-action-thriller-the-marksman/"><span>Liam Neeson takes a young boy under his wing in the action thriller The Marksman</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/trevor/" title="Posts by Trevor Davies" rel="author">Trevor Davies</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">10 hours ago</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('#bdaia-more-gg4xh .bdaia-wb-mb-inner').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'gg4xh', '' );
						});
																	});
				</script>
<div class="bdaia-wb-more-btn" id="bdaia-more-gg4xh">
<div class="bdaia-wb-mb-inner">
Load more<span class="bdaia-io bdaia-io-angle-down"></span>
</div>
</div>
</div>
<style type="text/css">#bdaia-widget-box6-6 .entry-title a:hover{color:#E6A602 !important;}#bdaia-widget-box6-6 .sk-circle .sk-child:before{background:#E6A602 !important;}#bdaia-widget-box6-6 .bdaia-wb-mb-inner{background:#E6A602 !important;}#bdaia-widget-box6-6 h4.block-title:before{background:#E6A602 !important;}#bdaia-widget-box6-6 h4.block-title span, #bdaia-widget-box6-6 h4.block-title a{color:#E6A602 !important;}</style></div></div> </div>
</div>
</div>
</div>
<div class="bdaia-footer-e3-desktop"><div class="bdaia-e3-container"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/728bottom', [728, 90]).display();
</script>
</div></div>
<div class="bdaia-footer">
<div class="bdaia-footer-widgets">
<div class="bd-container">
<div class="bdaia-footer-widgets-area footer-col-three">
<div id="footer-first" class="footer-widget-inner">
<div id="bdaia-widget-html-2" class="widget bdaia-widget bdaia-widget-html e3-trans"><h4 class="block-title"><span>About US</span></h4>
<div class="widget-inner">
<p>
<img src="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-White-1.png" alt="" />
</p>
<p style="margin-top:25px;">
Critical Hit is built on the idea that we are more than one thing. Are you a hardcore gamer who also enjoys a night out at the movies? Perhaps you’re a professional cosplayer who is searching for the perfect burger, or maybe you’re just interested in high-end tech and Netflix binging. Covering gaming, entertainment, tech and geek, Critical Hit offers information and critique from a staff of diverse, knowledgeable and fiercely opinionated writers. </p>
</div>
</div><div id="bdaia-social-links-6" class="widget bdaia-widget bdaia-social-links">
<h4 class="block-title"><span>Follow Us</span></h4>
<div class="widget-inner">
<div class="widget-social-links bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class="none bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class="none bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class="none bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class="none bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class="none bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</div> </div>
<div id="footer-second" class="footer-widget-inner">
<div id="bdaia-widget-box1-2" class="widget bdaia-widget bdaia-box1"><h4 class="block-title"><span>Read This</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb1 bdaia-wb-idtyiRz bdaia-ajax-pagination-" data-box_nu="wb1" data-box_id="bdaia-wb-idtyiRz" data-paged="1" data-sort_order="random_7_day" data-ajax_pagination="" data-num_posts="4" data-tag_slug="" data-cat_uid="" data-cat_uids="" data-max_nu="18" data-total_posts_num="69" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="true" data-date_meta="true" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/monster-hunter-pulled-from-chinese-cinemas-over-racist-joke/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Monster Hunter pulled from Chinese cinemas over &quot;racist&quot; joke 22" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2020/12/MonsterHunter_1.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1116974" data-permalink="https://www.criticalhit.net/entertainment/monster-hunter-pulled-from-chinese-cinemas-over-racist-joke/attachment/tony-jaa-finalizedmilla-jovovich-pending/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/12/MonsterHunter_1.jpg?fit=850%2C568&amp;ssl=1" data-orig-size="850,568" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5&quot;,&quot;credit&quot;:&quot;Photos By: Coco Van Oppens Photo&quot;,&quot;camera&quot;:&quot;X-T2&quot;,&quot;caption&quot;:&quot;Milla Jovovich and Tony Jaa star in Screen Gems and Constantin Films MONSTER HUNTER.&quot;,&quot;created_timestamp&quot;:&quot;1539020891&quot;,&quot;copyright&quot;:&quot;\u00a9CONSTANTIN FILM Produktion Services GmbH&quot;,&quot;focal_length&quot;:&quot;80.4&quot;,&quot;iso&quot;:&quot;320&quot;,&quot;shutter_speed&quot;:&quot;0.000625&quot;,&quot;title&quot;:&quot;Tony Jaa (Finalized);Milla Jovovich (Pending)&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="MonsterHunter_1" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/12/MonsterHunter_1.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/12/MonsterHunter_1.jpg?fit=850%2C568&amp;ssl=1" title="Monster Hunter pulled from Chinese cinemas over &quot;racist&quot; joke 22"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/monster-hunter-pulled-from-chinese-cinemas-over-racist-joke/"><span>Monster Hunter pulled from Chinese cinemas over &#8220;racist&#8221; joke</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/reaver/" title="Posts by Kervyn Cloete" rel="author">Kervyn Cloete</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">18 hours ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/oscar-isaac-to-star-in-metal-gear-solid-live-action-film/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Oscar Isaac to star in Metal Gear Solid live-action film 23" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2020/12/OscarIsaac_MetalGearSolid_1.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1116773" data-permalink="https://www.criticalhit.net/entertainment/oscar-isaac-to-star-in-metal-gear-solid-live-action-film/attachment/oscarisaac_metalgearsolid_1/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/12/OscarIsaac_MetalGearSolid_1.jpg?fit=850%2C493&amp;ssl=1" data-orig-size="850,493" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="OscarIsaac_MetalGearSolid_1" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/12/OscarIsaac_MetalGearSolid_1.jpg?fit=300%2C174&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/12/OscarIsaac_MetalGearSolid_1.jpg?fit=850%2C493&amp;ssl=1" title="Oscar Isaac to star in Metal Gear Solid live-action film 23"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/oscar-isaac-to-star-in-metal-gear-solid-live-action-film/"><span>Oscar Isaac to star in Metal Gear Solid live-action film</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/reaver/" title="Posts by Kervyn Cloete" rel="author">Kervyn Cloete</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">16 hours ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/peter-dinklage-to-star-in-a-toxic-avenger-remake-and-no-this-isnt-a-joke/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Peter Dinklage to star in a Toxic Avenger remake and no this isn&#039;t a joke 24" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2020/12/Peter-Dinklage-ToxicAvenger.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1115803" data-permalink="https://www.criticalhit.net/entertainment/peter-dinklage-to-star-in-a-toxic-avenger-remake-and-no-this-isnt-a-joke/attachment/peter-dinklage-toxicavenger/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/12/Peter-Dinklage-ToxicAvenger.jpg?fit=850%2C484&amp;ssl=1" data-orig-size="850,484" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Peter-Dinklage-ToxicAvenger" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/12/Peter-Dinklage-ToxicAvenger.jpg?fit=300%2C171&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/12/Peter-Dinklage-ToxicAvenger.jpg?fit=850%2C484&amp;ssl=1" title="Peter Dinklage to star in a Toxic Avenger remake and no this isn&#039;t a joke 24"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/peter-dinklage-to-star-in-a-toxic-avenger-remake-and-no-this-isnt-a-joke/"><span>Peter Dinklage to star in a Toxic Avenger remake and no this isn&#8217;t a joke</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/craigrisi/" title="Posts by Craig Risi" rel="author">Craig Risi</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">6 days ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/discovery-home-of-flavourtown-and-shark-week-is-launching-its-own-streaming-service/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Discovery, home of Flavourtown and Shark Week, is launching its own streaming service 25" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2020/12/Guy-fieri.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1115988" data-permalink="https://www.criticalhit.net/entertainment/discovery-home-of-flavourtown-and-shark-week-is-launching-its-own-streaming-service/attachment/guy-fieri/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/12/Guy-fieri.jpg?fit=1200%2C632&amp;ssl=1" data-orig-size="1200,632" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Guy fieri" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/12/Guy-fieri.jpg?fit=300%2C158&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/12/Guy-fieri.jpg?fit=850%2C447&amp;ssl=1" title="Discovery, home of Flavourtown and Shark Week, is launching its own streaming service 25"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/discovery-home-of-flavourtown-and-shark-week-is-launching-its-own-streaming-service/"><span>Discovery, home of Flavourtown and Shark Week, is launching its own streaming service</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/craigrisi/" title="Posts by Craig Risi" rel="author">Craig Risi</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">5 days ago</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
</div>
</div></div> </div>
<div id="footer-third" class="footer-widget-inner">
<div id="bdaia-widget-timeline-2" class="widget bdaia-widget bdaia-widget-timeline">
<h4 class="block-title"><span>Timeline</span></h4>
<div class="widget-inner">
<ul>
<li>
<a href="https://www.criticalhit.net/technology/apple-now-allowing-developers-to-share-in-app-purchases-with-their-families/">
<span class="bdayh-date">9 hours ago</span> <h3>Apple now allowing developers to share in-app purchases with their families</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-7-december-2020/">
<span class="bdayh-date">10 hours ago</span> <h3>Best comic book covers of the week &#8211; 7 December 2020</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/entertainment/liam-neeson-takes-a-young-boy-under-his-wing-in-the-action-thriller-the-marksman/">
<span class="bdayh-date">10 hours ago</span> <h3>Liam Neeson takes a young boy under his wing in the action thriller The Marksman</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/gaming/epic-cancels-all-in-person-fortnite-events-well-into-2021/">
<span class="bdayh-date">11 hours ago</span> <h3>Fortnite events will be digital-only in 2021</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/entertainment/warner-bros-developing-a-female-led-movie-adaptation-of-dc-comics-hero-plastic-man/">
<span class="bdayh-date">12 hours ago</span> <h3>Warner Bros. developing a female-led movie adaptation of DC Comics hero Plastic Man</h3>
</a>
</li>
</ul>
</div>
</div> </div>
</div>
</div>
</div>
<div class="woohoo-footer-top-area" style="background-color:#000000;">
<div class="bd-container">
<div class="woohoo-footer-menu">
<div class="menu-footer-container"><ul id="menu-footer" class="footer-bottom-menu"><li id="menu-item-573845" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-573845"><a href="https://www.criticalhit.net/">Critical Hit</a></li>
<li id="menu-item-574303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574303"><a href="https://www.criticalhit.net/contact/">Contact</a></li>
<li id="menu-item-573839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-573839"><a href="https://www.criticalhit.net/advertise/">Advertise</a></li>
<li id="menu-item-574736" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574736"><a href="https://www.criticalhit.net/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-574795" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574795"><a href="https://www.criticalhit.net/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
</div>
</div>
<div class="bdaia-footer-area" style="background-color:#000000;">
<div class="bd-container">
<div class="bdaia-footer-area-l">
</div>
<div class="bdaia-footer-area-r">
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

<noscript><iframe src=\"https://www.googletagmanager.com/ns.html?id=GTM-5GNB24P\"
height=\"0\" width=\"0\" style=\"display:none;visibility:hidden\"></iframe></noscript>

<script type=\"text/javascript\">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
<div class="gotop" title="Go Top"><span class="bdaia-io bdaia-io-chevron-up"></span></div><div id="reading-position-indicator"></div>
<script>
    </script>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.criticalhit.net\/gaming\/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch\/":1116745};
	</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.2/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"critical-hit-net"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/disqus-comment-system/public/js/comment_count.js' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"1116745 https:\/\/www.criticalhit.net\/?p=1116745","disqusShortname":"critical-hit-net","disqusTitle":"Watch a Santa Stan beg for a PS5 in this hilarious SNL sketch","disqusUrl":"https:\/\/www.criticalhit.net\/gaming\/watch-a-santa-stan-beg-for-a-ps5-in-this-hilarious-snl-sketch\/","postId":"1116745"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/easy-table/js/easy-table-script.js' id='easy_table_script-js'></script>
<script type='text/javascript' id='woohoo-main-js-extra'>
/* <![CDATA[ */
var bd = {"nonce":"64e2472aef","ajaxurl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","is_singular":"1","has_lazy_load":"1","bd_lazyload":"1","mobile_topmenu":"1","sticky_sidebar":"1","all_lightbox":"1","click_to_comments":"","post_reading_position_indicator":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/themes/woohoo-child/js/main.js' id='woohoo-main-js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/themes/woohoo-child/js/js-cookie.js' id='js-cookie-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/themes/woohoo/js/search.js' id='bd-search-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.2/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202050.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.2',blog:'122131268',post:'1116745',tz:'2',srv:'www.criticalhit.net'} ]);
	_stq.push([ 'clickTrackerInit', '122131268', '1116745' ]);
</script>
</body>
</html>