<!DOCTYPE html>
<html lang="en-GB" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#">
<head>
<meta property="fb:pages" content="161755108961" />
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.criticalhit.net/xmlrpc.php" />

<meta name="google-site-verification" content="1vFejJFCT-gTHbz4YXtJrlWGHn4iBz-VmX1lyaF2QQ4" />

<title>First images and plot details for Amazon&#039;s Utopia series revealed</title>
<meta name="description" content="Amazon has some big series on their way and we finally have more details on Utopia." />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/" />
<meta property="og:locale" content="en_GB">
<meta property="og:type" content="article">
<meta property="og:title" content="First images and plot details for Amazon&#039;s Utopia series revealed">
<meta property="og:description" content="Amazon has some big series on their way and we finally have more details on Utopia.">
<meta property="og:url" content="https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/">
<meta property="og:site_name" content="Critical Hit">
<meta property="article:publisher" content="https://facebook.com/criticalhit.net">
<meta property="article:author" content="https://www.facebook.com/craig.risi">
<meta property="article:tag" content="Amazon">
<meta property="article:tag" content="Ashleigh Lathrop">
<meta property="article:tag" content="Dan Byrd">
<meta property="article:tag" content="Desmin Borges">
<meta property="article:tag" content="Gillian Flynn">
<meta property="article:tag" content="Jessica Rothe">
<meta property="article:tag" content="Utopia">
<meta property="article:section" content="Entertainment">
<meta property="og:updated_time" content="2020-07-22T10:42:48+02:00">
<meta property="og:image" content="https://i2.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon-1.jpg">
<meta property="og:image:secure_url" content="https://i2.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon-1.jpg">
<meta property="og:image:width" content="960">
<meta property="og:image:height" content="500">
<meta property="og:image:alt" content="First images and plot details for Amazon&#8217;s Utopia series revealed">
<meta property="og:image:type" content="image/jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="First images and plot details for Amazon&#039;s Utopia series revealed">
<meta name="twitter:description" content="Amazon has some big series on their way and we finally have more details on Utopia.">
<meta name="twitter:site" content="@CriticalHitNet">
<meta name="twitter:creator" content="@RisiCraig">
<meta name="twitter:image" content="https://i2.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon-1.jpg">
<script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@type":"NewsArticle","headline":"First images and plot details for Amazon's Utopia series revealed","description":"Amazon has some big series on their way and we finally have more details on Utopia.","datePublished":"2020-07-22T12:30:00+02:00","dateModified":"2020-07-22T10:42:48+02:00","publisher":{"@type":"Organization","name":"Critical Hit","logo":{"@type":"ImageObject","url":"https:\/\/media.criticalhit.net\/\/2019\/03\/Critical_Hit-Logo-Icon.png"}},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.criticalhit.net\/entertainment\/first-images-and-plot-details-for-amazons-utopia-series-revealed\/"},"author":{"@type":"Person","name":"Craig Risi"},"image":{"@type":"ImageObject","url":"https:\/\/i2.wp.com\/media.criticalhit.net\/\/2020\/07\/utopia-usversion-maincharacters-amazon-1.jpg?fit=960%2C500&ssl=1","width":960,"height":500}}]}</script>

<link rel='dns-prefetch' href='//www.criticalhit.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; Feed" href="https://www.criticalhit.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; Comments Feed" href="https://www.criticalhit.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; First images and plot details for Amazon&#8217;s Utopia series revealed Comments Feed" href="https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.criticalhit.net\/wp-includes\/js\/wp-emoji-release.min.js"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='bdaia_shorty-style-css' href='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='formidable-css' href='https://www.criticalhit.net/wp-content/plugins/formidable/css/formidableforms.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.4.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://c0.wp.com/c/5.4.2/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='bdaia_shorty_stylesheet-css' href='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/shortcodes.css' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='theme-child-style-css' href='https://www.criticalhit.net/wp-content/themes/woohoo-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='woohoo-google-fonts-css' href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C300%2C700%7CLato%3A400%2C300%2C700%2C900%7CWork+Sans%3A400%2C300%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C600%2C700%2C800%7CPlayfair+Display%3A400%2C700%2C900%2C400italic%7CRaleway%3A400%2C300%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A400%2C300%2C100%2C700%7CMontserrat%3A400%2C700&#038;subset=latin%2Cgreek%2Cgreek-ext%2Cvietnamese%2Ccyrillic-ext%2Clatin-ext%2Ccyrillic' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css' href='https://www.criticalhit.net/wp-content/plugins/easy-table/themes/default/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='woohoo-default-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/style.css' type='text/css' media='all' />
<style id='woohoo-default-inline-css' type='text/css'>
body.category-41989 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-5 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-33983 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-41988 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-34107 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-58 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-41990 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-38 div.bdaia-blocks div.bdaia-post-view{display: none !important;}
</style>
<link rel='stylesheet' id='wooohoo-ilightbox-skin-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='wooohoo-ilightbox-skin-black-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/ilightbox/metro-black-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://c0.wp.com/p/jetpack/8.7.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.7.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var bd_w_blocks = {"bdaia_w_ajax_url":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","bdaia_w_ajax_nonce":"52675af72f"};
var bd_blocks = {"bdaia_ajax_url":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","bdaia_ajaxnonce":"52675af72f"};
var bd_script = {"post_id":"1084806","ajaxurl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/js/scripts.js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/js/shorty-min.js'></script>
<link rel='https://api.w.org/' href='https://www.criticalhit.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.criticalhit.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.criticalhit.net/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.criticalhit.net/?p=1084806' />
<link rel="alternate" type="application/json+oembed" href="https://www.criticalhit.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.criticalhit.net%2Fentertainment%2Ffirst-images-and-plot-details-for-amazons-utopia-series-revealed%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.criticalhit.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.criticalhit.net%2Fentertainment%2Ffirst-images-and-plot-details-for-amazons-utopia-series-revealed%2F&#038;format=xml" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<style type='text/css'>img#wpstats{display:none}</style> <script type="text/javascript">
            /* <![CDATA[ */
            var sf_position = '0';
            var sf_templates = "<a href=\"{search_url_escaped}\"><span class=\"sf_text\">View All Results<\/span><\/a>";
            var sf_input = '.search-live';
            jQuery(document).ready(function(){
                jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/www.criticalhit.net\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","rtl":0});
                jQuery(".live-search_ajaxy-selective-input").keyup(function() {
                    var width = jQuery(this).val().length * 8;
                    if(width < 50) {
                        width = 50;
                    }
                    jQuery(this).width(width);
                });
                jQuery(".live-search_ajaxy-selective-search").click(function() {
                    jQuery(this).find(".live-search_ajaxy-selective-input").focus();
                });
                jQuery(".live-search_ajaxy-selective-close").click(function() {
                    jQuery(this).parent().remove();
                });
            });
            /* ]]> */
        </script>
<link rel="shortcut icon" href="https://media.criticalhit.net/2018/12/favicon.png" type="image/x-icon" /><script data-ad-client="ca-pub-1473612930314813" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5GNB24P');</script>

<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<style>

@media all and (min-device-width: 700px) and (max-device-width: 728px) {#leaderboard-pixfuture {transform: scale(0.9);}} @media all and (min-device-width: 671px) and (max-device-width: 699px) {#leaderboard-pixfuture {transform: scale(0.9);transform-origin: 0 0;}} @media all and (min-device-width: 651px) and (max-device-width: 670px) {#leaderboard-pixfuture {transform: scale(0.88);transform-origin: 0 0;}} @media all and (min-device-width: 631px) and (max-device-width: 650px) {#leaderboard-pixfuture {transform: scale(0.85);transform-origin: 0 0;}} @media all and (min-device-width: 601px) and (max-device-width: 630px) {#leaderboard-pixfuture {transform: scale(0.8);transform-origin: 0 0;}} @media all and (min-device-width: 601px) and (max-device-width: 630px) {#leaderboard-pixfuture {transform: scale(0.8);transform-origin: 0 0;}} @media all and (min-device-width: 560px) and (max-device-width: 600px) {#leaderboard-pixfuture {transform: scale(0.75);transform-origin: 0 0;}} @media all and (min-device-width: 520px) and (max-device-width: 559px) {#leaderboard-pixfuture {transform: scale(0.7);transform-origin: 0 0;}} @media all and (min-device-width: 491px) and (max-device-width: 519px) {#leaderboard-pixfuture {transform: scale(0.65);transform-origin: 0 0;}} @media all and (min-device-width: 451px) and (max-device-width: 490px) {#leaderboard-pixfuture {transform: scale(0.6);transform-origin: 0 0;}} @media all and (min-device-width: 401px) and (max-device-width: 450px) {#leaderboard-pixfuture {transform: scale(0.55);transform-origin: 0 0;}} @media all and (min-device-width: 371px) and (max-device-width: 400px) {#leaderboard-pixfuture {transform: scale(0.5);transform-origin: 0 0;}} @media all and (min-device-width: 341px) and (max-device-width: 370px) {#leaderboard-pixfuture {transform: scale(0.46);transform-origin: 0 0;}} @media all and (min-device-width: 301px) and (max-device-width: 340px) {#leaderboard-pixfuture {transform: scale(0.42);transform-origin: 0 0;}} @media all and (max-device-width: 300px) {#leaderboard-pixfuture {transform: scale(0.4);transform-origin: 0 0;}}

</style>
<script type="text/javascript">
/* <![CDATA[ */
var userRating = {"ajaxurl":"https://www.criticalhit.net/wp-admin/admin-ajax.php" , "your_rating":"" , "nonce":"52675af72f"};
var userLike = {"ajaxurl":"https://www.criticalhit.net/wp-admin/admin-ajax.php" , "nonce":"52675af72f"};
/* ]]> */
var bdaia_theme_uri = 'https://www.criticalhit.net/wp-content/themes/woohoo';
</script>
<style type="text/css">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</style><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=270%2C270&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">
				.bdaia-post-content blockquote p,
blockquote p  {
  font-size: 20px !important;
  background: #f9f9f9 !important;
  border-left: 10px solid #ccc !important;
  margin: .5em 10px !important;
  padding: 0 10px !important;
  quotes: "\201C""\201D""\2018""\2019" !important;
  padding: 10px 20px !important;
  line-height: 1.4 !important;
	text-transform: none !important;
	color: grey  !important;
	text-align: left !important;
	font-weight: 300 !important;
}

.bdaia-post-content blockquote, blockquote {
    margin: 20px 5px 10px 0px !important;
	    padding-left: 0px !important;
    border-left: none !important;
}

.wp-block-jetpack-gif .wp-block-jetpack-gif-caption {
    color: #ffffff !important;
    font-weight: bold;
}			</style>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<meta name="msvalidate.01" content="2408EBF25A6FABECCCF3EC45230C1258" />
<script>
!function(a){var b=/iPhone/i,c=/iPod/i,d=/iPad/i,e=/(?=.*\bAndroid\b)(?=.*\bMobile\b)/i,f=/Android/i,g=/(?=.*\bAndroid\b)(?=.*\bSD4930UR\b)/i,h=/(?=.*\bAndroid\b)(?=.*\b(?:KFOT|KFTT|KFJWI|KFJWA|KFSOWI|KFTHWI|KFTHWA|KFAPWI|KFAPWA|KFARWI|KFASWI|KFSAWI|KFSAWA)\b)/i,i=/IEMobile/i,j=/(?=.*\bWindows\b)(?=.*\bARM\b)/i,k=/BlackBerry/i,l=/BB10/i,m=/Opera Mini/i,n=/(CriOS|Chrome)(?=.*\bMobile\b)/i,o=/(?=.*\bFirefox\b)(?=.*\bMobile\b)/i,p=new RegExp("(?:Nexus 7|BNTV250|Kindle Fire|Silk|GT-P1000)","i"),q=function(a,b){return a.test(b)},r=function(a){var r=a||navigator.userAgent,s=r.split("[FBAN");return"undefined"!=typeof s[1]&&(r=s[0]),s=r.split("Twitter"),"undefined"!=typeof s[1]&&(r=s[0]),this.apple={phone:q(b,r),ipod:q(c,r),tablet:!q(b,r)&&q(d,r),device:q(b,r)||q(c,r)||q(d,r)},this.amazon={phone:q(g,r),tablet:!q(g,r)&&q(h,r),device:q(g,r)||q(h,r)},this.android={phone:q(g,r)||q(e,r),tablet:!q(g,r)&&!q(e,r)&&(q(h,r)||q(f,r)),device:q(g,r)||q(h,r)||q(e,r)||q(f,r)},this.windows={phone:q(i,r),tablet:q(j,r),device:q(i,r)||q(j,r)},this.other={blackberry:q(k,r),blackberry10:q(l,r),opera:q(m,r),firefox:q(o,r),chrome:q(n,r),device:q(k,r)||q(l,r)||q(m,r)||q(o,r)||q(n,r)},this.seven_inch=q(p,r),this.any=this.apple.device||this.android.device||this.windows.device||this.other.device||this.seven_inch,this.phone=this.apple.phone||this.android.phone||this.windows.phone,this.tablet=this.apple.tablet||this.android.tablet||this.windows.tablet,"undefined"==typeof window?this:void 0},s=function(){var a=new r;return a.Class=r,a};"undefined"!=typeof module&&module.exports&&"undefined"==typeof window?module.exports=r:"undefined"!=typeof module&&module.exports&&"undefined"!=typeof window?module.exports=s():"function"==typeof define&&define.amd?define("isMobile",[],a.isMobile=s()):a.isMobile=s()}(this);
  googletag.cmd.push(function() {
	if(isMobile.any) {
	googletag.defineSlot('/55341649/300250MidarticleMobile', [300, 250],
		'div-gpt-ad-1540807120663-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/300x250ACmobile', [300, 250],
	    'div-gpt-ad-1540807963183-0').addService(googletag.pubads());
			googletag.defineSlot('/55341649/MastheadTop', [728, 90],
			'div-gpt-ad-1542102676397-0').addService(googletag.pubads());

	} else {
	googletag.defineSlot('/55341649/MastheadTop', [728, 90],
	'div-gpt-ad-1542102676397-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/728MidArticle', [728, 90],
			'div-gpt-ad-1540806613519-0').addService(googletag.pubads());
  googletag.defineSlot('/55341649/728Comments', [728, 90],
	    'div-gpt-ad-1540808126586-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/Background', [1, 1],
		'div-gpt-ad-1540376831756-0').addService(googletag.pubads());

    }
	googletag.enableServices();
  });
</script>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "WebSite",
  "url": "https://www.criticalhit.net/",
  "name": "Critical Hit",
  "description": "Critical Hit is a website built on the idea that we are more than one thing. Writers, writing about the things they love; games, film, TV, technology and more.",
  "publisher": "Critical Hit",
  "potentialAction": {
    "@type": "SearchAction",
    "target": "https://www.criticalhit.net/?s={search_term}",
    "query-input": "required name=search_term" }
    }
</script>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "Organization",
  "url": "https://www.criticalhit.net",
  "logo": "https://www.criticalhit.net/images/Icon.png"
}
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-1473612930314813",
          enable_page_level_ads: false
     });
</script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.flexslider-min.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.eislideshow.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.placeholder.min.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.fitvids.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/modernizr.js"></script>
</head>
<body class="post-template-default single single-post postid-1084806 single-format-standard bdaia-boxed  of-new-article " itemscope itemtype="http://schema.org/WebPage">
<div class="page-outer bdaia-header-default bdaia-lazyload  sticky-nav-on  bdaia-post-template-default  bdaia-sidebar-right ">
<div class="bg-cover"></div>
<aside id="bd-MobileSiderbar">
<div id="mobile-menu"></div>
<div class="widget-social-links bdaia-social-io-colored">
<div class="sl-widget-inner">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class=" bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class=" bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class=" bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class=" bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class=" bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</aside>

<div id='div-gpt-ad-1540376831756-0' style='height:1px; width:1px;'>
<script>
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540376831756-0'); });
	</script>
</div>
<div id="page">
<div class="inner-wrapper">
<div id="warp" class="clearfix  bdaia-sidebar-right ">
<div class="header-wrapper">
<div class="bdayh-click-open">
<div class="bd-ClickOpen bd-ClickAOpen">
<span></span>
</div>
</div>
<header class="header-container">
<div class="bd-container">
<div class="logo">
<h2 class="site-title"> <a href="https://www.criticalhit.net/" rel="home" title="Critical Hit">
<img src="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-Entertainment.png" alt="Critical Hit" />
</a>
</h2> </div>
<div class="bdaia-header-e3-desktop"><div class="bdaia-e3-container"> <div id="leaderboard-pixfuture" style="width:728px; margin:0 auto;">
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<div id="gpt-passback">
<script>
    window.googletag = window.googletag || {cmd: []};
    googletag.cmd.push(function() {
    googletag.defineSlot('/55341649/MastheadTop', [728, 90], 'gpt-passback').addService(googletag.pubads());
    googletag.enableServices();
    googletag.display('gpt-passback');
    });
  </script>
</div>
</div></div></div>
</div>
</header>
<div class="cfix"></div>
<nav id="navigation" class="">
<div class="navigation-wrapper">
<div class="bd-container">
<div class="primary-menu">
<a class="nav-logo" title="Critical Hit" href="https://www.criticalhit.net/">
<img src="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-Text-Only.png" width="195" height="48" alt="Critical Hit" />
</a>
<ul id="menu-primary">
<li id="menu-item-526858" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/gaming/"> <i class="fa fa fa-gamepad"></i> <span class="menu-label" style="">Games</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526854" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/entertainment/"> <i class="fa fa fa-film"></i> <span class="menu-label" style="">Entertainment</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526870" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/technology/"> <i class="fa fa fa-power-off"></i> <span class="menu-label" style="">Tech</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526876" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/comics-toys/"> <i class="fa fa fa-comment-o"></i> <span class="menu-label" style="">Comics</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526860" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/lifestyle/"> <i class="fa fa fa-heart"></i> <span class="menu-label" style="">Lifestyle</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-726070" class=" menu-item menu-item-type-post_type menu-item-object-page bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/esports/"> <i class="fa fa fa-users"></i> <span class="menu-label" style="">esports</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-881926" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/review/"> <i class="fa fa fa-book"></i> <span class="menu-label" style="">Reviews</span></a>
<div class="mega-menu-content">
</div> </ul>
</div>
<div class="nav-right-area">
<div class="bdaia-nav-search">
<span class="bdaia-ns-btn bdaia-io bdaia-io-search"></span>
<div class="bdaia-ns-wrap">
<div class="bdaia-ns-content">
<div class="bdaia-ns-inner">
<form method="get" id="searchform" action="https://www.criticalhit.net/">
<input type="text" class="bbd-search-field search-live" id="s" name="s" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}" />
<button type="submit" class="bbd-search-btn"><span class="bdaia-io bdaia-io-search"></span></button>
</form>
</div>
</div>
</div>
</div>
</div>
<div class="cfix"></div>
</div>
</div>
</nav>
<div class="cfix"></div>
</div>
<div class="bdMain">
<div class="bd-container bdaia-post-template">
<div class="bd-main bdaia-site-content" id="bdaia-primary">
<div id="content" role="main">
<div xmlns:v="http://rdf.data-vocabulary.org/#" class="bdaia-crumb-container"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.criticalhit.net">Home</a></span> <span class="delimiter"><span class="bdaia-io bdaia-io-angle-double-right"></span></span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.criticalhit.net/category/entertainment/">Entertainment</a></span> <span class="delimiter"><span class="bdaia-io bdaia-io-angle-double-right"></span></span> <span class="current">First images and plot details for Amazon&#8217;s Utopia series revealed</span></div><div class="bdayh-clearfix"></div>
<article id="post-1084806" class="hentry post-1084806 post type-post status-publish format-standard has-post-thumbnail category-entertainment tag-amazon tag-ashleigh-lathrop tag-dan-byrd tag-desmin-borges tag-gillian-flynn tag-jessica-rothe tag-utopia" itemscope itemtype="https://schema.org/Article">
<header class="bdaia-post-header">
<div class="bdaia-post-title">
<h1 class="post-title entry-title"><span>First images and plot details for Amazon&#8217;s Utopia series revealed</span></h1>
</div>

<div class="bdaia-meta-info">
<div class="bdaia-post-author-name">
By <a href="https://www.criticalhit.net/author/craigrisi/" title="">Craig Risi </a>
<a href="https://twitter.com/RisiCraig" target="_blank">
<span class="bdaia-io bdaia-io-twitter"></span>
</a>
</div>
<div class="bdaia-post-date"><span class='bdaia-io bdaia-io-calendar'></span>Posted on&nbsp;<span class="bdayh-date">July 22, 2020</span></div>
<div class="bdaia-post-time-read"><span class='bdaia-io bdaia-io-clock'></span>2&nbsp;min read</div>
<div class="bdaia-post-comment"><span class='bdaia-io bdaia-io-bubbles4'></span><a href="https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/#comments"><span class="dsq-postid" data-dsqidentifier="1084806 https://www.criticalhit.net/?p=1084806">1</span></a></div>
</div>

</header>
<div class="bdaia-post-sharing bdaia-post-sharing-top">
<ul>
<li class="facebook">
<a title="facebook" onClick="window.open('http://www.facebook.com/sharer.php?u=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/">
<span class="bdaia-io bdaia-io-facebook"></span>
<span>Share on Facebook</span>
</a>
</li>
<li class="twitter">
<a title="twitter" onClick="window.open('http://twitter.com/share?url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/&amp;text=First%20images%20and%20plot%20details%20for%20Amazon&#8217;s%20Utopia%20series%20revealed','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/&amp;text=First%20images%20and%20plot%20details%20for%20Amazon&#8217;s%20Utopia%20series%20revealed">
<span class="bdaia-io bdaia-io-twitter"></span>
<span>Share on Twitter</span>
</a>
</li>
<li class="google">
<a title="google" onClick="window.open('https://plus.google.com/share?url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/">
<span class="bdaia-io bdaia-io-google-plus"></span>
<span>Share on Google+</span>
</a>
</li>
<li class="reddit">
<a title="reddit" onClick="window.open('http://reddit.com/submit?url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/&amp;title=First%20images%20and%20plot%20details%20for%20Amazon&#8217;s%20Utopia%20series%20revealed','Reddit','width=617,height=514,left='+(screen.availWidth/2-308)+',top='+(screen.availHeight/2-257)+''); return false;" href="https://reddit.com/submit?url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/&amp;title=First%20images%20and%20plot%20details%20for%20Amazon&#8217;s%20Utopia%20series%20revealed">
<span class="bdaia-io bdaia-io-reddit"></span>
<span>Share on Reddit</span>
</a>
</li>
<li class="pinterest">
<a title="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.criticalhit.net%2Fentertainment%2Ffirst-images-and-plot-details-for-amazons-utopia-series-revealed%2F&amp;description=First+images+and+plot+details+for+Amazon%27s+Utopia+series+revealed&amp;media=https%3A%2F%2Fi2.wp.com%2Fmedia.criticalhit.net%2F%2F2020%2F07%2Futopia-usversion-maincharacters-amazon-1.jpg%3Ffit%3D960%252C500%26ssl%3D1">
<span class="bdaia-io bdaia-io-social-pinterest"></span>
<span>Share on Pinterest</span>
</a>
</li>
<li class="linkedin">
<a title="linkedin" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/">
<span class="bdaia-io bdaia-io-linkedin2"></span>
<span>Share on Linkedin</span>
</a>
</li>
<li class="tumblr">
<a title="tumblr" onClick="window.open('http://www.tumblr.com/share/link?url=www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/&amp;name=First%20images%20and%20plot%20details%20for%20Amazon&#8217;s%20Utopia%20series%20revealed','Tumblr','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.tumblr.com/share/link?url=www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/&amp;name=First%20images%20and%20plot%20details%20for%20Amazon&#8217;s%20Utopia%20series%20revealed">
<span class="bdaia-io bdaia-io-tumblr"></span>
<span>Share on Tumblr</span>
</a>
</li>
<li class="whatsapp">
<a href="whatsapp://send?text=Amazon+has+some+big+series+on+their+way+and+we+finally+have+more+details+on+Utopia.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fentertainment%2Ffirst-images-and-plot-details-for-amazons-utopia-series-revealed%2F"><span class="bdaia-io bdaia-io-whatsapp"></span></a> </li>
<li class="telegram">
<a href="tg://msg?text=Amazon+has+some+big+series+on+their+way+and+we+finally+have+more+details+on+Utopia.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fentertainment%2Ffirst-images-and-plot-details-for-amazons-utopia-series-revealed%2F"><span class="bdaia-io bdaia-io-telegram"></span></a> </li>
</ul>
</div>

<div class="bdaia-post-content">
<div class="wp-block-image"><figure class="aligncenter size-large"><img data-attachment-id="1084814" data-permalink="https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/attachment/utopia-usversion-maincharacters-amazon-1/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon-1.jpg?fit=960%2C500&amp;ssl=1" data-orig-size="960,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="utopia-usversion-maincharacters-amazon-1" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon-1.jpg?fit=300%2C156&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon-1.jpg?fit=850%2C443&amp;ssl=1" src="https://i2.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon-1.jpg?w=850&#038;ssl=1" alt="First images and plot details for Amazon&#039;s Utopia series revealed 4" class="wp-image-1084814" srcset="https://i2.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon-1.jpg?w=960&amp;ssl=1 960w, https://i2.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon-1.jpg?resize=300%2C156&amp;ssl=1 300w, https://i2.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon-1.jpg?resize=768%2C400&amp;ssl=1 768w, https://i2.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon-1.jpg?resize=850%2C443&amp;ssl=1 850w" sizes="(max-width: 850px) 100vw, 850px" title="First images and plot details for Amazon&#039;s Utopia series revealed 4" data-recalc-dims="1"></figure></div>
<p>HBO and Netflix may get most of the spotlight when it comes to popular TV series debuts, but with far bigger budgets and big properties coming their way, Amazon arguably has the bigger series in development outside of its already strong line-up of original content.</p>
<p>One of those highly anticipated series is Utopia. Adapted from a 2013 UK series of the same name but with an even bigger focus on government conspiracies, Utopia follows Ian (Dan Byrd), Wilson (Desmin Borges), Samantha (Jessica Rothe), and Becky (Ashleigh Lathrop), as a group of comic book nerds who are part of an online forum that meets up to discuss the fictional graphic novel Dystopia. </p>
<p>By arranging to meet in person at a convention that will offer a sneak peek at Dystopia’s sequel, Utopia, the group finds themselves hunted by trained assassins attempting to stop anyone from reading the story. Help arrives for the gang when Jessica Hyde (Sasha Lane), the protagonist from the comic-book series, shows up in an attempt to save her missing father and reveals that Utopia may hold the answers to their survival. A plot outlined that was revealed by <a class="rank-math-link" href="https://www.slashfilm.com/american-adaptation-of-utopia-first-look-photos/">/Film</a>, along with some first images for the series:</p>
<figure class="wp-block-image size-large"><img data-attachment-id="1084808" data-permalink="https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/attachment/amazon-utopia-john-cusack/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/07/amazon-utopia-john-cusack.jpg?fit=740%2C370&amp;ssl=1" data-orig-size="740,370" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="amazon-utopia-john-cusack" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/07/amazon-utopia-john-cusack.jpg?fit=300%2C150&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/07/amazon-utopia-john-cusack.jpg?fit=740%2C370&amp;ssl=1" src="https://i2.wp.com/media.criticalhit.net//2020/07/amazon-utopia-john-cusack.jpg?w=850&#038;ssl=1" alt="First images and plot details for Amazon&#039;s Utopia series revealed 5" class="wp-image-1084808" srcset="https://i2.wp.com/media.criticalhit.net//2020/07/amazon-utopia-john-cusack.jpg?w=740&amp;ssl=1 740w, https://i2.wp.com/media.criticalhit.net//2020/07/amazon-utopia-john-cusack.jpg?resize=300%2C150&amp;ssl=1 300w" sizes="(max-width: 740px) 100vw, 740px" title="First images and plot details for Amazon&#039;s Utopia series revealed 5" data-recalc-dims="1"></figure>
<div class="wp-block-image"><figure class="aligncenter size-large"><img data-attachment-id="1084811" data-permalink="https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/attachment/amazon-utopia-series-cast/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/07/amazon-utopia-series-cast.jpg?fit=740%2C370&amp;ssl=1" data-orig-size="740,370" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="amazon-utopia-series-cast" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/07/amazon-utopia-series-cast.jpg?fit=300%2C150&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/07/amazon-utopia-series-cast.jpg?fit=740%2C370&amp;ssl=1" src="https://i1.wp.com/media.criticalhit.net//2020/07/amazon-utopia-series-cast.jpg?w=850&#038;ssl=1" alt="First images and plot details for Amazon&#039;s Utopia series revealed 6" class="wp-image-1084811" srcset="https://i1.wp.com/media.criticalhit.net//2020/07/amazon-utopia-series-cast.jpg?w=740&amp;ssl=1 740w, https://i1.wp.com/media.criticalhit.net//2020/07/amazon-utopia-series-cast.jpg?resize=300%2C150&amp;ssl=1 300w" sizes="(max-width: 740px) 100vw, 740px" title="First images and plot details for Amazon&#039;s Utopia series revealed 6" data-recalc-dims="1"></figure></div>
<p>It&#8217;s an interesting premise that could also easily relate to many fans who feel incredibly attached to their favourite works of fiction. The series was initially supposed to be adapted by David Fincher for HBO, but the project was sent to Amazon Studios due to budget issues. Something which Amazon’s supersized wallet is perhaps better suited for. Instead, Gillian Flynn (who wrote Fincher’s Gone Girl), who will serve as the writer and showrunner of the series.</p><div class="xorte5f1baeae6a246"><div id='div-gpt-ad-1540806613519-0' style='width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540806613519-0'); });
</script>
</div>
<div id='div-gpt-ad-1540807120663-0' tyle='margin:auto; width:320px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540807120663-0'); });
</script>
</div>
</div><style type="text/css">
.xorte5f1baeae6a246 {
margin: 5px; padding: 0px;
}
@media screen and (min-width: 1201px) {
.xorte5f1baeae6a246 {
display: block;
}
}
@media screen and (min-width: 993px) and (max-width: 1200px) {
.xorte5f1baeae6a246 {
display: block;
}
}
@media screen and (min-width: 769px) and (max-width: 992px) {
.xorte5f1baeae6a246 {
display: block;
}
}
@media screen and (min-width: 768px) and (max-width: 768px) {
.xorte5f1baeae6a246 {
display: block;
}
}
@media screen and (max-width: 767px) {
.xorte5f1baeae6a246 {
display: block;
}
}
</style>
<p>Utopia&nbsp;also stars John Cusack as Kevin Christie, a billionaire philanthropist, and&nbsp;Rainn Wilson&nbsp;as Dr Michael Stearns. These pics alone don’t look too spectacular, but with a big budget, great cast and bold ambition, this could be another killer series for Amazon when it releases.</p>
<p>Last Updated: <span class="updated">July 22, 2020</span></p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-1084806" class="share-twitter sd-button share-icon" href="https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-1084806" class="share-facebook sd-button share-icon" href="https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-end"></li></ul></div></div></div>
</div>
<footer>
<div class="bdaia-post-sharing bdaia-post-sharing-bottom">
<ul>
<li class="facebook">
<a title="facebook" onClick="window.open('http://www.facebook.com/sharer.php?u=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/">
<span class="bdaia-io bdaia-io-facebook"></span>
<span>Share on Facebook</span>
</a>
</li>
<li class="twitter">
<a title="twitter" onClick="window.open('http://twitter.com/share?url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/&amp;text=First%20images%20and%20plot%20details%20for%20Amazon&#8217;s%20Utopia%20series%20revealed','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/&amp;text=First%20images%20and%20plot%20details%20for%20Amazon&#8217;s%20Utopia%20series%20revealed">
<span class="bdaia-io bdaia-io-twitter"></span>
<span>Share on Twitter</span>
</a>
</li>
<li class="google">
<a title="google" onClick="window.open('https://plus.google.com/share?url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/">
<span class="bdaia-io bdaia-io-google-plus"></span>
<span>Share on Google+</span>
</a>
</li>
<li class="reddit">
<a title="reddit" onClick="window.open('http://reddit.com/submit?url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/&amp;title=First%20images%20and%20plot%20details%20for%20Amazon&#8217;s%20Utopia%20series%20revealed','Reddit','width=617,height=514,left='+(screen.availWidth/2-308)+',top='+(screen.availHeight/2-257)+''); return false;" href="https://reddit.com/submit?url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/&amp;title=First%20images%20and%20plot%20details%20for%20Amazon&#8217;s%20Utopia%20series%20revealed">
<span class="bdaia-io bdaia-io-reddit"></span>
<span>Share on Reddit</span>
</a>
</li>
<li class="pinterest">
<a title="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.criticalhit.net%2Fentertainment%2Ffirst-images-and-plot-details-for-amazons-utopia-series-revealed%2F&amp;description=First+images+and+plot+details+for+Amazon%27s+Utopia+series+revealed&amp;media=https%3A%2F%2Fi2.wp.com%2Fmedia.criticalhit.net%2F%2F2020%2F07%2Futopia-usversion-maincharacters-amazon-1.jpg%3Ffit%3D960%252C500%26ssl%3D1">
<span class="bdaia-io bdaia-io-social-pinterest"></span>
<span>Share on Pinterest</span>
</a>
</li>
<li class="linkedin">
<a title="linkedin" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/">
<span class="bdaia-io bdaia-io-linkedin2"></span>
<span>Share on Linkedin</span>
</a>
</li>
<li class="tumblr">
<a title="tumblr" onClick="window.open('http://www.tumblr.com/share/link?url=www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/&amp;name=First%20images%20and%20plot%20details%20for%20Amazon&#8217;s%20Utopia%20series%20revealed','Tumblr','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.tumblr.com/share/link?url=www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/&amp;name=First%20images%20and%20plot%20details%20for%20Amazon&#8217;s%20Utopia%20series%20revealed">
<span class="bdaia-io bdaia-io-tumblr"></span>
<span>Share on Tumblr</span>
</a>
</li>
<li class="whatsapp">
<a href="whatsapp://send?text=Amazon+has+some+big+series+on+their+way+and+we+finally+have+more+details+on+Utopia.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fentertainment%2Ffirst-images-and-plot-details-for-amazons-utopia-series-revealed%2F"><span class="bdaia-io bdaia-io-whatsapp"></span></a> </li>
<li class="telegram">
<a href="tg://msg?text=Amazon+has+some+big+series+on+their+way+and+we+finally+have+more+details+on+Utopia.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fentertainment%2Ffirst-images-and-plot-details-for-amazons-utopia-series-revealed%2F"><span class="bdaia-io bdaia-io-telegram"></span></a> </li>
</ul>
</div>

<div class="bdaia-p-bottom-e3-desktop"><div class="bdaia-e3-container"><div id="contentad298317"></div>
<script type="text/javascript">
    (function(d) {
        var params =
        {
            id: "bdc01488-c73b-4b54-88bd-d9fd30218a86",
            d: "Y3JpdGljYWxoaXQubmV0",
            wid: "298317",
            cb: (new Date()).getTime()
        };
        var qs = Object.keys(params).reduce(function(a, k){ a.push(k + '=' + encodeURIComponent(params[k])); return a},[]).join(String.fromCharCode(38));
        var s = d.createElement('script'); s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content-ad.net/Scripts/widget2.aspx?" + qs;
        d.getElementById("contentad298317").appendChild(s);
    })(document);
</script></div></div>
<div class="bdaia-post-next-prev">
<div class="bdaia-post-prev-post">
<a href="https://www.criticalhit.net/gaming/you-didnt-see-nothing-especially-15-minutes-of-new-mafia-definitive-edition-gameplay-capiche/" rel="prev"><span>Previous article</span> You didn&rsquo;t see nothing, especially 15 minutes of new Mafia: Definitive Edition gameplay, Capiche?</a> </div>
<div class="bdaia-post-next-post">
<a href="https://www.criticalhit.net/gaming/ubisofts-having-another-bad-day-over-fresh-misconduct-allegations-and-baffling-assassins-creed-decisions/" rel="next"><span>Next article</span> Ubisoft&rsquo;s having another bad day over fresh misconduct allegations and baffling Assassin&rsquo;s Creed decisions</a> </div>
</div>

<div class="bdaia-author-box">
<div class="authorBlock-avatar">
<a href="https://www.criticalhit.net/author/craigrisi/"><img src="https://secure.gravatar.com/avatar/a31e3cf46ff23ca15ce0606a22e673d5?s=150&#038;d=mm&#038;r=pg" width="150" height="150" alt="Avatar" class="avatar avatar-150 wp-user-avatar wp-user-avatar-150 photo avatar-default" /></a>
</div>
<div class="authorBlock-header">
<h3 class="authorBlock-header-title">
<a href="https://www.criticalhit.net/author/craigrisi/">Craig Risi </h3>
<p class="authorBlock-header-bio">
A man of many talents, but no sense how to use them. I could be out changing the world, but I'd rather be running, watching movies, playing games and writing here instead. </p>
<div class="authorBlock-meta bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-32">
<a class="bdaia-io-url-twitter" href="https://www.twitter.com/RisiCraig"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class="bdaia-io-url-facebook" href="https://www.facebook.com/craig.risi"><span class="bdaia-io bdaia-io-facebook"></span></a>
</div>
</div>
</div>
</div>
 </footer>
<span style=display:none itemprop=author itemscope itemtype="https://schema.org/Person">
<meta itemprop=name content="Craig Risi">
</span>
<meta itemprop=interactionCount content="UserComments:1">
<meta itemprop=datePublished content="2020-07-22T12:30:00+00:00">
<meta itemprop=dateModified content="2020-07-22T12:30:00+00:00">
<meta itemscope itemprop=mainEntityOfPage itemtype="https://schema.org/WebPage" itemid="https://www.criticalhit.net/entertainment/first-images-and-plot-details-for-amazons-utopia-series-revealed/">
<span style=display:none itemprop=publisher itemscope itemtype="https://schema.org/Organization">
<span style=display:none itemprop=logo itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-Main.png">
</span>
<meta itemprop=name content="Critical Hit">
</span>
<meta itemprop=headline content="First images and plot details for Amazon&#8217;s Utopia series revealed">
<span style=display:none itemprop=image itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop=url content="https://i2.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon-1.jpg?fit=960%2C500&#038;ssl=1">
<meta itemprop=width content=1240>
<meta itemprop=height content=540>
</span>
</article>
<div id="disqus_thread"></div>
<section id="bdCheckAlso" class="bdCheckAlso-right">
<h4 class="block-title">
<span>Check Also</span>
<a href="#" id="check-also-close"><span class="bdaia-io bdaia-io-cross"></span></a>
</h4>
<div class="check-also-post">
<figure class="check-also-thumb" style="background-image:url(https://i0.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon.jpg?resize=320%2C220&ssl=1);"></figure>
<h2 class="post-title"><a href="https://www.criticalhit.net/entertainment/comic-con-watch-the-first-trailer-for-amazons-ambitious-thriller-utopia/" rel="bookmark">Comic-Con: Watch the first-trailer for Amazon&#8217;s ambitious thriller Utopia</a></h2>
<p>We get a first trailer for Amazon's highly anticipated comic-themed thriller, Utopia, penn&#8230;</p>
</div>
</section>
</div>
</div>
<div class="bd-sidebar theia_sticky">
<div class="cfix"></div>
<div class="theiaStickySidebar">
<div id="bdaia-widget-e3-2" class="widget bdaia-widget bdaia-widget-e3 e3-trans"><div class="widget-inner">
<div class="e3-inner"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/300x250ATF', [300, 250]).display();
</script></div></div>
</div><div id="bdaia-social-links-3" class="widget bdaia-widget bdaia-social-links">
<h4 class="block-title"><span>Social</span></h4>
<div class="widget-inner">
<div class="widget-social-links bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class="none bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class="none bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class="none bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class="none bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class="none bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</div><div id="bdaia-widget-box6-2" class="widget bdaia-widget bdaia-box6"><h4 class="block-title"><span>Latest Reviews</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb6 bdaia-wb-idGFKy8 bdaia-ajax-pagination-next_prev" data-box_nu="wb6" data-box_id="bdaia-wb-idGFKy8" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="5" data-tag_slug="" data-cat_uid="58" data-cat_uids="" data-max_nu="658" data-total_posts_num="3287" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="true" data-date_meta="true" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-bigsh bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/rock-of-ages-3-review-the-great-terrain-robbery/" class="bdaia-text-gradient">
<img width="320" height="220" src="https://i1.wp.com/media.criticalhit.net//2020/07/Rock-of-Ages-3-1.jpg?resize=320%2C220&amp;ssl=1" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="Rock of Ages 3 Review &ndash; The great terrain robbery 7" srcset="https://i1.wp.com/media.criticalhit.net//2020/07/Rock-of-Ages-3-1.jpg?resize=320%2C220&amp;ssl=1 320w, https://i0.wp.com/media.criticalhit.net/2020/07/Rock-of-Ages-3-1.jpg?zoom=2&amp;resize=320%2C220&amp;ssl=1 640w" sizes="(max-width: 320px) 100vw, 320px" data-attachment-id="1085316" data-permalink="https://www.criticalhit.net/gaming/rock-of-ages-3-review-the-great-terrain-robbery/attachment/rock-of-ages-3-1-jpg/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/07/Rock-of-Ages-3-1.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Rock-of-Ages-3-1.jpg" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/07/Rock-of-Ages-3-1.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/07/Rock-of-Ages-3-1.jpg?fit=850%2C478&amp;ssl=1" title="Rock of Ages 3 Review &ndash; The great terrain robbery 7"> </a>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/rock-of-ages-3-review-the-great-terrain-robbery/"><span>Rock of Ages 3 Review &ndash; The great terrain robbery</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">July 23, 2020</span></div>
</footer>
</div>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/ooblets-review-oobviously-a-good-time/">
<img width="104" height="74" src="https://i0.wp.com/media.criticalhit.net//2020/07/ooblets-has-already-hooked-me.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="Ooblets Review&ndash; Oobviously a good time 8" srcset="https://i0.wp.com/media.criticalhit.net//2020/07/ooblets-has-already-hooked-me.jpg?resize=104%2C74&amp;ssl=1 104w, https://i0.wp.com/media.criticalhit.net/2020/07/ooblets-has-already-hooked-me.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i0.wp.com/media.criticalhit.net/2020/07/ooblets-has-already-hooked-me.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1085268" data-permalink="https://www.criticalhit.net/gaming/ooblets-review-oobviously-a-good-time/attachment/ooblets-has-already-hooked-me-jpg/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/07/ooblets-has-already-hooked-me.jpg?fit=918%2C516&amp;ssl=1" data-orig-size="918,516" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ooblets-has-already-hooked-me.jpg" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/07/ooblets-has-already-hooked-me.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/07/ooblets-has-already-hooked-me.jpg?fit=850%2C478&amp;ssl=1" title="Ooblets Review&ndash; Oobviously a good time 8"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/ooblets-review-oobviously-a-good-time/"><span>Ooblets Review&ndash; Oobviously a good time</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/blang/" title="Posts by Brad Lang" rel="author">Brad Lang</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">July 23, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/warrior-nun-review-a-confession-worthy-guilty-pleasure/">
<img width="104" height="74" src="https://i1.wp.com/media.criticalhit.net//2020/07/WarriorNun850.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="Warrior Nun review: A confession-worthy guilty pleasure 9" srcset="https://i1.wp.com/media.criticalhit.net//2020/07/WarriorNun850.jpg?resize=104%2C74&amp;ssl=1 104w, https://i0.wp.com/media.criticalhit.net/2020/07/WarriorNun850.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i0.wp.com/media.criticalhit.net/2020/07/WarriorNun850.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1085001" data-permalink="https://www.criticalhit.net/warriornun850/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/07/WarriorNun850.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="WarriorNun850" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/07/WarriorNun850.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/07/WarriorNun850.jpg?fit=850%2C478&amp;ssl=1" title="Warrior Nun review: A confession-worthy guilty pleasure 9"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/warrior-nun-review-a-confession-worthy-guilty-pleasure/"><span>Warrior Nun review: A confession-worthy guilty pleasure</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/pfangirl/" title="Posts by Noelle Adams" rel="author">Noelle Adams</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">July 23, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/cursed-review-netflixs-swords-and-sorcery-fantasy-remix-of-arthurian-legend/">
<img width="104" height="74" src="https://i1.wp.com/media.criticalhit.net//2020/07/Cursed_Season1_Episode4_00_44_00_09RC2.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="Cursed review – Netflix’s swords and sorcery fantasy remix of Arthurian Legend 10" srcset="https://i1.wp.com/media.criticalhit.net//2020/07/Cursed_Season1_Episode4_00_44_00_09RC2.jpg?resize=104%2C74&amp;ssl=1 104w, https://i2.wp.com/media.criticalhit.net/2020/07/Cursed_Season1_Episode4_00_44_00_09RC2.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i2.wp.com/media.criticalhit.net/2020/07/Cursed_Season1_Episode4_00_44_00_09RC2.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1083719" data-permalink="https://www.criticalhit.net/entertainment/cursed-review-netflixs-swords-and-sorcery-fantasy-remix-of-arthurian-legend/attachment/cursed_season1_episode4_00_44_00_09rc2/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/07/Cursed_Season1_Episode4_00_44_00_09RC2.jpg?fit=850%2C517&amp;ssl=1" data-orig-size="850,517" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;COURTESY OF NETFLIX&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;CURSED (L TO R) KATHERINE LANGFORD as NIMUE in episode 104 of CURSED Cr. Netflix \u00a9 2020&quot;,&quot;created_timestamp&quot;:&quot;1588703637&quot;,&quot;copyright&quot;:&quot;\u00a9 2020 Netflix, Inc.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Cursed_Season1_Episode4_00_44_00_09RC2" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/07/Cursed_Season1_Episode4_00_44_00_09RC2.jpg?fit=300%2C182&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/07/Cursed_Season1_Episode4_00_44_00_09RC2.jpg?fit=850%2C517&amp;ssl=1" title="Cursed review – Netflix’s swords and sorcery fantasy remix of Arthurian Legend 10"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/cursed-review-netflixs-swords-and-sorcery-fantasy-remix-of-arthurian-legend/"><span>Cursed review – Netflix’s swords and sorcery fantasy remix of Arthurian Legend</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/nukunukudash/" title="Posts by Tracy Benson" rel="author">Tracy Benson</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">July 17, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/creaks-review-a-wonderfully-weird-puzzle-platformer/">
<img width="104" height="74" src="https://i1.wp.com/media.criticalhit.net//2020/07/creaks-header.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="Creaks review – A wonderfully weird puzzle platformer 11" srcset="https://i1.wp.com/media.criticalhit.net//2020/07/creaks-header.jpg?resize=104%2C74&amp;ssl=1 104w, https://i1.wp.com/media.criticalhit.net/2020/07/creaks-header.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i1.wp.com/media.criticalhit.net/2020/07/creaks-header.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1083447" data-permalink="https://www.criticalhit.net/creaks-header/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/07/creaks-header.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="creaks-header" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/07/creaks-header.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/07/creaks-header.jpg?fit=850%2C478&amp;ssl=1" title="Creaks review – A wonderfully weird puzzle platformer 11"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/creaks-review-a-wonderfully-weird-puzzle-platformer/"><span>Creaks review – A wonderfully weird puzzle platformer</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/pfangirl/" title="Posts by Noelle Adams" rel="author">Noelle Adams</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">July 16, 2020</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-idGFKy8 .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'GFKy8', 'next' );
						});
						jQuery('.bdaia-wb-idGFKy8 .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'GFKy8', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-e3-11" class="widget bdaia-widget bdaia-widget-e3 "><h4 class="block-title"><span>Advert</span></h4>
<div class="widget-inner">
<div class="e3-inner"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/300600mid', [300, 600]).display();
</script></div></div>
</div><div id="bdaia-widget-html-4" class="widget bdaia-widget bdaia-widget-html "><h4 class="block-title"><span>Recent Comments</span></h4>
<div class="widget-inner">
<div id="recentcomments" class="dsq-widget"><script type="text/javascript" src="https://critical-hit-net.disqus.com/recent_comments_widget.js?num_items=5&hide_avatars=1&avatar_size=0&excerpt_length=200"></script></div><a href="https://disqus.com/">Powered by Disqus</a></div>
</div><div id="bdaia-widget-box2-4" class="widget bdaia-widget bdaia-box2"><h4 class="block-title"><span>Latest Posts </span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb2 bdaia-wb-idHMmjm bdaia-ajax-pagination-next_prev" data-box_nu="wb2" data-box_id="bdaia-wb-idHMmjm" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="5" data-tag_slug="" data-cat_uid="" data-cat_uids="" data-max_nu="12508" data-total_posts_num="62538" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-big bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/destiny-2-where-is-xur-and-whats-he-got-for-sale-july-24/">
<img width="320" height="220" src="https://i0.wp.com/media.criticalhit.net//2020/05/Xur-2-1-1.jpg?resize=320%2C220&amp;ssl=1" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="Destiny 2: Where is Xur (and whats he got for sale?) &ndash; July 24 12" srcset="https://i0.wp.com/media.criticalhit.net//2020/05/Xur-2-1-1.jpg?resize=320%2C220&amp;ssl=1 320w, https://i1.wp.com/media.criticalhit.net/2020/05/Xur-2-1-1.jpg?zoom=2&amp;resize=320%2C220&amp;ssl=1 640w" sizes="(max-width: 320px) 100vw, 320px" data-attachment-id="1061781" data-permalink="https://www.criticalhit.net/gaming/destiny-2-where-is-xur-and-whats-he-got-for-sale-may-1/attachment/xur-2-1-1-jpg-15/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/05/Xur-2-1-1.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Xur-2-1-1.jpg" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/05/Xur-2-1-1.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/05/Xur-2-1-1.jpg?fit=850%2C478&amp;ssl=1" title="Destiny 2: Where is Xur (and whats he got for sale?) &ndash; July 24 12"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/destiny-2-where-is-xur-and-whats-he-got-for-sale-july-24/"><span>Destiny 2: Where is Xur (and whats he got for sale?) &ndash; July 24</span></a></h3>
</header>
<footer>
</footer>
<p class="block-exb">There are still those who are willing to get up at the crack of dusk and boot up their console to find him for you. People who’ll risk digital life and limb to let you know if Xur is selling a treasure or rubbish. I just so happen to be one of those people. Maybe you’re stuck at work and can only log in later tonight. In that case: Where is Xur?</p>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/technology/slack-files-anti-trust-complaint-against-microsoft-and-its-teams-product/">
<img width="104" height="74" src="https://i0.wp.com/media.criticalhit.net//2020/07/slack-logo.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="Slack files anti-trust complaint against Microsoft and its Teams product 13" srcset="https://i0.wp.com/media.criticalhit.net//2020/07/slack-logo.jpg?resize=104%2C74&amp;ssl=1 104w, https://i0.wp.com/media.criticalhit.net//2020/07/slack-logo.jpg?resize=632%2C449&amp;ssl=1 632w, https://i2.wp.com/media.criticalhit.net/2020/07/slack-logo.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i2.wp.com/media.criticalhit.net/2020/07/slack-logo.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1085671" data-permalink="https://www.criticalhit.net/technology/slack-files-anti-trust-complaint-against-microsoft-and-its-teams-product/attachment/slack-logo-jpg-2/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/07/slack-logo.jpg?fit=800%2C449&amp;ssl=1" data-orig-size="800,449" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="slack-logo.jpg" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/07/slack-logo.jpg?fit=300%2C168&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/07/slack-logo.jpg?fit=800%2C449&amp;ssl=1" title="Slack files anti-trust complaint against Microsoft and its Teams product 13"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/technology/slack-files-anti-trust-complaint-against-microsoft-and-its-teams-product/"><span>Slack files anti-trust complaint against Microsoft and its Teams product</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/technology/alleged-ransomware-attack-behind-garmin-services-outage/">
<img width="104" height="74" src="https://i1.wp.com/media.criticalhit.net//2020/07/Garmin-Maintenance-1.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="Alleged ransomware attack behind Garmin services outage 14" srcset="https://i1.wp.com/media.criticalhit.net//2020/07/Garmin-Maintenance-1.jpg?resize=104%2C74&amp;ssl=1 104w, https://i0.wp.com/media.criticalhit.net/2020/07/Garmin-Maintenance-1.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i0.wp.com/media.criticalhit.net/2020/07/Garmin-Maintenance-1.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1085635" data-permalink="https://www.criticalhit.net/technology/alleged-ransomware-attack-behind-garmin-services-outage/attachment/garmin-maintenance-1/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/07/Garmin-Maintenance-1.jpg?fit=800%2C509&amp;ssl=1" data-orig-size="800,509" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Garmin-Maintenance-1" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/07/Garmin-Maintenance-1.jpg?fit=300%2C191&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/07/Garmin-Maintenance-1.jpg?fit=800%2C509&amp;ssl=1" title="Alleged ransomware attack behind Garmin services outage 14"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/technology/alleged-ransomware-attack-behind-garmin-services-outage/"><span>Alleged ransomware attack behind Garmin services outage</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/watch-dogs-legions-new-resistance-trailer-is-more-of-the-same-but-james-bond-dies/">
<img width="104" height="74" src="https://i1.wp.com/media.criticalhit.net//2020/07/Watch-Dogs-Legion-4-2.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="Watch Dogs: Legion&rsquo;s new &ldquo;Resistance&rdquo; trailer is more of the same, but James Bond dies 15" srcset="https://i1.wp.com/media.criticalhit.net//2020/07/Watch-Dogs-Legion-4-2.jpg?resize=104%2C74&amp;ssl=1 104w, https://i0.wp.com/media.criticalhit.net/2020/07/Watch-Dogs-Legion-4-2.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i0.wp.com/media.criticalhit.net/2020/07/Watch-Dogs-Legion-4-2.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1085687" data-permalink="https://www.criticalhit.net/gaming/watch-dogs-legions-new-resistance-trailer-is-more-of-the-same-but-james-bond-dies/attachment/watch-dogs-legion-4-2-jpg/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/07/Watch-Dogs-Legion-4-2.jpg?fit=918%2C516&amp;ssl=1" data-orig-size="918,516" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Watch-Dogs-Legion-4-2.jpg" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/07/Watch-Dogs-Legion-4-2.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/07/Watch-Dogs-Legion-4-2.jpg?fit=850%2C478&amp;ssl=1" title="Watch Dogs: Legion&rsquo;s new &ldquo;Resistance&rdquo; trailer is more of the same, but James Bond dies 15"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/watch-dogs-legions-new-resistance-trailer-is-more-of-the-same-but-james-bond-dies/"><span>Watch Dogs: Legion&rsquo;s new &ldquo;Resistance&rdquo; trailer is more of the same, but James Bond dies</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/comic-con-watch-the-first-trailer-for-amazons-ambitious-thriller-utopia/">
<img width="104" height="74" src="https://i0.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="Comic-Con: Watch the first-trailer for Amazon&#039;s ambitious thriller Utopia 16" srcset="https://i0.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon.jpg?resize=104%2C74&amp;ssl=1 104w, https://i2.wp.com/media.criticalhit.net/2020/07/utopia-usversion-maincharacters-amazon.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i2.wp.com/media.criticalhit.net/2020/07/utopia-usversion-maincharacters-amazon.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1085578" data-permalink="https://www.criticalhit.net/entertainment/comic-con-watch-the-first-trailer-for-amazons-ambitious-thriller-utopia/attachment/utopia-usversion-maincharacters-amazon-jpg/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon.jpg?fit=960%2C500&amp;ssl=1" data-orig-size="960,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="utopia-usversion-maincharacters-amazon.jpg" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon.jpg?fit=300%2C156&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/07/utopia-usversion-maincharacters-amazon.jpg?fit=850%2C443&amp;ssl=1" title="Comic-Con: Watch the first-trailer for Amazon&#039;s ambitious thriller Utopia 16"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/comic-con-watch-the-first-trailer-for-amazons-ambitious-thriller-utopia/"><span>Comic-Con: Watch the first-trailer for Amazon&#8217;s ambitious thriller Utopia</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-idHMmjm .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'HMmjm', 'next' );
						});
						jQuery('.bdaia-wb-idHMmjm .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'HMmjm', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-box2-2" class="widget bdaia-widget bdaia-box2"><h4 class="block-title"><span>Competitions </span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb2 bdaia-wb-idy3eHy bdaia-ajax-pagination-" data-box_nu="wb2" data-box_id="bdaia-wb-idy3eHy" data-paged="1" data-sort_order="" data-ajax_pagination="" data-num_posts="4" data-tag_slug="" data-cat_uid="34345" data-cat_uids="" data-max_nu="59" data-total_posts_num="234" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="true" data-review="">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-big bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/and-the-winners-of-our-the-last-of-us-part-ii-hampers-are/">
<img width="320" height="220" src="https://i1.wp.com/media.criticalhit.net//2020/06/last-of-us-part-2-w.jpg?resize=320%2C220&amp;ssl=1" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="And the winners of our The Last of Us Part II hampers are&hellip; 17" srcset="https://i1.wp.com/media.criticalhit.net//2020/06/last-of-us-part-2-w.jpg?resize=320%2C220&amp;ssl=1 320w, https://i1.wp.com/media.criticalhit.net/2020/06/last-of-us-part-2-w.jpg?zoom=2&amp;resize=320%2C220&amp;ssl=1 640w" sizes="(max-width: 320px) 100vw, 320px" data-attachment-id="1072415" data-permalink="https://www.criticalhit.net/gaming/the-last-of-us-part-ii-review/attachment/last-of-us-part-2-w-jpg/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/06/last-of-us-part-2-w.jpg?fit=918%2C516&amp;ssl=1" data-orig-size="918,516" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="last-of-us-part-2-w.jpg" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/06/last-of-us-part-2-w.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/06/last-of-us-part-2-w.jpg?fit=850%2C478&amp;ssl=1" title="And the winners of our The Last of Us Part II hampers are&hellip; 17">  </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/and-the-winners-of-our-the-last-of-us-part-ii-hampers-are/"><span>And the winners of our The Last of Us Part II hampers are&hellip;</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">June 26, 2020</span></div>
</footer>
<p class="block-exb">We’ve run all the entries through our handy dandy Randomiser 9000 Ultra Max, and we’ve picked three lucky winners who’ll be getting not only the game, but some sweet T-shirt swag as well. And those winners are...</p>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/win-one-of-three-the-last-of-us-part-ii-hampers/">
<img width="104" height="74" src="https://i2.wp.com/media.criticalhit.net//2020/06/tlou-3.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="Win one of three The Last of Us Part II hampers! 18" srcset="https://i2.wp.com/media.criticalhit.net//2020/06/tlou-3.jpg?resize=104%2C74&amp;ssl=1 104w, https://i1.wp.com/media.criticalhit.net/2020/06/tlou-3.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i1.wp.com/media.criticalhit.net/2020/06/tlou-3.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1073981" data-permalink="https://www.criticalhit.net/gaming/win-one-of-three-the-last-of-us-part-ii-hampers/attachment/tlou-3/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/06/tlou-3.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tlou-3" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/06/tlou-3.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/06/tlou-3.jpg?fit=850%2C478&amp;ssl=1" title="Win one of three The Last of Us Part II hampers! 18"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/win-one-of-three-the-last-of-us-part-ii-hampers/"><span>Win one of three The Last of Us Part II hampers!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">June 19, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/competition-win-one-of-20-everspace-2-prototype-codes/">
<img width="104" height="74" src="https://i1.wp.com/media.criticalhit.net//2020/05/Everspace-2-3.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="Competition: Win one of 20 Everspace 2 prototype codes! 19" srcset="https://i1.wp.com/media.criticalhit.net//2020/05/Everspace-2-3.jpg?resize=104%2C74&amp;ssl=1 104w, https://i1.wp.com/media.criticalhit.net/2020/05/Everspace-2-3.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i1.wp.com/media.criticalhit.net/2020/05/Everspace-2-3.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1062087" data-permalink="https://www.criticalhit.net/gaming/everspace-2-is-using-its-new-rpg-elements-to-explore-the-final-fun-tier/attachment/everspace-2-3-jpg/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/05/Everspace-2-3.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Everspace-2-3.jpg" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/05/Everspace-2-3.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/05/Everspace-2-3.jpg?fit=850%2C478&amp;ssl=1" title="Competition: Win one of 20 Everspace 2 prototype codes! 19"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/competition-win-one-of-20-everspace-2-prototype-codes/"><span>Competition: Win one of 20 Everspace 2 prototype codes!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">May 5, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/competitions/win-one-of-ten-free-double-tickets-to-the-rand-show-2020-and-rush/">
<img width="104" height="74" src="https://i2.wp.com/media.criticalhit.net//2020/03/Rush-Esports-b.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="Win one of ten free double tickets to The Rand Show 2020 and RUSH! 20" srcset="https://i2.wp.com/media.criticalhit.net//2020/03/Rush-Esports-b.jpg?resize=104%2C74&amp;ssl=1 104w, https://i2.wp.com/media.criticalhit.net/2020/03/Rush-Esports-b.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i2.wp.com/media.criticalhit.net/2020/03/Rush-Esports-b.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1052105" data-permalink="https://www.criticalhit.net/competitions/win-one-of-ten-free-double-tickets-to-the-rand-show-2020-and-rush/attachment/rush-esports-b/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/03/Rush-Esports-b.jpg?fit=2048%2C1364&amp;ssl=1" data-orig-size="2048,1364" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Rush-Esports-b" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/03/Rush-Esports-b.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/03/Rush-Esports-b.jpg?fit=850%2C566&amp;ssl=1" title="Win one of ten free double tickets to The Rand Show 2020 and RUSH! 20"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/competitions/win-one-of-ten-free-double-tickets-to-the-rand-show-2020-and-rush/"><span>Win one of ten free double tickets to The Rand Show 2020 and RUSH!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">March 12, 2020</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
</div>
<style type="text/css">#bdaia-widget-box2-2 .entry-title a:hover{color:#e90d8c !important;}#bdaia-widget-box2-2 .sk-circle .sk-child:before{background:#e90d8c !important;}#bdaia-widget-box2-2 .bdaia-wb-mb-inner{background:#e90d8c !important;}#bdaia-widget-box2-2 h4.block-title:before{background:#e90d8c !important;}#bdaia-widget-box2-2 h4.block-title span, #bdaia-widget-box2-2 h4.block-title a{color:#e90d8c !important;}</style></div></div><div id="bdaia-widget-box3-2" class="widget bdaia-widget bdaia-box3"><h4 class="block-title"><span>Features</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb3 bdaia-wb-idC0wHd bdaia-ajax-pagination-next_prev" data-box_nu="wb3" data-box_id="bdaia-wb-idC0wHd" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="4" data-tag_slug="" data-cat_uid="48449" data-cat_uids="" data-max_nu="276" data-total_posts_num="1101" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="" data-review="">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-box-row">
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/everything-announced-in-todays-xbox-series-x-showcase/">
<img width="320" height="220" src="https://i2.wp.com/media.criticalhit.net//2020/07/Halo.jpg?resize=320%2C220&amp;ssl=1" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="Everything announced in today&rsquo;s Xbox Series X Showcase 21" srcset="https://i2.wp.com/media.criticalhit.net//2020/07/Halo.jpg?resize=320%2C220&amp;ssl=1 320w, https://i0.wp.com/media.criticalhit.net/2020/07/Halo.jpg?zoom=2&amp;resize=320%2C220&amp;ssl=1 640w" sizes="(max-width: 320px) 100vw, 320px" data-attachment-id="1085370" data-permalink="https://www.criticalhit.net/gaming/everything-announced-in-todays-xbox-series-x-showcase/attachment/halo-2/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/07/Halo.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Halo" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/07/Halo.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/07/Halo.jpg?fit=850%2C478&amp;ssl=1" title="Everything announced in today&rsquo;s Xbox Series X Showcase 21"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/everything-announced-in-todays-xbox-series-x-showcase/"><span>Everything announced in today&rsquo;s Xbox Series X Showcase</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/rock-of-ages-3-review-the-great-terrain-robbery/">
<img width="320" height="220" src="https://i1.wp.com/media.criticalhit.net//2020/07/Rock-of-Ages-3-1.jpg?resize=320%2C220&amp;ssl=1" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="Rock of Ages 3 Review &ndash; The great terrain robbery 22" srcset="https://i1.wp.com/media.criticalhit.net//2020/07/Rock-of-Ages-3-1.jpg?resize=320%2C220&amp;ssl=1 320w, https://i0.wp.com/media.criticalhit.net/2020/07/Rock-of-Ages-3-1.jpg?zoom=2&amp;resize=320%2C220&amp;ssl=1 640w" sizes="(max-width: 320px) 100vw, 320px" data-attachment-id="1085316" data-permalink="https://www.criticalhit.net/gaming/rock-of-ages-3-review-the-great-terrain-robbery/attachment/rock-of-ages-3-1-jpg/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/07/Rock-of-Ages-3-1.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Rock-of-Ages-3-1.jpg" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/07/Rock-of-Ages-3-1.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/07/Rock-of-Ages-3-1.jpg?fit=850%2C478&amp;ssl=1" title="Rock of Ages 3 Review &ndash; The great terrain robbery 22"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/rock-of-ages-3-review-the-great-terrain-robbery/"><span>Rock of Ages 3 Review &ndash; The great terrain robbery</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
<div class="bdaia-box-row">
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/five-small-touches-that-makes-ghost-of-tsushima-feel-that-little-bit-more-special/">
<img width="320" height="220" src="https://i2.wp.com/media.criticalhit.net//2020/07/Ghost-of-Tsushima_20200721124624.jpg?resize=320%2C220&amp;ssl=1" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="Five small touches that makes Ghost of Tsushima feel that little bit more special 23" srcset="https://i2.wp.com/media.criticalhit.net//2020/07/Ghost-of-Tsushima_20200721124624.jpg?resize=320%2C220&amp;ssl=1 320w, https://i2.wp.com/media.criticalhit.net/2020/07/Ghost-of-Tsushima_20200721124624.jpg?zoom=2&amp;resize=320%2C220&amp;ssl=1 640w" sizes="(max-width: 320px) 100vw, 320px" data-attachment-id="1084675" data-permalink="https://www.criticalhit.net/gaming/five-small-touches-that-makes-ghost-of-tsushima-feel-that-little-bit-more-special/attachment/ghost-of-tsushima_20200721124624-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/07/Ghost-of-Tsushima_20200721124624.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ghost-of-Tsushima_20200721124624.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/07/Ghost-of-Tsushima_20200721124624.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/07/Ghost-of-Tsushima_20200721124624.jpg?fit=850%2C478&amp;ssl=1" title="Five small touches that makes Ghost of Tsushima feel that little bit more special 23"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/five-small-touches-that-makes-ghost-of-tsushima-feel-that-little-bit-more-special/"><span>Five small touches that makes Ghost of Tsushima feel that little bit more special</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/heres-everything-that-nintendo-announced-in-their-sweet-and-short-direct-yesterday/">
<img width="320" height="220" src="https://i2.wp.com/media.criticalhit.net//2020/07/Cadence-of-Hyrule.jpg?resize=320%2C220&amp;ssl=1" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="Here&rsquo;s everything that Nintendo announced in their sweet and short Direct yesterday 24" srcset="https://i2.wp.com/media.criticalhit.net//2020/07/Cadence-of-Hyrule.jpg?resize=320%2C220&amp;ssl=1 320w, https://i1.wp.com/media.criticalhit.net/2020/07/Cadence-of-Hyrule.jpg?zoom=2&amp;resize=320%2C220&amp;ssl=1 640w" sizes="(max-width: 320px) 100vw, 320px" data-attachment-id="1084569" data-permalink="https://www.criticalhit.net/gaming/heres-everything-that-nintendo-announced-in-their-sweet-and-short-direct-yesterday/attachment/cadence-of-hyrule-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/07/Cadence-of-Hyrule.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Cadence-of-Hyrule.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/07/Cadence-of-Hyrule.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/07/Cadence-of-Hyrule.jpg?fit=850%2C478&amp;ssl=1" title="Here&rsquo;s everything that Nintendo announced in their sweet and short Direct yesterday 24"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/heres-everything-that-nintendo-announced-in-their-sweet-and-short-direct-yesterday/"><span>Here&rsquo;s everything that Nintendo announced in their sweet and short Direct yesterday</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-idC0wHd .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'C0wHd', 'next' );
						});
						jQuery('.bdaia-wb-idC0wHd .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'C0wHd', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-e3-13" class="widget bdaia-widget bdaia-widget-e3 "><div class="widget-inner">
<div class="e3-inner"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/CH300BTF', [300, 250]).display();
</script></div></div>
</div> </div>
</div>
</div>
</div>
<div class="bdaia-footer-e3-desktop"><div class="bdaia-e3-container"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/728bottom', [728, 90]).display();
</script>
</div></div>
<div class="bdaia-footer">
<div class="bdaia-footer-widgets">
<div class="bd-container">
<div class="bdaia-footer-widgets-area footer-col-three">
<div id="footer-first" class="footer-widget-inner">
<div id="bdaia-widget-html-2" class="widget bdaia-widget bdaia-widget-html e3-trans"><h4 class="block-title"><span>About US</span></h4>
<div class="widget-inner">
<p>
<img src="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-White-1.png" alt="" />
</p>
<p style="margin-top:25px;">
Critical Hit is built on the idea that we are more than one thing. Are you a hardcore gamer who also enjoys a night out at the movies? Perhaps you’re a professional cosplayer who is searching for the perfect burger, or maybe you’re just interested in high-end tech and Netflix binging. Covering gaming, entertainment, tech and geek, Critical Hit offers information and critique from a staff of diverse, knowledgeable and fiercely opinionated writers. </p>
</div>
</div><div id="bdaia-social-links-6" class="widget bdaia-widget bdaia-social-links">
<h4 class="block-title"><span>Follow Us</span></h4>
<div class="widget-inner">
<div class="widget-social-links bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class="none bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class="none bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class="none bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class="none bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class="none bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</div> </div>
<div id="footer-second" class="footer-widget-inner">
<div id="bdaia-widget-box1-2" class="widget bdaia-widget bdaia-box1"><h4 class="block-title"><span>Read This</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb1 bdaia-wb-idCrkdd bdaia-ajax-pagination-" data-box_nu="wb1" data-box_id="bdaia-wb-idCrkdd" data-paged="1" data-sort_order="random_7_day" data-ajax_pagination="" data-num_posts="4" data-tag_slug="" data-cat_uid="" data-cat_uids="" data-max_nu="20" data-total_posts_num="80" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="true" data-date_meta="true" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/the-world-of-stalker-2-is-mysterious-dangerous-and-shaped-by-your-decisions/">
<img width="104" height="74" src="https://i0.wp.com/media.criticalhit.net//2020/07/stalker-2-3.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="The world of STALKER 2 is mysterious, dangerous and shaped by your decisions 25" srcset="https://i0.wp.com/media.criticalhit.net//2020/07/stalker-2-3.jpg?resize=104%2C74&amp;ssl=1 104w, https://i1.wp.com/media.criticalhit.net/2020/07/stalker-2-3.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i1.wp.com/media.criticalhit.net/2020/07/stalker-2-3.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1085496" data-permalink="https://www.criticalhit.net/gaming/the-world-of-stalker-2-is-mysterious-dangerous-and-shaped-by-your-decisions/attachment/stalker-2-3-jpg/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/07/stalker-2-3.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="stalker-2-3.jpg" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/07/stalker-2-3.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/07/stalker-2-3.jpg?fit=850%2C478&amp;ssl=1" title="The world of STALKER 2 is mysterious, dangerous and shaped by your decisions 25"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/the-world-of-stalker-2-is-mysterious-dangerous-and-shaped-by-your-decisions/"><span>The world of STALKER 2 is mysterious, dangerous and shaped by your decisions</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">July 24, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/technology/gross-kfc-looking-to-make-3d-bioprinted-chicken-nuggets/">
<img width="104" height="74" src="https://i0.wp.com/media.criticalhit.net//2020/07/kfc-chicken-nugget.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="KFC is looking to make 3D bio-printed chicken nuggets 26" srcset="https://i0.wp.com/media.criticalhit.net//2020/07/kfc-chicken-nugget.jpg?resize=104%2C74&amp;ssl=1 104w, https://i0.wp.com/media.criticalhit.net//2020/07/kfc-chicken-nugget.jpg?resize=632%2C450&amp;ssl=1 632w, https://i2.wp.com/media.criticalhit.net/2020/07/kfc-chicken-nugget.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i2.wp.com/media.criticalhit.net/2020/07/kfc-chicken-nugget.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1084343" data-permalink="https://www.criticalhit.net/technology/gross-kfc-looking-to-make-3d-bioprinted-chicken-nuggets/attachment/kfc-chicken-nugget/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/07/kfc-chicken-nugget.jpg?fit=800%2C450&amp;ssl=1" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="kfc-chicken-nugget" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/07/kfc-chicken-nugget.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/07/kfc-chicken-nugget.jpg?fit=800%2C450&amp;ssl=1" title="KFC is looking to make 3D bio-printed chicken nuggets 26"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/technology/gross-kfc-looking-to-make-3d-bioprinted-chicken-nuggets/"><span>KFC is looking to make 3D bio-printed chicken nuggets</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/craigrisi/" title="Posts by Craig Risi" rel="author">Craig Risi</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">July 20, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/a-replay-system-might-be-making-its-way-into-valorant/">
<img width="104" height="74" src="https://i2.wp.com/media.criticalhit.net//2020/07/valorant-review.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="A replay system might be making its way into Valorant 27" srcset="https://i2.wp.com/media.criticalhit.net//2020/07/valorant-review.jpg?resize=104%2C74&amp;ssl=1 104w, https://i2.wp.com/media.criticalhit.net/2020/07/valorant-review.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i2.wp.com/media.criticalhit.net/2020/07/valorant-review.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1084659" data-permalink="https://www.criticalhit.net/gaming/a-replay-system-might-be-making-its-way-into-valorant/attachment/valorant-review-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/07/valorant-review.jpg?fit=918%2C516&amp;ssl=1" data-orig-size="918,516" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="valorant-review.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/07/valorant-review.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/07/valorant-review.jpg?fit=850%2C478&amp;ssl=1" title="A replay system might be making its way into Valorant 27"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/a-replay-system-might-be-making-its-way-into-valorant/"><span>A replay system might be making its way into Valorant</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/blang/" title="Posts by Brad Lang" rel="author">Brad Lang</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">July 21, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/technology/alleged-ransomware-attack-behind-garmin-services-outage/">
<img width="104" height="74" src="https://i1.wp.com/media.criticalhit.net//2020/07/Garmin-Maintenance-1.jpg?resize=104%2C74&amp;ssl=1" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="Alleged ransomware attack behind Garmin services outage 28" srcset="https://i1.wp.com/media.criticalhit.net//2020/07/Garmin-Maintenance-1.jpg?resize=104%2C74&amp;ssl=1 104w, https://i0.wp.com/media.criticalhit.net/2020/07/Garmin-Maintenance-1.jpg?zoom=2&amp;resize=104%2C74&amp;ssl=1 208w, https://i0.wp.com/media.criticalhit.net/2020/07/Garmin-Maintenance-1.jpg?zoom=3&amp;resize=104%2C74&amp;ssl=1 312w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1085635" data-permalink="https://www.criticalhit.net/technology/alleged-ransomware-attack-behind-garmin-services-outage/attachment/garmin-maintenance-1/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/07/Garmin-Maintenance-1.jpg?fit=800%2C509&amp;ssl=1" data-orig-size="800,509" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Garmin-Maintenance-1" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/07/Garmin-Maintenance-1.jpg?fit=300%2C191&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/07/Garmin-Maintenance-1.jpg?fit=800%2C509&amp;ssl=1" title="Alleged ransomware attack behind Garmin services outage 28"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/technology/alleged-ransomware-attack-behind-garmin-services-outage/"><span>Alleged ransomware attack behind Garmin services outage</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/craigrisi/" title="Posts by Craig Risi" rel="author">Craig Risi</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">July 24, 2020</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
</div>
</div></div> </div>
<div id="footer-third" class="footer-widget-inner">
<div id="bdaia-widget-timeline-2" class="widget bdaia-widget bdaia-widget-timeline">
<h4 class="block-title"><span>Timeline</span></h4>
<div class="widget-inner">
<ul>
<li>
<a href="https://www.criticalhit.net/gaming/destiny-2-where-is-xur-and-whats-he-got-for-sale-july-24/">
<span class="bdayh-date">July 24, 2020</span> <h3>Destiny 2: Where is Xur (and whats he got for sale?) &ndash; July 24</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/technology/slack-files-anti-trust-complaint-against-microsoft-and-its-teams-product/">
<span class="bdayh-date">July 24, 2020</span> <h3>Slack files anti-trust complaint against Microsoft and its Teams product</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/technology/alleged-ransomware-attack-behind-garmin-services-outage/">
<span class="bdayh-date">July 24, 2020</span> <h3>Alleged ransomware attack behind Garmin services outage</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/gaming/watch-dogs-legions-new-resistance-trailer-is-more-of-the-same-but-james-bond-dies/">
<span class="bdayh-date">July 24, 2020</span> <h3>Watch Dogs: Legion&rsquo;s new &ldquo;Resistance&rdquo; trailer is more of the same, but James Bond dies</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/entertainment/comic-con-watch-the-first-trailer-for-amazons-ambitious-thriller-utopia/">
<span class="bdayh-date">July 24, 2020</span> <h3>Comic-Con: Watch the first-trailer for Amazon&#8217;s ambitious thriller Utopia</h3>
</a>
</li>
</ul>
</div>
</div> </div>
</div>
</div>
</div>
<div class="woohoo-footer-top-area" style="background-color:#000000;">
<div class="bd-container">
<div class="woohoo-footer-menu">
<div class="menu-footer-container"><ul id="menu-footer" class="footer-bottom-menu"><li id="menu-item-573845" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-573845"><a href="https://www.criticalhit.net/">Critical Hit</a></li>
<li id="menu-item-574303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574303"><a href="https://www.criticalhit.net/contact/">Contact</a></li>
<li id="menu-item-573839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-573839"><a href="https://www.criticalhit.net/advertise/">Advertise</a></li>
<li id="menu-item-574736" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574736"><a href="https://www.criticalhit.net/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-574795" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574795"><a href="https://www.criticalhit.net/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
</div>
</div>
<div class="bdaia-footer-area" style="background-color:#000000;">
<div class="bd-container">
<div class="bdaia-footer-area-l">
</div>
<div class="bdaia-footer-area-r">
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

<noscript><iframe src=\"https://www.googletagmanager.com/ns.html?id=GTM-5GNB24P\"
height=\"0\" width=\"0\" style=\"display:none;visibility:hidden\"></iframe></noscript>

<div class="gotop" title="Go Top"><span class="bdaia-io bdaia-io-chevron-up"></span></div><div id="reading-position-indicator"></div>
<script>
    </script>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.criticalhit.net\/entertainment\/first-images-and-plot-details-for-amazons-utopia-series-revealed\/":1084806};
	</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"critical-hit-net"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/disqus-comment-system/public/js/comment_count.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"1084806 https:\/\/www.criticalhit.net\/?p=1084806","disqusShortname":"critical-hit-net","disqusTitle":"First images and plot details for Amazon\u2019s Utopia series revealed","disqusUrl":"https:\/\/www.criticalhit.net\/entertainment\/first-images-and-plot-details-for-amazons-utopia-series-revealed\/","postId":"1084806"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/easy-table/js/easy-table-script.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bd = "{\"nonce\":\"52675af72f\",\"ajaxurl\":\"https:\\\/\\\/www.criticalhit.net\\\/wp-admin\\\/admin-ajax.php\",\"is_singular\":true,\"has_lazy_load\":false,\"bd_lazyload\":true,\"mobile_topmenu\":true,\"sticky_sidebar\":true,\"all_lightbox\":true,\"click_to_comments\":false,\"post_reading_position_indicator\":\"1\"}";
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/themes/woohoo/js/main.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/themes/woohoo/js/search.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","nonce":"4db1c7f382","display_exif":"0","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"white","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.criticalhit.net\/wp-login.php?redirect_to=https%3A%2F%2Fwww.criticalhit.net%2Fentertainment%2Ffirst-images-and-plot-details-for-amazons-utopia-series-revealed%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.7.1/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202030.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7.1',blog:'122131268',post:'1084806',tz:'2',srv:'www.criticalhit.net'} ]);
	_stq.push([ 'clickTrackerInit', '122131268', '1084806' ]);
</script>
</body>
</html>