<!DOCTYPE html>
<html lang="en-GB" prefix="og: http://ogp.me/ns#">
<head>

<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="6a9e0b5d-495a-45f8-95da-3962f059fa4e"></script>
<script type="text/javascript">
function OptanonWrapper() { }
</script>

<meta property="fb:pages" content="161755108961" />
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.criticalhit.net/xmlrpc.php" />
<title>Amazon&rsquo;s Lord of the Rings MMO has been cancelled according to new reports &#8211; Critical Hit</title>
<meta name='robots' content='max-image-preview:large' />

<meta name="google-site-verification" content="1vFejJFCT-gTHbz4YXtJrlWGHn4iBz-VmX1lyaF2QQ4" />
<link rel='dns-prefetch' href='//www.criticalhit.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; Feed" href="https://www.criticalhit.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; Comments Feed" href="https://www.criticalhit.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; Amazon&rsquo;s Lord of the Rings MMO has been cancelled according to new reports Comments Feed" href="https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.criticalhit.net\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='bdaia_shorty-style-css' href='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='formidable-css' href='https://www.criticalhit.net/wp-content/plugins/formidable/css/formidableforms.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.7.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://c0.wp.com/c/5.7.1/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='bdaia_shorty_stylesheet-css' href='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/shortcodes.css' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='theme-child-style-css' href='https://www.criticalhit.net/wp-content/themes/woohoo-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='woohoo-google-fonts-css' href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C300%2C700%7CLato%3A400%2C300%2C700%2C900%7CWork+Sans%3A400%2C300%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C600%2C700%2C800%7CPlayfair+Display%3A400%2C700%2C900%2C400italic%7CRaleway%3A400%2C300%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A400%2C300%2C100%2C700%7CMontserrat%3A400%2C700&#038;subset=latin%2Cgreek%2Cgreek-ext%2Cvietnamese%2Ccyrillic-ext%2Clatin-ext%2Ccyrillic' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css' href='https://www.criticalhit.net/wp-content/plugins/easy-table/themes/default/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='woohoo-default-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/style.css' type='text/css' media='all' />
<style id='woohoo-default-inline-css' type='text/css'>
body.category-41989 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-5 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-33983 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-41988 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-34107 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-58 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-41990 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-38 div.bdaia-blocks div.bdaia-post-view{display: none !important;}
</style>
<link rel='stylesheet' id='wooohoo-ilightbox-skin-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='wooohoo-ilightbox-skin-black-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/ilightbox/metro-black-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://c0.wp.com/p/jetpack/9.6.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/9.6.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' id='jquery-core-js-extra'>
/* <![CDATA[ */
var bd_w_blocks = {"bdaia_w_ajax_url":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","bdaia_w_ajax_nonce":"ab1128b2ce"};
var bd_blocks = {"bdaia_ajax_url":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","bdaia_ajaxnonce":"ab1128b2ce"};
var bd_script = {"post_id":"1148628","ajaxurl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.7.1/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.7.1/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/js/scripts.js' id='bdaia_shorty_scripts-js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/js/shorty-min.js' id='bdaia_shorty_min-js'></script>
<link rel="https://api.w.org/" href="https://www.criticalhit.net/wp-json/" /><link rel="alternate" type="application/json" href="https://www.criticalhit.net/wp-json/wp/v2/posts/1148628" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.criticalhit.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.criticalhit.net/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.7.1" />
<link rel="canonical" href="https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/" />
<link rel='shortlink' href='https://www.criticalhit.net/?p=1148628' />
<link rel="alternate" type="application/json+oembed" href="https://www.criticalhit.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Famazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.criticalhit.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Famazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.30.0" /><style type='text/css'>img#wpstats{display:none}</style>
<script type="text/javascript">
            /* <![CDATA[ */
            var sf_position = '0';
            var sf_templates = "<a href=\"{search_url_escaped}\"><span class=\"sf_text\">View All Results<\/span><\/a>";
            var sf_input = '.search-live';
            jQuery(document).ready(function(){
                jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/www.criticalhit.net\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","rtl":0});
                jQuery(".live-search_ajaxy-selective-input").keyup(function() {
                    var width = jQuery(this).val().length * 8;
                    if(width < 50) {
                        width = 50;
                    }
                    jQuery(this).width(width);
                });
                jQuery(".live-search_ajaxy-selective-search").click(function() {
                    jQuery(this).find(".live-search_ajaxy-selective-input").focus();
                });
                jQuery(".live-search_ajaxy-selective-close").click(function() {
                    jQuery(this).parent().remove();
                });
            });
            /* ]]> */
        </script>
<link rel="shortcut icon" href="https://media.criticalhit.net/2018/12/favicon.png" type="image/x-icon" />
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-89232854-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-89232854-1');
</script>
<script data-ad-client="ca-pub-1473612930314813" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<style>

@media all and (min-device-width: 700px) and (max-device-width: 728px) {#leaderboard-pixfuture {transform: scale(0.9);}} @media all and (min-device-width: 671px) and (max-device-width: 699px) {#leaderboard-pixfuture {transform: scale(0.9);transform-origin: 0 0;}} @media all and (min-device-width: 651px) and (max-device-width: 670px) {#leaderboard-pixfuture {transform: scale(0.88);transform-origin: 0 0;}} @media all and (min-device-width: 631px) and (max-device-width: 650px) {#leaderboard-pixfuture {transform: scale(0.85);transform-origin: 0 0;}} @media all and (min-device-width: 601px) and (max-device-width: 630px) {#leaderboard-pixfuture {transform: scale(0.8);transform-origin: 0 0;}} @media all and (min-device-width: 601px) and (max-device-width: 630px) {#leaderboard-pixfuture {transform: scale(0.8);transform-origin: 0 0;}} @media all and (min-device-width: 560px) and (max-device-width: 600px) {#leaderboard-pixfuture {transform: scale(0.75);transform-origin: 0 0;}} @media all and (min-device-width: 520px) and (max-device-width: 559px) {#leaderboard-pixfuture {transform: scale(0.7);transform-origin: 0 0;}} @media all and (min-device-width: 491px) and (max-device-width: 519px) {#leaderboard-pixfuture {transform: scale(0.65);transform-origin: 0 0;}} @media all and (min-device-width: 451px) and (max-device-width: 490px) {#leaderboard-pixfuture {transform: scale(0.6);transform-origin: 0 0;}} @media all and (min-device-width: 401px) and (max-device-width: 450px) {#leaderboard-pixfuture {transform: scale(0.55);transform-origin: 0 0;}} @media all and (min-device-width: 371px) and (max-device-width: 400px) {#leaderboard-pixfuture {transform: scale(0.5);transform-origin: 0 0;}} @media all and (min-device-width: 341px) and (max-device-width: 370px) {#leaderboard-pixfuture {transform: scale(0.46);transform-origin: 0 0;}} @media all and (min-device-width: 301px) and (max-device-width: 340px) {#leaderboard-pixfuture {transform: scale(0.42);transform-origin: 0 0;}} @media all and (max-device-width: 300px) {#leaderboard-pixfuture {transform: scale(0.4);transform-origin: 0 0;}}

</style>
<script type="text/javascript">
/* <![CDATA[ */
var userRating = {"ajaxurl":"https://www.criticalhit.net/wp-admin/admin-ajax.php" , "your_rating":"" , "nonce":"ab1128b2ce"};
var userLike = {"ajaxurl":"https://www.criticalhit.net/wp-admin/admin-ajax.php" , "nonce":"ab1128b2ce"};
/* ]]> */
var bdaia_theme_uri = 'https://www.criticalhit.net/wp-content/themes/woohoo';
</script>
<style type="text/css">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</style><meta name="google-site-verification" content="oaOpgh_1OG0g963kfPRsU8QMMrkWBD1cAC_zyhXnAvc"><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style> <style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>

<meta property="og:type" content="article" />
<meta property="og:title" content="Amazon&rsquo;s Lord of the Rings MMO has been cancelled according to new reports" />
<meta property="og:url" content="https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/" />
<meta property="og:description" content="Deep in the land of Amazon game studios, in the Fires of Mount Overtime, the Dark Lord Bezos forged a master game, and into this game he poured all of his cruelty, his malice and his will to kill a…" />
<meta property="article:published_time" content="2021-04-19T06:30:00+00:00" />
<meta property="article:modified_time" content="2021-04-19T05:40:14+00:00" />
<meta property="og:site_name" content="Critical Hit" />
<meta property="og:image" content="https://i1.wp.com/media.criticalhit.net//2021/04/Gollum.jpg?fit=850%2C425&amp;ssl=1" />
<meta property="og:image:width" content="850" />
<meta property="og:image:height" content="425" />
<meta property="og:locale" content="en_GB" />
<meta name="twitter:creator" content="@CriticalHitNet" />
<meta name="twitter:site" content="@CriticalHitNet" />
<meta name="twitter:text:title" content="Amazon&rsquo;s Lord of the Rings MMO has been cancelled according to new reports" />
<meta name="twitter:image" content="https://i1.wp.com/media.criticalhit.net//2021/04/Gollum.jpg?fit=850%2C425&#038;ssl=1&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<link rel="icon" href="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=270%2C270&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">
				.bdaia-post-content blockquote p,
blockquote p  {
  font-size: 20px !important;
  background: #f9f9f9 !important;
  border-left: 10px solid #ccc !important;
  margin: .5em 10px !important;
  padding: 0 10px !important;
  quotes: "\201C""\201D""\2018""\2019" !important;
  padding: 10px 20px !important;
  line-height: 1.4 !important;
	text-transform: none !important;
	color: grey  !important;
	text-align: left !important;
	font-weight: 300 !important;
}

.bdaia-post-content blockquote, blockquote {
    margin: 20px 5px 10px 0px !important;
	    padding-left: 0px !important;
    border-left: none !important;
}

.wp-block-jetpack-gif .wp-block-jetpack-gif-caption {
    color: #ffffff !important;
    font-weight: bold;
}			</style>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<meta name="msvalidate.01" content="2408EBF25A6FABECCCF3EC45230C1258" />
<script>
!function(a){var b=/iPhone/i,c=/iPod/i,d=/iPad/i,e=/(?=.*\bAndroid\b)(?=.*\bMobile\b)/i,f=/Android/i,g=/(?=.*\bAndroid\b)(?=.*\bSD4930UR\b)/i,h=/(?=.*\bAndroid\b)(?=.*\b(?:KFOT|KFTT|KFJWI|KFJWA|KFSOWI|KFTHWI|KFTHWA|KFAPWI|KFAPWA|KFARWI|KFASWI|KFSAWI|KFSAWA)\b)/i,i=/IEMobile/i,j=/(?=.*\bWindows\b)(?=.*\bARM\b)/i,k=/BlackBerry/i,l=/BB10/i,m=/Opera Mini/i,n=/(CriOS|Chrome)(?=.*\bMobile\b)/i,o=/(?=.*\bFirefox\b)(?=.*\bMobile\b)/i,p=new RegExp("(?:Nexus 7|BNTV250|Kindle Fire|Silk|GT-P1000)","i"),q=function(a,b){return a.test(b)},r=function(a){var r=a||navigator.userAgent,s=r.split("[FBAN");return"undefined"!=typeof s[1]&&(r=s[0]),s=r.split("Twitter"),"undefined"!=typeof s[1]&&(r=s[0]),this.apple={phone:q(b,r),ipod:q(c,r),tablet:!q(b,r)&&q(d,r),device:q(b,r)||q(c,r)||q(d,r)},this.amazon={phone:q(g,r),tablet:!q(g,r)&&q(h,r),device:q(g,r)||q(h,r)},this.android={phone:q(g,r)||q(e,r),tablet:!q(g,r)&&!q(e,r)&&(q(h,r)||q(f,r)),device:q(g,r)||q(h,r)||q(e,r)||q(f,r)},this.windows={phone:q(i,r),tablet:q(j,r),device:q(i,r)||q(j,r)},this.other={blackberry:q(k,r),blackberry10:q(l,r),opera:q(m,r),firefox:q(o,r),chrome:q(n,r),device:q(k,r)||q(l,r)||q(m,r)||q(o,r)||q(n,r)},this.seven_inch=q(p,r),this.any=this.apple.device||this.android.device||this.windows.device||this.other.device||this.seven_inch,this.phone=this.apple.phone||this.android.phone||this.windows.phone,this.tablet=this.apple.tablet||this.android.tablet||this.windows.tablet,"undefined"==typeof window?this:void 0},s=function(){var a=new r;return a.Class=r,a};"undefined"!=typeof module&&module.exports&&"undefined"==typeof window?module.exports=r:"undefined"!=typeof module&&module.exports&&"undefined"!=typeof window?module.exports=s():"function"==typeof define&&define.amd?define("isMobile",[],a.isMobile=s()):a.isMobile=s()}(this);
  googletag.cmd.push(function() {
	if(isMobile.any) {
	googletag.defineSlot('/55341649/300250MidarticleMobile', [300, 250],
		'div-gpt-ad-1540807120663-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/300x250ACmobile', [300, 250],
	    'div-gpt-ad-1540807963183-0').addService(googletag.pubads());
			googletag.defineSlot('/55341649/MastheadTop', [728, 90],
			'div-gpt-ad-1542102676397-0').addService(googletag.pubads());

	} else {
	googletag.defineSlot('/55341649/MastheadTop', [728, 90],
	'div-gpt-ad-1542102676397-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/728MidArticle', [728, 90],
			'div-gpt-ad-1540806613519-0').addService(googletag.pubads());
  googletag.defineSlot('/55341649/728Comments', [728, 90],
	    'div-gpt-ad-1540808126586-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/Background', [1, 1],
		'div-gpt-ad-1540376831756-0').addService(googletag.pubads());

    }
	googletag.enableServices();
  });
</script>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "WebSite",
  "url": "https://www.criticalhit.net/",
  "name": "Critical Hit",
  "description": "Critical Hit is a website built on the idea that we are more than one thing. Writers, writing about the things they love; games, film, TV, technology and more.",
  "publisher": "Critical Hit",
  "potentialAction": {
    "@type": "SearchAction",
    "target": "https://www.criticalhit.net/?s={search_term}",
    "query-input": "required name=search_term" }
    }
</script>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "Organization",
  "url": "https://www.criticalhit.net",
  "logo": "https://www.criticalhit.net/images/Icon.png"
}
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-1473612930314813",
          enable_page_level_ads: false
     });
</script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.flexslider-min.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.eislideshow.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.placeholder.min.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.fitvids.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/modernizr.js"></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/criticalhit/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
</head>
<body class="post-template-default single single-post postid-1148628 single-format-standard wp-embed-responsive bdaia-boxed  of-new-article  has-lazy-load" itemscope itemtype="http://schema.org/WebPage">
<div class="page-outer bdaia-header-default bdaia-lazyload  sticky-nav-on  bdaia-post-template-default  bdaia-sidebar-right ">
<div class="bg-cover"></div>
<aside id="bd-MobileSiderbar">
<div id="mobile-menu"></div>
<div class="widget-social-links bdaia-social-io-colored">
<div class="sl-widget-inner">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class=" bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class=" bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class=" bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class=" bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class=" bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</aside>

<div id='div-gpt-ad-1540376831756-0' style='height:1px; width:1px;'>
<script>
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540376831756-0'); });
	</script>
</div>
<div id="page">
<div class="inner-wrapper">
<div id="warp" class="clearfix  bdaia-sidebar-right ">
<div class="header-wrapper">
<div class="bdayh-click-open">
<div class="bd-ClickOpen bd-ClickAOpen">
<span></span>
</div>
</div>
<header class="header-container">
<div class="bd-container">
<div class="logo site--logo">
<h2 class="site-title"> <a href="https://www.criticalhit.net/" rel="home" title="Critical Hit">
<img src="https://media.criticalhit.net/2016/12/Critical_Hit-Logo-Gaming.png" alt="Critical Hit" />
</a>
</h2> </div>
<div class="bdaia-header-e3-desktop"><div class="bdaia-e3-container"> <div id="leaderboard-pixfuture" style="width:728px; margin:0 auto;">
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<div id="gpt-passback">
<script>
    window.googletag = window.googletag || {cmd: []};
    googletag.cmd.push(function() {
    googletag.defineSlot('/55341649/MastheadTop', [728, 90], 'gpt-passback').addService(googletag.pubads());
    googletag.enableServices();
    googletag.display('gpt-passback');
    });
  </script>
</div>
</div></div></div>
</div>
</header>
<div class="cfix"></div>
<nav id="navigation" class="">
<div class="navigation-wrapper">
<div class="bd-container">
<div class="primary-menu">
<a class="nav-logo" title="Critical Hit" href="https://www.criticalhit.net/">
<img src="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-Text-Only.png" width="195" height="48" alt="Critical Hit" />
</a>
<ul id="menu-primary">
<li id="menu-item-526858" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/gaming/"> <i class="fa fa fa-gamepad"></i> <span class="menu-label" style="">Games</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526854" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/entertainment/"> <i class="fa fa fa-film"></i> <span class="menu-label" style="">Entertainment</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526870" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/technology/"> <i class="fa fa fa-power-off"></i> <span class="menu-label" style="">Tech</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526876" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/comics-toys/"> <i class="fa fa fa-comment-o"></i> <span class="menu-label" style="">Comics</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526860" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/lifestyle/"> <i class="fa fa fa-heart"></i> <span class="menu-label" style="">Lifestyle</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-881926" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/review/"> <i class="fa fa fa-book"></i> <span class="menu-label" style="">Reviews</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-1135239" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/gaming/podcast/"> <span class="menu-label" style="">The Podcast</span></a>
<div class="mega-menu-content">
</div> </ul>
</div>
<div class="nav-right-area">
<div class="bdaia-nav-search">
<span class="bdaia-ns-btn bdaia-io bdaia-io-search"></span>
<div class="bdaia-ns-wrap">
<div class="bdaia-ns-content">
<div class="bdaia-ns-inner">
<form method="get" id="searchform" action="https://www.criticalhit.net/">
<input type="text" class="bbd-search-field search-live" id="s" name="s" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}" />
<button type="submit" class="bbd-search-btn"><span class="bdaia-io bdaia-io-search"></span></button>
</form>
</div>
</div>
</div>
</div>
</div>
<div class="cfix"></div>
</div>
</div>
</nav>
<div class="cfix"></div>
</div>
<div class="bdMain">
<div class="bd-container bdaia-post-template">
<div class="bd-main bdaia-site-content" id="bdaia-primary">
<div id="content" role="main">
<div class="bdaia-crumb-container"><span><a class="crumbs-home" href="https://www.criticalhit.net">Home</a></span> <span class="delimiter"><span class="bdaia-io bdaia-io-angle-double-right"></span></span> <span><a href="https://www.criticalhit.net/category/gaming/">Gaming</a></span> <span class="delimiter"><span class="bdaia-io bdaia-io-angle-double-right"></span></span> <span class="current">Amazon&rsquo;s Lord of the Rings MMO has been cancelled according to new reports</span></div><div class="bdayh-clearfix"></div>
<article id="post-1148628" class="hentry post-1148628 post type-post status-publish format-standard has-post-thumbnail category-gaming tag-gaming tag-gollum tag-lord-of-the-rings tag-mmo tag-pc tag-ps4 tag-ps5 tag-timeslive tag-xbox-one tag-xbox-series-x" itemscope itemtype="https://schema.org/Article">
<header class="bdaia-post-header">
<div class="bdaia-post-title">
<h1 class="post-title entry-title"><span>Amazon&rsquo;s Lord of the Rings MMO has been cancelled according to new reports</span></h1>
</div>

<div class="bdaia-meta-info">
<div class="bdaia-post-author-name">
By <a href="https://www.criticalhit.net/author/dbonthuys/" title="">Darryn Bonthuys </a>
</div>
<div class="bdaia-post-date"><span class='bdaia-io bdaia-io-calendar'></span>Posted on&nbsp;<span class="bdayh-date">10 hours ago</span></div>
<div class="bdaia-post-time-read"><span class='bdaia-io bdaia-io-clock'></span>2&nbsp;min read</div>
<div class="bdaia-post-comment"><span class='bdaia-io bdaia-io-bubbles4'></span><a href="https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/#respond"><span class="dsq-postid" data-dsqidentifier="1148628 https://www.criticalhit.net/?p=1148628">0</span></a></div>
</div>

</header>
<div class="bdaia-post-sharing bdaia-post-sharing-top">
<ul>
<li class="facebook">
<a title="facebook" onClick="window.open('http://www.facebook.com/sharer.php?u=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/">
<span class="bdaia-io bdaia-io-facebook"></span>
<span>Share on Facebook</span>
</a>
</li>
<li class="twitter">
<a title="twitter" onClick="window.open('http://twitter.com/share?url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/&amp;text=Amazon&rsquo;s%20Lord%20of%20the%20Rings%20MMO%20has%20been%20cancelled%20according%20to%20new%20reports','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/&amp;text=Amazon&rsquo;s%20Lord%20of%20the%20Rings%20MMO%20has%20been%20cancelled%20according%20to%20new%20reports">
<span class="bdaia-io bdaia-io-twitter"></span>
<span>Share on Twitter</span>
</a>
</li>
<li class="google">
<a title="google" onClick="window.open('https://plus.google.com/share?url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/">
<span class="bdaia-io bdaia-io-google-plus"></span>
<span>Share on Google+</span>
</a>
</li>
<li class="reddit">
<a title="reddit" onClick="window.open('http://reddit.com/submit?url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/&amp;title=Amazon&rsquo;s%20Lord%20of%20the%20Rings%20MMO%20has%20been%20cancelled%20according%20to%20new%20reports','Reddit','width=617,height=514,left='+(screen.availWidth/2-308)+',top='+(screen.availHeight/2-257)+''); return false;" href="https://reddit.com/submit?url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/&amp;title=Amazon&rsquo;s%20Lord%20of%20the%20Rings%20MMO%20has%20been%20cancelled%20according%20to%20new%20reports">
<span class="bdaia-io bdaia-io-reddit"></span>
<span>Share on Reddit</span>
</a>
</li>
<li class="pinterest">
<a title="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Famazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports%2F&amp;description=Amazon%26rsquo%3Bs+Lord+of+the+Rings+MMO+has+been+cancelled+according+to+new+reports&amp;media=https%3A%2F%2Fi1.wp.com%2Fmedia.criticalhit.net%2F%2F2021%2F04%2FGollum.jpg%3Ffit%3D850%252C425%26ssl%3D1">
<span class="bdaia-io bdaia-io-social-pinterest"></span>
<span>Share on Pinterest</span>
</a>
</li>
<li class="linkedin">
<a title="linkedin" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/">
<span class="bdaia-io bdaia-io-linkedin2"></span>
<span>Share on Linkedin</span>
</a>
</li>
<li class="tumblr">
<a title="tumblr" onClick="window.open('http://www.tumblr.com/share/link?url=www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/&amp;name=Amazon&rsquo;s%20Lord%20of%20the%20Rings%20MMO%20has%20been%20cancelled%20according%20to%20new%20reports','Tumblr','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.tumblr.com/share/link?url=www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/&amp;name=Amazon&rsquo;s%20Lord%20of%20the%20Rings%20MMO%20has%20been%20cancelled%20according%20to%20new%20reports">
<span class="bdaia-io bdaia-io-tumblr"></span>
<span>Share on Tumblr</span>
</a>
</li>
<li class="whatsapp">
<a href="whatsapp://send?text=Deep+in+the+land+of+Amazon+game+studios%2C+in+the+Fires+of+Mount+Overtime%2C+the+Dark+Lord+Bezos+forged+a+master+game%2C+and+into+this+game+he+poured+all+of+his+cruelty%2C+his+malice+and+his+will+to+kill+all+efforts+for+his+employees+to+form+a+union.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Famazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports%2F"><span class="bdaia-io bdaia-io-whatsapp"></span></a> </li>
<li class="telegram">
<a href="tg://msg?text=Deep+in+the+land+of+Amazon+game+studios%2C+in+the+Fires+of+Mount+Overtime%2C+the+Dark+Lord+Bezos+forged+a+master+game%2C+and+into+this+game+he+poured+all+of+his+cruelty%2C+his+malice+and+his+will+to+kill+all+efforts+for+his+employees+to+form+a+union.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Famazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports%2F"><span class="bdaia-io bdaia-io-telegram"></span></a> </li>
</ul>
</div>

<div class="bdaia-post-content">
<figure class="wp-block-image"><img src="https://i1.wp.com/media.criticalhit.net//2021/04/Gollum.jpg?w=850&#038;ssl=1" alt="Gollum" title="Gollum" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/media.criticalhit.net//2021/04/Gollum.jpg?w=850&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i1.wp.com/media.criticalhit.net//2021/04/Gollum.jpg?w=850&#038;ssl=1" alt="Gollum" title="Gollum" data-recalc-dims="1"/></noscript></figure>
<p>It began with the forging of the great game ideas. Three projects were given to the immortal, wisest and fairest of all studios. Seven projects were handed great genre-miners and craftsmen of the mountain halls. And nine, nine game projects were gifted to the race of men, who above all else desire power.</p>
<p>For within these rings was bound the strength and the will to govern each video game development period. But they were all of them deceived, for another game was being made. Deep in the land of Amazon game studios, in the Fires of Mount Overtime, the Dark Lord Bezos forged a master game, and into this game he poured all of his cruelty, his malice and his will to kill all efforts for his employees to form a union.</p>
<p>And it looks like that game has been plunged back into the fires from whence it came! Amazon’s Lord of the Rings MMO, which was announced way back in 2019, is reportedly deader than Boromir after a contract dispute with Chinese giant Tencent and co-developer Leyou Technologies emerged. <a href="https://www.bloomberg.com/news/articles/2021-04-17/amazon-cancels-lord-of-the-rings-game-announced-two-years-ago" data-type="URL" data-id="https://www.bloomberg.com/news/articles/2021-04-17/amazon-cancels-lord-of-the-rings-game-announced-two-years-ago">According to a Bloomberg report</a>, Amazon and Tencent couldn’t reach an agreement, eventually hitting the brakes on the project.</p>
<p>Apparently designed as a free-to-play MMO, the Lord of the Rings game would have arrived on console and PC if it had been completed but has instead become yet another example of Amazon’s rocky venture into the world of gaming. Breakaway and Crucible got hit with the big ol’ cancel button, and the MMO New World has been repeatedly delayed. It’s now scheduled for an August release, but we’ll see.</p><div class="fxgrw607db5805fd65"><div id='div-gpt-ad-1540806613519-0' style='width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540806613519-0'); });
</script>
</div>
<div id='div-gpt-ad-1540807120663-0' tyle='margin:auto; width:320px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540807120663-0'); });
</script>
</div>
</div><style type="text/css">
.fxgrw607db5805fd65 {
margin: 5px; padding: 0px;
}
@media screen and (min-width: 1201px) {
.fxgrw607db5805fd65 {
display: block;
}
}
@media screen and (min-width: 993px) and (max-width: 1200px) {
.fxgrw607db5805fd65 {
display: block;
}
}
@media screen and (min-width: 769px) and (max-width: 992px) {
.fxgrw607db5805fd65 {
display: block;
}
}
@media screen and (min-width: 768px) and (max-width: 768px) {
.fxgrw607db5805fd65 {
display: block;
}
}
@media screen and (max-width: 767px) {
.fxgrw607db5805fd65 {
display: block;
}
}
</style>
<p>As for the folks working on the game, it looks like the internal members from the Amazon side have been shifted to other projects. Leyou Technologies is the parent company of Warframe developer Digital Extremes and Gears Tactics studio Splash Damage, plus it owns a stake in Halo support studio Certain Affinity so it’ll probably be fine.</p>
<p>Tencent is still a gargantuan beast with its fingers in many profitable pies, like this little game called League of Legends. Maybe you’ve heard about it. That’s not to say that you won’t expect any Lord of the Rings content in the future, <a href="https://www.criticalhit.net/entertainment/amazons-the-lord-of-the-rings-tv-series-gets-a-full-synopsis-season-plans-revealed/" data-type="post" data-id="1123798">as Amazon still has a TV series</a> with a half-billion-dollar price tag attached to it in development, and <a href="https://www.criticalhit.net/gaming/the-lord-of-the-rings-gollum-has-been-delayed-to-2022/" data-type="post" data-id="1127130">there’s a solo video game</a> starring everyone’s favourite ring-chaser on the way.</p>
<p>Last Updated: <span class="updated">April 19, 2021</span></p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-1148628" class="share-twitter sd-button share-icon" href="https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-1148628" class="share-facebook sd-button share-icon" href="https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-end"></li></ul></div></div></div>
</div>
<footer>
<div class="bdaia-post-sharing bdaia-post-sharing-bottom">
<ul>
<li class="facebook">
<a title="facebook" onClick="window.open('http://www.facebook.com/sharer.php?u=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/">
<span class="bdaia-io bdaia-io-facebook"></span>
<span>Share on Facebook</span>
</a>
</li>
<li class="twitter">
<a title="twitter" onClick="window.open('http://twitter.com/share?url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/&amp;text=Amazon&rsquo;s%20Lord%20of%20the%20Rings%20MMO%20has%20been%20cancelled%20according%20to%20new%20reports','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/&amp;text=Amazon&rsquo;s%20Lord%20of%20the%20Rings%20MMO%20has%20been%20cancelled%20according%20to%20new%20reports">
<span class="bdaia-io bdaia-io-twitter"></span>
<span>Share on Twitter</span>
</a>
</li>
<li class="google">
<a title="google" onClick="window.open('https://plus.google.com/share?url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/">
<span class="bdaia-io bdaia-io-google-plus"></span>
<span>Share on Google+</span>
</a>
</li>
<li class="reddit">
<a title="reddit" onClick="window.open('http://reddit.com/submit?url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/&amp;title=Amazon&rsquo;s%20Lord%20of%20the%20Rings%20MMO%20has%20been%20cancelled%20according%20to%20new%20reports','Reddit','width=617,height=514,left='+(screen.availWidth/2-308)+',top='+(screen.availHeight/2-257)+''); return false;" href="https://reddit.com/submit?url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/&amp;title=Amazon&rsquo;s%20Lord%20of%20the%20Rings%20MMO%20has%20been%20cancelled%20according%20to%20new%20reports">
<span class="bdaia-io bdaia-io-reddit"></span>
<span>Share on Reddit</span>
</a>
</li>
<li class="pinterest">
<a title="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Famazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports%2F&amp;description=Amazon%26rsquo%3Bs+Lord+of+the+Rings+MMO+has+been+cancelled+according+to+new+reports&amp;media=https%3A%2F%2Fi1.wp.com%2Fmedia.criticalhit.net%2F%2F2021%2F04%2FGollum.jpg%3Ffit%3D850%252C425%26ssl%3D1">
<span class="bdaia-io bdaia-io-social-pinterest"></span>
<span>Share on Pinterest</span>
</a>
</li>
<li class="linkedin">
<a title="linkedin" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/">
<span class="bdaia-io bdaia-io-linkedin2"></span>
<span>Share on Linkedin</span>
</a>
</li>
<li class="tumblr">
<a title="tumblr" onClick="window.open('http://www.tumblr.com/share/link?url=www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/&amp;name=Amazon&rsquo;s%20Lord%20of%20the%20Rings%20MMO%20has%20been%20cancelled%20according%20to%20new%20reports','Tumblr','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.tumblr.com/share/link?url=www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/&amp;name=Amazon&rsquo;s%20Lord%20of%20the%20Rings%20MMO%20has%20been%20cancelled%20according%20to%20new%20reports">
<span class="bdaia-io bdaia-io-tumblr"></span>
<span>Share on Tumblr</span>
</a>
</li>
<li class="whatsapp">
<a href="whatsapp://send?text=Deep+in+the+land+of+Amazon+game+studios%2C+in+the+Fires+of+Mount+Overtime%2C+the+Dark+Lord+Bezos+forged+a+master+game%2C+and+into+this+game+he+poured+all+of+his+cruelty%2C+his+malice+and+his+will+to+kill+all+efforts+for+his+employees+to+form+a+union.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Famazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports%2F"><span class="bdaia-io bdaia-io-whatsapp"></span></a> </li>
<li class="telegram">
<a href="tg://msg?text=Deep+in+the+land+of+Amazon+game+studios%2C+in+the+Fires+of+Mount+Overtime%2C+the+Dark+Lord+Bezos+forged+a+master+game%2C+and+into+this+game+he+poured+all+of+his+cruelty%2C+his+malice+and+his+will+to+kill+all+efforts+for+his+employees+to+form+a+union.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Famazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports%2F"><span class="bdaia-io bdaia-io-telegram"></span></a> </li>
</ul>
</div>

<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'alternating-thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>
<div class="bdaia-author-box">
<div class="authorBlock-avatar">
<a href="https://www.criticalhit.net/author/dbonthuys/"><img src="https://secure.gravatar.com/avatar/f29c2b82775c8feedeae3045ca4a11c8?s=150&#038;d=mm&#038;r=pg" width="150" height="150" alt="Avatar" class="avatar avatar-150 wp-user-avatar wp-user-avatar-150 photo avatar-default jetpack-lazy-image" data-lazy-src="https://secure.gravatar.com/avatar/f29c2b82775c8feedeae3045ca4a11c8?s=150&amp;is-pending-load=1#038;d=mm&#038;r=pg" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img src="https://secure.gravatar.com/avatar/f29c2b82775c8feedeae3045ca4a11c8?s=150&#038;d=mm&#038;r=pg" width="150" height="150" alt="Avatar" class="avatar avatar-150 wp-user-avatar wp-user-avatar-150 photo avatar-default" /></noscript></a>
</div>
<div class="authorBlock-header">
<h3 class="authorBlock-header-title">
<a href="https://www.criticalhit.net/author/dbonthuys/">Darryn Bonthuys </h3>
<p class="authorBlock-header-bio">
Word-slinger at Critical Hit. Inventor of the macho Swiss gym chocolate known as Testoblerone. That's...that's about it really. </p>
<div class="authorBlock-meta bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-32">
</div>
</div>
</div>
</div>
 </footer>
<span style=display:none itemprop=author itemscope itemtype="https://schema.org/Person">
<meta itemprop=name content="Darryn Bonthuys">
</span>
<meta itemprop=interactionCount content="UserComments:0">
<meta itemprop=datePublished content="2021-04-19T08:30:00+00:00">
<meta itemprop=dateModified content="2021-04-19T08:30:00+00:00">
<meta itemscope itemprop=mainEntityOfPage itemtype="https://schema.org/WebPage" itemid="https://www.criticalhit.net/gaming/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports/">
<span style=display:none itemprop=publisher itemscope itemtype="https://schema.org/Organization">
<span style=display:none itemprop=logo itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-Main.png">
</span>
<meta itemprop=name content="Critical Hit">
</span>
<meta itemprop=headline content="Amazon&rsquo;s Lord of the Rings MMO has been cancelled according to new reports">
<span style=display:none itemprop=image itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop=url content="https://i1.wp.com/media.criticalhit.net//2021/04/Gollum.jpg?fit=850%2C425&#038;ssl=1">
<meta itemprop=width content=1240>
<meta itemprop=height content=540>
</span>
</article>
<div id="disqus_thread"></div>
<section id="bdCheckAlso" class="bdCheckAlso-right">
<h4 class="block-title">
<span>Check Also</span>
<a href="#" id="check-also-close"><span class="bdaia-io bdaia-io-cross"></span></a>
</h4>
<div class="check-also-post">
<figure class="check-also-thumb" style="background-image:url(https://i2.wp.com/media.criticalhit.net//2021/04/Damn-Daniel.jpg?resize=320%2C220&ssl=1);"></figure>
<h2 class="post-title"><a href="https://www.criticalhit.net/gaming/outriders-player-defeats-endgame-boss-with-single-49-million-damage-headshot/" rel="bookmark">Outriders player defeats endgame boss with single 49 million-damage headshot</a></h2>
<p>One Redditor has possibly gone too far man. &#8230;</p>
</div>
</section>
</div>
</div>
<div class="bd-sidebar theia_sticky">
<div class="cfix"></div>
<div class="theiaStickySidebar">
<div id="bdaia-widget-e3-2" class="widget bdaia-widget bdaia-widget-e3 e3-trans"><div class="widget-inner">
<div class="e3-inner">
<div id='div-gpt-ad-1614927687679-0' style='width: 300px; height: 250px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1614927687679-0'); });
  </script>
</div></div></div>
</div><div id="bdaia-social-links-3" class="widget bdaia-widget bdaia-social-links">
<h4 class="block-title"><span>Social</span></h4>
<div class="widget-inner">
<div class="widget-social-links bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class="none bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class="none bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class="none bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class="none bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class="none bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</div><div id="bdaia-widget-box6-2" class="widget bdaia-widget bdaia-box6"><h4 class="block-title"><span>Latest Reviews</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb6 bdaia-wb-ide914q bdaia-ajax-pagination-next_prev" data-box_nu="wb6" data-box_id="bdaia-wb-ide914q" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="5" data-tag_slug="" data-cat_uid="58" data-cat_uids="" data-max_nu="690" data-total_posts_num="3446" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="true" data-date_meta="true" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-bigsh bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/technology/redragon-ratri-mechanical-keyboard-review-the-typing-of-the-red/" class="bdaia-text-gradient">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/04/Ratri-2.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1148063" data-permalink="https://www.criticalhit.net/technology/redragon-ratri-mechanical-keyboard-review-the-typing-of-the-red/attachment/ratri-2-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/04/Ratri-2.jpg?fit=849%2C478&amp;ssl=1" data-orig-size="849,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ratri-2.jpg" data-image-description="" data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/04/Ratri-2.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/04/Ratri-2.jpg?fit=849%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/technology/redragon-ratri-mechanical-keyboard-review-the-typing-of-the-red/"><span>Redragon Ratri Mechanical Keyboard Review&ndash;The typing of the red</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">4 days ago</span></div>
</footer>
</div>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/review/hearthstone-forged-in-the-barrens-review-levelling-up/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2021/04/og_barrens_en-us_thumb.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1147541" data-permalink="https://www.criticalhit.net/review/hearthstone-forged-in-the-barrens-review-levelling-up/attachment/og_barrens_en-us_thumb-jpg/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2021/04/og_barrens_en-us_thumb.jpg?fit=1173%2C616&amp;ssl=1" data-orig-size="1173,616" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="og_barrens_en-us_thumb.jpg" data-image-description="" data-medium-file="https://i0.wp.com/media.criticalhit.net//2021/04/og_barrens_en-us_thumb.jpg?fit=300%2C158&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2021/04/og_barrens_en-us_thumb.jpg?fit=850%2C447&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/review/hearthstone-forged-in-the-barrens-review-levelling-up/"><span>Hearthstone: Forged in the Barrens Review: Levelling Up</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/blang/" title="Posts by Brad Lang" rel="author">Brad Lang</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">5 days ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/technology/asus-rog-zephyrus-duo-15-se-gx551-review-dual-screen-queen/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2021/04/Asus-feature.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1147142" data-permalink="https://www.criticalhit.net/technology/asus-rog-zephyrus-duo-15-se-gx551-review-dual-screen-queen/attachment/asus-feature-5/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2021/04/Asus-feature.jpg?fit=1920%2C1080&amp;ssl=1" data-orig-size="1920,1080" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Asus-feature" data-image-description="" data-medium-file="https://i0.wp.com/media.criticalhit.net//2021/04/Asus-feature.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2021/04/Asus-feature.jpg?fit=850%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/technology/asus-rog-zephyrus-duo-15-se-gx551-review-dual-screen-queen/"><span>Asus ROG Zephyrus Duo 15 SE GX551 Review &ndash; Dual Screen Queen</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">1 week ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/mortal-kombat-review/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2021/03/MortalKombat_2021.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1144592" data-permalink="https://www.criticalhit.net/entertainment/mortal-kombat-release-delayed-by-one-week/attachment/mortalkombat_2021/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2021/03/MortalKombat_2021.jpg?fit=850%2C579&amp;ssl=1" data-orig-size="850,579" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="MortalKombat_2021" data-image-description="" data-medium-file="https://i0.wp.com/media.criticalhit.net//2021/03/MortalKombat_2021.jpg?fit=300%2C204&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2021/03/MortalKombat_2021.jpg?fit=850%2C579&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/mortal-kombat-review/"><span>Mortal Kombat review &#8211; Not flawless but still a victory</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/reaver/" title="Posts by Kervyn Cloete" rel="author">Kervyn Cloete</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">1 week ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/the-nevers-advanced-review/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2021/04/TheNevers_1200.jpeg?resize=104%2C74&amp;ssl=1" data-attachment-id="1146693" data-permalink="https://www.criticalhit.net/entertainment/the-nevers-advanced-review/attachment/thenevers_1200/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2021/04/TheNevers_1200.jpeg?fit=1280%2C720&amp;ssl=1" data-orig-size="1280,720" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="TheNevers_1200" data-image-description="" data-medium-file="https://i1.wp.com/media.criticalhit.net//2021/04/TheNevers_1200.jpeg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2021/04/TheNevers_1200.jpeg?fit=850%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/the-nevers-advanced-review/"><span>The Nevers advanced review &#8211; A thrilling new spin on some familiar fare</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/reaver/" title="Posts by Kervyn Cloete" rel="author">Kervyn Cloete</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">1 week ago</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-ide914q .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'e914q', 'next' );
						});
						jQuery('.bdaia-wb-ide914q .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'e914q', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-e3-11" class="widget bdaia-widget bdaia-widget-e3 "><h4 class="block-title"><span>Advert</span></h4>
<div class="widget-inner">
<div class="e3-inner">
<div id='div-gpt-ad-1614927560451-0' style='width: 300px; height: 600px;'>
<script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1614927560451-0'); });
  </script>
</div></div></div>
</div><div id="bdaia-widget-html-4" class="widget bdaia-widget bdaia-widget-html "><h4 class="block-title"><span>Recent Comments</span></h4>
<div class="widget-inner">
<div id="recentcomments" class="dsq-widget"><script type="text/javascript" src="https://critical-hit-net.disqus.com/recent_comments_widget.js?num_items=5&hide_avatars=1&avatar_size=0&excerpt_length=200"></script></div><a href="https://disqus.com/">Powered by Disqus</a></div>
</div><div id="bdaia-widget-box2-4" class="widget bdaia-widget bdaia-box2"><h4 class="block-title"><span>Latest Posts </span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb2 bdaia-wb-idHQ9VU bdaia-ajax-pagination-next_prev" data-box_nu="wb2" data-box_id="bdaia-wb-idHQ9VU" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="5" data-tag_slug="" data-cat_uid="" data-cat_uids="" data-max_nu="12990" data-total_posts_num="64947" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-big bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/mads-mikkelsen-is-out-for-vengeance-against-the-riders-of-justice/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2021/04/Riders-of-Justice-1.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1148675" data-permalink="https://www.criticalhit.net/entertainment/mads-mikkelsen-is-out-for-vengeance-against-the-riders-of-justice/attachment/riders-of-justice-1/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2021/04/Riders-of-Justice-1.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Riders of Justice 1" data-image-description="" data-medium-file="https://i0.wp.com/media.criticalhit.net//2021/04/Riders-of-Justice-1.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2021/04/Riders-of-Justice-1.jpg?fit=850%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/mads-mikkelsen-is-out-for-vengeance-against-the-riders-of-justice/"><span>Mads Mikkelsen is out for vengeance against the Riders of Justice</span></a></h3>
</header>
<footer>
</footer>
<p class="block-exb">Riders of Justice follows recently-deployed Markus (Mads Mikkelsen), who is forced to return home to care for his teenage daughter after his wife is killed in a tragic train accident. But when a survivor of the wrecked train surfaces claiming foul play, Markus begins to suspect his wife was murdered and embarks on a mission to find those responsible.</p>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/watch-the-kick-ass-first-trailer-for-marvels-shang-chi-and-the-legend-of-the-ten-rings/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/04/ShangChi_LegendOfTheTenRings_poster_crop_1.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1148776" data-permalink="https://www.criticalhit.net/entertainment/watch-the-kick-ass-first-trailer-for-marvels-shang-chi-and-the-legend-of-the-ten-rings/attachment/shangchi_legendofthetenrings_poster_crop_1/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/04/ShangChi_LegendOfTheTenRings_poster_crop_1.jpg?fit=850%2C540&amp;ssl=1" data-orig-size="850,540" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ShangChi_LegendOfTheTenRings_poster_crop_1" data-image-description="" data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/04/ShangChi_LegendOfTheTenRings_poster_crop_1.jpg?fit=300%2C191&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/04/ShangChi_LegendOfTheTenRings_poster_crop_1.jpg?fit=850%2C540&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/watch-the-kick-ass-first-trailer-for-marvels-shang-chi-and-the-legend-of-the-ten-rings/"><span>Watch the kick-ass first trailer for Marvel&#8217;s Shang-Chi and the Legend of the Ten Rings!</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-19-april-2020/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2021/04/BCBC-April-19.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1148555" data-permalink="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-19-april-2020/attachment/bcbc-april-19-jpg/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2021/04/BCBC-April-19.jpg?fit=849%2C478&amp;ssl=1" data-orig-size="849,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BCBC-April-19.jpg" data-image-description="" data-medium-file="https://i1.wp.com/media.criticalhit.net//2021/04/BCBC-April-19.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2021/04/BCBC-April-19.jpg?fit=849%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-19-april-2020/"><span>Best comic book covers of the week &ndash; 19 April 2020</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/eric-bana-is-a-detective-is-haunted-by-his-past-in-this-trailer-for-the-dry/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2021/04/Eric-Bana-as-Aaron-Falk-The-Dry.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1148403" data-permalink="https://www.criticalhit.net/entertainment/eric-bana-is-a-detective-is-haunted-by-his-past-in-this-trailer-for-the-dry/attachment/eric-bana-as-aaron-falk-the-dry/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2021/04/Eric-Bana-as-Aaron-Falk-The-Dry.jpg?fit=960%2C500&amp;ssl=1" data-orig-size="960,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Eric-Bana-as-Aaron-Falk-The-Dry" data-image-description="" data-medium-file="https://i0.wp.com/media.criticalhit.net//2021/04/Eric-Bana-as-Aaron-Falk-The-Dry.jpg?fit=300%2C156&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2021/04/Eric-Bana-as-Aaron-Falk-The-Dry.jpg?fit=850%2C443&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/eric-bana-is-a-detective-is-haunted-by-his-past-in-this-trailer-for-the-dry/"><span>Eric Bana is a detective who is haunted by his past in this trailer for The Dry</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/technology/the-current-global-chip-shortage-may-last-all-the-way-into-2023/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/04/arm-processor-cpu-computer-motherboard-featured.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1148417" data-permalink="https://www.criticalhit.net/technology/the-current-global-chip-shortage-may-last-all-the-way-into-2023/attachment/arm-processor-cpu-computer-motherboard-featured-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/04/arm-processor-cpu-computer-motherboard-featured.jpg?fit=800%2C400&amp;ssl=1" data-orig-size="800,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="arm-processor-cpu-computer-motherboard-featured.jpg" data-image-description="" data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/04/arm-processor-cpu-computer-motherboard-featured.jpg?fit=300%2C150&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/04/arm-processor-cpu-computer-motherboard-featured.jpg?fit=800%2C400&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/technology/the-current-global-chip-shortage-may-last-all-the-way-into-2023/"><span>The current global chip shortage may last all the way into 2023</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-idHQ9VU .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'HQ9VU', 'next' );
						});
						jQuery('.bdaia-wb-idHQ9VU .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'HQ9VU', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-box2-2" class="widget bdaia-widget bdaia-box2"><h4 class="block-title"><span>Competitions </span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb2 bdaia-wb-idiQlFT bdaia-ajax-pagination-" data-box_nu="wb2" data-box_id="bdaia-wb-idiQlFT" data-paged="1" data-sort_order="" data-ajax_pagination="" data-num_posts="4" data-tag_slug="" data-cat_uid="34345" data-cat_uids="" data-max_nu="61" data-total_posts_num="242" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="true" data-review="">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-big bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/win-a-copy-of-doom-3-vr-edition-on-playstation/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2021/03/Doom-3-Vr.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1144691" data-permalink="https://www.criticalhit.net/gaming/win-a-copy-of-doom-3-vr-edition-on-playstation/attachment/doom-3-vr-jpg/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2021/03/Doom-3-Vr.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Doom-3-Vr.jpg" data-image-description="" data-medium-file="https://i1.wp.com/media.criticalhit.net//2021/03/Doom-3-Vr.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2021/03/Doom-3-Vr.jpg?fit=850%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/win-a-copy-of-doom-3-vr-edition-on-playstation/"><span>Win a copy of Doom 3 VR Edition on PlayStation!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">3 weeks ago</span></div>
</footer>
<p class="block-exb">Doom 3 was scary in 2004, its legacy was cemented in a spiffy remaster a couple of years later, and chances are that it’ll be even more capable of ruining your pants when experienced via the extra FPS power of the PlayStation VR. Doom 3 VR hit shelves this week, and if you’re looking to score the game for the low price of nothing, then here’s your chance.</p>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/win-an-epic-blizzard-30th-anniversary-celebration-collection-pack/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2021/02/blizz-pack.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1130923" data-permalink="https://www.criticalhit.net/gaming/win-an-epic-blizzard-30th-anniversary-celebration-collection-pack/attachment/blizz-pack/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2021/02/blizz-pack.jpg?fit=960%2C540&amp;ssl=1" data-orig-size="960,540" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="blizz-pack" data-image-description="" data-medium-file="https://i0.wp.com/media.criticalhit.net//2021/02/blizz-pack.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2021/02/blizz-pack.jpg?fit=850%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/win-an-epic-blizzard-30th-anniversary-celebration-collection-pack/"><span>Win an Epic Blizzard 30th Anniversary celebration collection pack!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">February 9, 2021</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/competitions/and-the-winner-of-our-lego-star-wars-set-is/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2020/12/LegoStarWars_ATAT_Build_Rev_1280xl-1.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1119793" data-permalink="https://www.criticalhit.net/review/lego-star-wars-at-at-walker-review/attachment/legostarwars_atat_build_rev_1280xl-2/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/12/LegoStarWars_ATAT_Build_Rev_1280xl-1.jpg?fit=1200%2C788&amp;ssl=1" data-orig-size="1200,788" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="LegoStarWars_ATAT_Build_Rev_1280xl" data-image-description="" data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/12/LegoStarWars_ATAT_Build_Rev_1280xl-1.jpg?fit=300%2C197&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/12/LegoStarWars_ATAT_Build_Rev_1280xl-1.jpg?fit=850%2C558&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/competitions/and-the-winner-of-our-lego-star-wars-set-is/"><span>And the winner of our Lego Star Wars set is&#8230;</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">December 18, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/competitions/win-a-lego-star-wars-kit-worth-r3000/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2020/12/lego-star-wars-at-at-0x.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1118803" data-permalink="https://www.criticalhit.net/competitions/win-a-lego-star-wars-kit-worth-r3000/attachment/created-by-mdkgraphicsengine-licensed-to-lego-production/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/12/lego-star-wars-at-at-0x.jpg?fit=850%2C650&amp;ssl=1" data-orig-size="850,650" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Created by MDKGraphicsEngine - Licensed to LEGO Production&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Created by MDKGraphicsEngine - Licensed to LEGO Production&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="LegoStarWarsATAT" data-image-description="" data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/12/lego-star-wars-at-at-0x.jpg?fit=300%2C229&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/12/lego-star-wars-at-at-0x.jpg?fit=850%2C650&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/competitions/win-a-lego-star-wars-kit-worth-r3000/"><span>Win a Lego Star Wars kit worth R3000</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">December 14, 2020</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
</div>
<style type="text/css">#bdaia-widget-box2-2 .entry-title a:hover{color:#e90d8c !important;}#bdaia-widget-box2-2 .sk-circle .sk-child:before{background:#e90d8c !important;}#bdaia-widget-box2-2 .bdaia-wb-mb-inner{background:#e90d8c !important;}#bdaia-widget-box2-2 h4.block-title:before{background:#e90d8c !important;}#bdaia-widget-box2-2 h4.block-title span, #bdaia-widget-box2-2 h4.block-title a{color:#e90d8c !important;}</style></div></div><div id="bdaia-widget-box3-2" class="widget bdaia-widget bdaia-box3"><h4 class="block-title"><span>Features</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb3 bdaia-wb-id2PNku bdaia-ajax-pagination-next_prev" data-box_nu="wb3" data-box_id="bdaia-wb-id2PNku" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="4" data-tag_slug="" data-cat_uid="48449" data-cat_uids="" data-max_nu="327" data-total_posts_num="1306" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="" data-review="">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-box-row">
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/its-time-to-reunite-the-cast-of-seinfeld-as-marvels-next-big-villains/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2021/04/Dr-George.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1148715" data-permalink="https://www.criticalhit.net/entertainment/its-time-to-reunite-the-cast-of-seinfeld-as-marvels-next-big-villains/attachment/dr-george-jpg/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2021/04/Dr-George.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Dr-George.jpg" data-image-description="" data-medium-file="https://i1.wp.com/media.criticalhit.net//2021/04/Dr-George.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2021/04/Dr-George.jpg?fit=850%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/its-time-to-reunite-the-cast-of-seinfeld-as-marvels-next-big-villains/"><span>It&#8217;s time to reunite the cast of Seinfeld as Marvel&#8217;s next big villains</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/everything-announced-in-last-nights-resident-evil-showcase/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2021/04/EzDAxX1WQAE1qCf.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1148133" data-permalink="https://www.criticalhit.net/gaming/everything-announced-in-last-nights-resident-evil-showcase/attachment/ezdaxx1wqae1qcf-jpg/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2021/04/EzDAxX1WQAE1qCf.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EzDAxX1WQAE1qCf.jpg" data-image-description="" data-medium-file="https://i0.wp.com/media.criticalhit.net//2021/04/EzDAxX1WQAE1qCf.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2021/04/EzDAxX1WQAE1qCf.jpg?fit=850%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/everything-announced-in-last-nights-resident-evil-showcase/"><span>Everything announced in last night&rsquo;s Resident Evil showcase</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
<div class="bdaia-box-row">
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/everything-announced-in-nintendos-latest-indie-world-showcase/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/04/OlliOlli-3.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1147858" data-permalink="https://www.criticalhit.net/gaming/everything-announced-in-nintendos-latest-indie-world-showcase/attachment/olliolli-3-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/04/OlliOlli-3.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="OlliOlli-3.jpg" data-image-description="" data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/04/OlliOlli-3.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/04/OlliOlli-3.jpg?fit=850%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/everything-announced-in-nintendos-latest-indie-world-showcase/"><span>Everything announced in Nintendo&rsquo;s latest Indie World Showcase</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/gord-is-a-nightmarish-city-building-adventure-where-the-whole-world-is-out-to-drive-you-mad/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/04/Zmora-front.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1147371" data-permalink="https://www.criticalhit.net/gaming/gord-is-a-nightmarish-city-building-adventure-where-the-whole-world-is-out-to-drive-you-mad/attachment/zmora-front-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/04/Zmora-front.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Zmora-front.jpg" data-image-description="" data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/04/Zmora-front.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/04/Zmora-front.jpg?fit=850%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/gord-is-a-nightmarish-city-building-adventure-where-the-whole-world-is-out-to-drive-you-mad/"><span>Gord is a nightmarish city-building adventure where the whole world is out to drive you mad</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-id2PNku .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( '2PNku', 'next' );
						});
						jQuery('.bdaia-wb-id2PNku .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( '2PNku', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-e3-13" class="widget bdaia-widget bdaia-widget-e3 "><div class="widget-inner">
<div class="e3-inner"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/CH300BTF', [300, 250]).display();
</script></div></div>
</div><div id="bdaia-widget-box6-6" class="widget bdaia-widget bdaia-box6"><h4 class="block-title"><span>Most Recent</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb6 bdaia-wb-idFfQGc bdaia-ajax-pagination-load_more" data-box_nu="wb6" data-box_id="bdaia-wb-idFfQGc" data-paged="1" data-sort_order="" data-ajax_pagination="load_more" data-num_posts="3" data-tag_slug="" data-cat_uid="" data-cat_uids="" data-max_nu="21649" data-total_posts_num="64947" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="true" data-date_meta="true" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-bigsh bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/mads-mikkelsen-is-out-for-vengeance-against-the-riders-of-justice/" class="bdaia-text-gradient">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2021/04/Riders-of-Justice-1.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1148675" data-permalink="https://www.criticalhit.net/entertainment/mads-mikkelsen-is-out-for-vengeance-against-the-riders-of-justice/attachment/riders-of-justice-1/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2021/04/Riders-of-Justice-1.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Riders of Justice 1" data-image-description="" data-medium-file="https://i0.wp.com/media.criticalhit.net//2021/04/Riders-of-Justice-1.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2021/04/Riders-of-Justice-1.jpg?fit=850%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/mads-mikkelsen-is-out-for-vengeance-against-the-riders-of-justice/"><span>Mads Mikkelsen is out for vengeance against the Riders of Justice</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/trevor/" title="Posts by Trevor Davies" rel="author">Trevor Davies</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">23 mins ago</span></div>
</footer>
</div>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/watch-the-kick-ass-first-trailer-for-marvels-shang-chi-and-the-legend-of-the-ten-rings/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/04/ShangChi_LegendOfTheTenRings_poster_crop_1.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1148776" data-permalink="https://www.criticalhit.net/entertainment/watch-the-kick-ass-first-trailer-for-marvels-shang-chi-and-the-legend-of-the-ten-rings/attachment/shangchi_legendofthetenrings_poster_crop_1/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/04/ShangChi_LegendOfTheTenRings_poster_crop_1.jpg?fit=850%2C540&amp;ssl=1" data-orig-size="850,540" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ShangChi_LegendOfTheTenRings_poster_crop_1" data-image-description="" data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/04/ShangChi_LegendOfTheTenRings_poster_crop_1.jpg?fit=300%2C191&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/04/ShangChi_LegendOfTheTenRings_poster_crop_1.jpg?fit=850%2C540&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/watch-the-kick-ass-first-trailer-for-marvels-shang-chi-and-the-legend-of-the-ten-rings/"><span>Watch the kick-ass first trailer for Marvel&#8217;s Shang-Chi and the Legend of the Ten Rings!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/reaver/" title="Posts by Kervyn Cloete" rel="author">Kervyn Cloete</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">3 hours ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-19-april-2020/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2021/04/BCBC-April-19.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1148555" data-permalink="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-19-april-2020/attachment/bcbc-april-19-jpg/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2021/04/BCBC-April-19.jpg?fit=849%2C478&amp;ssl=1" data-orig-size="849,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BCBC-April-19.jpg" data-image-description="" data-medium-file="https://i1.wp.com/media.criticalhit.net//2021/04/BCBC-April-19.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2021/04/BCBC-April-19.jpg?fit=849%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-19-april-2020/"><span>Best comic book covers of the week &ndash; 19 April 2020</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">3 hours ago</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('#bdaia-more-FfQGc .bdaia-wb-mb-inner').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'FfQGc', '' );
						});
																	});
				</script>
<div class="bdaia-wb-more-btn" id="bdaia-more-FfQGc">
<div class="bdaia-wb-mb-inner">
Load more<span class="bdaia-io bdaia-io-angle-down"></span>
</div>
</div>
</div>
<style type="text/css">#bdaia-widget-box6-6 .entry-title a:hover{color:#E6A602 !important;}#bdaia-widget-box6-6 .sk-circle .sk-child:before{background:#E6A602 !important;}#bdaia-widget-box6-6 .bdaia-wb-mb-inner{background:#E6A602 !important;}#bdaia-widget-box6-6 h4.block-title:before{background:#E6A602 !important;}#bdaia-widget-box6-6 h4.block-title span, #bdaia-widget-box6-6 h4.block-title a{color:#E6A602 !important;}</style></div></div> </div>
</div>
</div>
</div>
<div class="bdaia-footer-e3-desktop"><div class="bdaia-e3-container"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/728bottom', [728, 90]).display();
</script>
</div></div>
<div class="bdaia-footer">
<div class="bdaia-footer-widgets">
<div class="bd-container">
<div class="bdaia-footer-widgets-area footer-col-three">
<div id="footer-first" class="footer-widget-inner">
<div id="bdaia-widget-html-2" class="widget bdaia-widget bdaia-widget-html e3-trans"><h4 class="block-title"><span>About US</span></h4>
<div class="widget-inner">
<p>
<img src="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-White-1.png" alt="" />
</p>
<p style="margin-top:25px;">
Critical Hit is built on the idea that we are more than one thing. Are you a hardcore gamer who also enjoys a night out at the movies? Perhaps you’re a professional cosplayer who is searching for the perfect burger, or maybe you’re just interested in high-end tech and Netflix binging. Covering gaming, entertainment, tech and geek, Critical Hit offers information and critique from a staff of diverse, knowledgeable and fiercely opinionated writers. </p>
</div>
</div><div id="bdaia-social-links-6" class="widget bdaia-widget bdaia-social-links">
<h4 class="block-title"><span>Follow Us</span></h4>
<div class="widget-inner">
<div class="widget-social-links bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class="none bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class="none bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class="none bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class="none bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class="none bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</div> </div>
<div id="footer-second" class="footer-widget-inner">
<div id="bdaia-widget-box1-2" class="widget bdaia-widget bdaia-box1"><h4 class="block-title"><span>Read This</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb1 bdaia-wb-idNhK5n bdaia-ajax-pagination-" data-box_nu="wb1" data-box_id="bdaia-wb-idNhK5n" data-paged="1" data-sort_order="random_7_day" data-ajax_pagination="" data-num_posts="4" data-tag_slug="" data-cat_uid="" data-cat_uids="" data-max_nu="15" data-total_posts_num="60" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="true" data-date_meta="true" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/castlevanias-fourth-and-final-season-stakes-a-may-13-release-on-netflix/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2021/04/Netflixs-Castlevania-Season-2-out-in-October_thumb.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1148625" data-permalink="https://www.criticalhit.net/entertainment/castlevanias-fourth-and-final-season-stakes-a-may-13-release-on-netflix/attachment/netflixs-castlevania-season-2-out-in-october_thumb-jpg-2/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2021/04/Netflixs-Castlevania-Season-2-out-in-October_thumb.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Netflixs-Castlevania-Season-2-out-in-October_thumb.jpg" data-image-description="" data-medium-file="https://i1.wp.com/media.criticalhit.net//2021/04/Netflixs-Castlevania-Season-2-out-in-October_thumb.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2021/04/Netflixs-Castlevania-Season-2-out-in-October_thumb.jpg?fit=850%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/castlevanias-fourth-and-final-season-stakes-a-may-13-release-on-netflix/"><span>Castlevania&rsquo;s fourth and final season stakes a May 13 release on Netflix</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">8 hours ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/days-gone-launches-on-pc-on-18-may/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2021/04/days-gone-review_thumb.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1148168" data-permalink="https://www.criticalhit.net/gaming/days-gone-launches-on-pc-on-18-may/attachment/days-gone-review_thumb-jpg/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2021/04/days-gone-review_thumb.jpg?fit=1346%2C757&amp;ssl=1" data-orig-size="1346,757" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="days-gone-review_thumb.jpg" data-image-description="" data-medium-file="https://i0.wp.com/media.criticalhit.net//2021/04/days-gone-review_thumb.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2021/04/days-gone-review_thumb.jpg?fit=850%2C478&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/days-gone-launches-on-pc-on-18-may/"><span>Days Gone launches on PC on 18 May</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/blang/" title="Posts by Brad Lang" rel="author">Brad Lang</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">3 days ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/returnals-nightmarish-monsters-have-custom-tentacle-technology/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2021/04/Returnal-monsters.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1147877" data-permalink="https://www.criticalhit.net/gaming/returnals-nightmarish-monsters-have-custom-tentacle-technology/attachment/returnal-monsters-jpg/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2021/04/Returnal-monsters.jpg?fit=850%2C448&amp;ssl=1" data-orig-size="850,448" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Returnal-monsters.jpg" data-image-description="" data-medium-file="https://i0.wp.com/media.criticalhit.net//2021/04/Returnal-monsters.jpg?fit=300%2C158&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2021/04/Returnal-monsters.jpg?fit=850%2C448&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/returnals-nightmarish-monsters-have-custom-tentacle-technology/"><span>Returnal&rsquo;s nightmarish monsters have custom tentacle technology</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">4 days ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/dylan-obrien-stars-in-the-mind-bending-trailer-for-flashback/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/04/Flashback-Poster-Featured.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1147817" data-permalink="https://www.criticalhit.net/entertainment/dylan-obrien-stars-in-the-mind-bending-trailer-for-flashback/attachment/flashback-poster-featured/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/04/Flashback-Poster-Featured.jpg?fit=800%2C416&amp;ssl=1" data-orig-size="800,416" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Flashback-Poster-Featured" data-image-description="" data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/04/Flashback-Poster-Featured.jpg?fit=300%2C156&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/04/Flashback-Poster-Featured.jpg?fit=800%2C416&amp;ssl=1" data-lazy-src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/dylan-obrien-stars-in-the-mind-bending-trailer-for-flashback/"><span>Dylan O&#8217;Brien stars in the mind-bending trailer for Flashback</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/craigrisi/" title="Posts by Craig Risi" rel="author">Craig Risi</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">4 days ago</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
</div>
</div></div> </div>
<div id="footer-third" class="footer-widget-inner">
<div id="bdaia-widget-timeline-2" class="widget bdaia-widget bdaia-widget-timeline">
<h4 class="block-title"><span>Timeline</span></h4>
<div class="widget-inner">
<ul>
<li>
<a href="https://www.criticalhit.net/entertainment/mads-mikkelsen-is-out-for-vengeance-against-the-riders-of-justice/">
<span class="bdayh-date">23 mins ago</span> <h3>Mads Mikkelsen is out for vengeance against the Riders of Justice</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/entertainment/watch-the-kick-ass-first-trailer-for-marvels-shang-chi-and-the-legend-of-the-ten-rings/">
<span class="bdayh-date">3 hours ago</span> <h3>Watch the kick-ass first trailer for Marvel&#8217;s Shang-Chi and the Legend of the Ten Rings!</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/comics-toys/best-comic-book-covers-of-the-week-19-april-2020/">
<span class="bdayh-date">3 hours ago</span> <h3>Best comic book covers of the week &ndash; 19 April 2020</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/entertainment/eric-bana-is-a-detective-is-haunted-by-his-past-in-this-trailer-for-the-dry/">
<span class="bdayh-date">3 hours ago</span> <h3>Eric Bana is a detective who is haunted by his past in this trailer for The Dry</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/technology/the-current-global-chip-shortage-may-last-all-the-way-into-2023/">
<span class="bdayh-date">4 hours ago</span> <h3>The current global chip shortage may last all the way into 2023</h3>
</a>
</li>
</ul>
</div>
</div> </div>
</div>
</div>
</div>
<div class="woohoo-footer-top-area" style="background-color:#000000;">
<div class="bd-container">
<div class="woohoo-footer-menu">
<div class="menu-footer-container"><ul id="menu-footer" class="footer-bottom-menu"><li id="menu-item-573845" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-573845"><a href="https://www.criticalhit.net/">Critical Hit</a></li>
<li id="menu-item-574303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574303"><a href="https://www.criticalhit.net/contact/">Contact</a></li>
<li id="menu-item-573839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-573839"><a href="https://www.criticalhit.net/advertise/">Advertise</a></li>
<li id="menu-item-574736" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574736"><a href="https://www.criticalhit.net/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-574795" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574795"><a href="https://www.criticalhit.net/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
</div>
</div>
<div class="bdaia-footer-area" style="background-color:#000000;">
<div class="bd-container">
<div class="bdaia-footer-area-l">
</div>
<div class="bdaia-footer-area-r">
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<script type=\"text/javascript\">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
<div class="gotop" title="Go Top"><span class="bdaia-io bdaia-io-chevron-up"></span></div><div id="reading-position-indicator"></div>
<script>
    </script>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.criticalhit.net\/gaming\/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports\/":1148628};
	</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.6.1/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"critical-hit-net"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/disqus-comment-system/public/js/comment_count.js' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.21"},"disqusIdentifier":"1148628 https:\/\/www.criticalhit.net\/?p=1148628","disqusShortname":"critical-hit-net","disqusTitle":"Amazon\u2019s Lord of the Rings MMO has been cancelled according to new reports","disqusUrl":"https:\/\/www.criticalhit.net\/gaming\/amazons-lord-of-the-rings-mmo-has-been-cancelled-according-to-new-reports\/","postId":"1148628"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js' id='disqus_embed-js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/easy-table/js/easy-table-script.js' id='easy_table_script-js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/intersectionobserver-polyfill.min.js' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' id='woohoo-main-js-extra'>
/* <![CDATA[ */
var bd = {"nonce":"ab1128b2ce","ajaxurl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","is_singular":"1","has_lazy_load":"1","bd_lazyload":"1","mobile_topmenu":"1","sticky_sidebar":"1","all_lightbox":"1","click_to_comments":"","post_reading_position_indicator":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/themes/woohoo-child/js/main.js' id='woohoo-main-js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/themes/woohoo-child/js/js-cookie.js' id='js-cookie-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.7.1/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.7.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/themes/woohoo/js/search.js' id='bd-search-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.6.1/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-tumblr' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-tumblr' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
</script>
<script src='https://stats.wp.com/e-202116.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6.1',blog:'122131268',post:'1148628',tz:'2',srv:'www.criticalhit.net'} ]);
	_stq.push([ 'clickTrackerInit', '122131268', '1148628' ]);
</script>
</body>
</html>