<!DOCTYPE html>
<html lang="en-GB" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#">
<head>
<meta property="fb:pages" content="161755108961" />
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.criticalhit.net/xmlrpc.php" />

<meta name="google-site-verification" content="1vFejJFCT-gTHbz4YXtJrlWGHn4iBz-VmX1lyaF2QQ4" />

<title>If you want those free games off The Epic Games Store, you&rsquo;ll need to start protecting your account - Critical Hit</title>
<meta name="description" content="Starting from today, all users taking advantage of those freebies will have to use two-factor authentication to redeem them." />
<meta name="robots" content="index, follow, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/" />
<meta property="og:locale" content="en_GB">
<meta property="og:type" content="article">
<meta property="og:title" content="If you want those free games off The Epic Games Store, you&rsquo;ll need to start protecting your account - Critical Hit">
<meta property="og:description" content="Starting from today, all users taking advantage of those freebies will have to use two-factor authentication to redeem them.">
<meta property="og:url" content="https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/">
<meta property="og:site_name" content="Critical Hit">
<meta property="article:publisher" content="https://facebook.com/criticalhit.net">
<meta property="article:tag" content="Epic Games">
<meta property="article:tag" content="free games">
<meta property="article:tag" content="Security">
<meta property="article:tag" content="The Epic Store">
<meta property="article:tag" content="Two-Factor Authentication">
<meta property="article:section" content="Gaming">
<meta property="og:updated_time" content="2020-04-29T10:43:19+02:00">
<meta property="og:image" content="https://media.criticalhit.net//2020/04/Diesel_collections_free-games_EpicGamesStore_lg-black-1200x630-3b7faa2c648f075f126343747afa1a4fb9b6e1a8.png">
<meta property="og:image:secure_url" content="https://media.criticalhit.net//2020/04/Diesel_collections_free-games_EpicGamesStore_lg-black-1200x630-3b7faa2c648f075f126343747afa1a4fb9b6e1a8.png">
<meta property="og:image:width" content="918">
<meta property="og:image:height" content="482">
<meta property="og:image:alt" content="If you want those free games off The Epic Games Store, you&rsquo;ll need to start protecting your account">
<meta property="og:image:type" content="image/png">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="If you want those free games off The Epic Games Store, you&rsquo;ll need to start protecting your account - Critical Hit">
<meta name="twitter:description" content="Starting from today, all users taking advantage of those freebies will have to use two-factor authentication to redeem them.">
<meta name="twitter:site" content="@criticalhitnet">
<meta name="twitter:creator" content="@IceBearlyCoping">
<meta name="twitter:image" content="https://media.criticalhit.net//2020/04/Diesel_collections_free-games_EpicGamesStore_lg-black-1200x630-3b7faa2c648f075f126343747afa1a4fb9b6e1a8.png">

<link rel='dns-prefetch' href='//www.criticalhit.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; Feed" href="https://www.criticalhit.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; Comments Feed" href="https://www.criticalhit.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; If you want those free games off The Epic Games Store, you&rsquo;ll need to start protecting your account Comments Feed" href="https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.criticalhit.net\/wp-includes\/js\/wp-emoji-release.min.js"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='bdaia_shorty-style-css' href='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='formidable-css' href='https://www.criticalhit.net/wp-content/plugins/formidable/css/formidableforms.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.4/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://c0.wp.com/c/5.4/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='bdaia_shorty_stylesheet-css' href='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/shortcodes.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-lightbox-2.min.css-css' href='https://www.criticalhit.net/wp-content/plugins/wp-lightbox-2/styles/lightbox.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='theme-child-style-css' href='https://www.criticalhit.net/wp-content/themes/woohoo-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='woohoo-google-fonts-css' href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C300%2C700%7CLato%3A400%2C300%2C700%2C900%7CWork+Sans%3A400%2C300%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C600%2C700%2C800%7CPlayfair+Display%3A400%2C700%2C900%2C400italic%7CRaleway%3A400%2C300%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A400%2C300%2C100%2C700%7CMontserrat%3A400%2C700&#038;subset=latin%2Cgreek%2Cgreek-ext%2Cvietnamese%2Ccyrillic-ext%2Clatin-ext%2Ccyrillic' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css' href='https://www.criticalhit.net/wp-content/plugins/easy-table/themes/default/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='woohoo-default-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/style.css' type='text/css' media='all' />
<style id='woohoo-default-inline-css' type='text/css'>
body.category-41989 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-5 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-33983 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-41988 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-34107 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-58 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-41990 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-38 div.bdaia-blocks div.bdaia-post-view{display: none !important;}
</style>
<link rel='stylesheet' id='wooohoo-ilightbox-skin-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='wooohoo-ilightbox-skin-black-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/ilightbox/metro-black-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://c0.wp.com/p/jetpack/8.4.2/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.4.2/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var bd_w_blocks = {"bdaia_w_ajax_url":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","bdaia_w_ajax_nonce":"e95bec7c45"};
var bd_blocks = {"bdaia_ajax_url":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","bdaia_ajaxnonce":"e95bec7c45"};
var bd_script = {"post_id":"1061304","ajaxurl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/js/scripts.js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/js/shorty-min.js'></script>
<link rel='https://api.w.org/' href='https://www.criticalhit.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.criticalhit.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.criticalhit.net/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4" />
<link rel='shortlink' href='https://www.criticalhit.net/?p=1061304' />
<link rel="alternate" type="application/json+oembed" href="https://www.criticalhit.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fif-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.criticalhit.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fif-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.7.0" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<style type='text/css'>img#wpstats{display:none}</style> <script type="text/javascript">
            /* <![CDATA[ */
            var sf_position = '0';
            var sf_templates = "<a href=\"{search_url_escaped}\"><span class=\"sf_text\">View All Results<\/span><\/a>";
            var sf_input = '.search-live';
            jQuery(document).ready(function(){
                jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/www.criticalhit.net\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","rtl":0});
                jQuery(".live-search_ajaxy-selective-input").keyup(function() {
                    var width = jQuery(this).val().length * 8;
                    if(width < 50) {
                        width = 50;
                    }
                    jQuery(this).width(width);
                });
                jQuery(".live-search_ajaxy-selective-search").click(function() {
                    jQuery(this).find(".live-search_ajaxy-selective-input").focus();
                });
                jQuery(".live-search_ajaxy-selective-close").click(function() {
                    jQuery(this).parent().remove();
                });
            });
            /* ]]> */
        </script>
<link rel="shortcut icon" href="https://media.criticalhit.net/2018/12/favicon.png" type="image/x-icon" /><script data-ad-client="ca-pub-1473612930314813" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5GNB24P');</script>
<script type="text/javascript">
/* <![CDATA[ */
var userRating = {"ajaxurl":"https://www.criticalhit.net/wp-admin/admin-ajax.php" , "your_rating":"" , "nonce":"e95bec7c45"};
var userLike = {"ajaxurl":"https://www.criticalhit.net/wp-admin/admin-ajax.php" , "nonce":"e95bec7c45"};
/* ]]> */
var bdaia_theme_uri = 'https://www.criticalhit.net/wp-content/themes/woohoo';
</script>
<style type="text/css">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</style><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>

<script type="application/ld+json" class="saswp-schema-markup-output">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</script>
<link rel="icon" href="https://media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon-180x180.png" />
<meta name="msapplication-TileImage" content="https://media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon-270x270.png" />
<style type="text/css" id="wp-custom-css">
				.bdaia-post-content blockquote p,
blockquote p  {
  font-size: 20px !important;
  background: #f9f9f9 !important;
  border-left: 10px solid #ccc !important;
  margin: .5em 10px !important;
  padding: 0 10px !important;
  quotes: "\201C""\201D""\2018""\2019" !important;
  padding: 10px 20px !important;
  line-height: 1.4 !important;
	text-transform: none !important;
	color: grey  !important;
	text-align: left !important;
	font-weight: 300 !important;
}

.bdaia-post-content blockquote, blockquote {
    margin: 20px 5px 10px 0px !important;
	    padding-left: 0px !important;
    border-left: none !important;
}

.wp-block-jetpack-gif .wp-block-jetpack-gif-caption {
    color: #ffffff !important;
    font-weight: bold;
}			</style>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<meta name="msvalidate.01" content="2408EBF25A6FABECCCF3EC45230C1258" />
<script>
!function(a){var b=/iPhone/i,c=/iPod/i,d=/iPad/i,e=/(?=.*\bAndroid\b)(?=.*\bMobile\b)/i,f=/Android/i,g=/(?=.*\bAndroid\b)(?=.*\bSD4930UR\b)/i,h=/(?=.*\bAndroid\b)(?=.*\b(?:KFOT|KFTT|KFJWI|KFJWA|KFSOWI|KFTHWI|KFTHWA|KFAPWI|KFAPWA|KFARWI|KFASWI|KFSAWI|KFSAWA)\b)/i,i=/IEMobile/i,j=/(?=.*\bWindows\b)(?=.*\bARM\b)/i,k=/BlackBerry/i,l=/BB10/i,m=/Opera Mini/i,n=/(CriOS|Chrome)(?=.*\bMobile\b)/i,o=/(?=.*\bFirefox\b)(?=.*\bMobile\b)/i,p=new RegExp("(?:Nexus 7|BNTV250|Kindle Fire|Silk|GT-P1000)","i"),q=function(a,b){return a.test(b)},r=function(a){var r=a||navigator.userAgent,s=r.split("[FBAN");return"undefined"!=typeof s[1]&&(r=s[0]),s=r.split("Twitter"),"undefined"!=typeof s[1]&&(r=s[0]),this.apple={phone:q(b,r),ipod:q(c,r),tablet:!q(b,r)&&q(d,r),device:q(b,r)||q(c,r)||q(d,r)},this.amazon={phone:q(g,r),tablet:!q(g,r)&&q(h,r),device:q(g,r)||q(h,r)},this.android={phone:q(g,r)||q(e,r),tablet:!q(g,r)&&!q(e,r)&&(q(h,r)||q(f,r)),device:q(g,r)||q(h,r)||q(e,r)||q(f,r)},this.windows={phone:q(i,r),tablet:q(j,r),device:q(i,r)||q(j,r)},this.other={blackberry:q(k,r),blackberry10:q(l,r),opera:q(m,r),firefox:q(o,r),chrome:q(n,r),device:q(k,r)||q(l,r)||q(m,r)||q(o,r)||q(n,r)},this.seven_inch=q(p,r),this.any=this.apple.device||this.android.device||this.windows.device||this.other.device||this.seven_inch,this.phone=this.apple.phone||this.android.phone||this.windows.phone,this.tablet=this.apple.tablet||this.android.tablet||this.windows.tablet,"undefined"==typeof window?this:void 0},s=function(){var a=new r;return a.Class=r,a};"undefined"!=typeof module&&module.exports&&"undefined"==typeof window?module.exports=r:"undefined"!=typeof module&&module.exports&&"undefined"!=typeof window?module.exports=s():"function"==typeof define&&define.amd?define("isMobile",[],a.isMobile=s()):a.isMobile=s()}(this);
  googletag.cmd.push(function() {
	if(isMobile.any) {
	googletag.defineSlot('/55341649/300250MidarticleMobile', [300, 250],
		'div-gpt-ad-1540807120663-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/300x250ACmobile', [300, 250],
	    'div-gpt-ad-1540807963183-0').addService(googletag.pubads());
			googletag.defineSlot('/55341649/MastheadTop', [728, 90],
			'div-gpt-ad-1542102676397-0').addService(googletag.pubads());

	} else {
	googletag.defineSlot('/55341649/MastheadTop', [728, 90],
	'div-gpt-ad-1542102676397-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/728MidArticle', [728, 90],
			'div-gpt-ad-1540806613519-0').addService(googletag.pubads());
  googletag.defineSlot('/55341649/728Comments', [728, 90],
	    'div-gpt-ad-1540808126586-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/Background', [1, 1],
		'div-gpt-ad-1540376831756-0').addService(googletag.pubads());

    }
	googletag.enableServices();
  });
</script>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "WebSite",
  "url": "https://www.criticalhit.net/",
  "name": "Critical Hit",
  "description": "Critical Hit is a website built on the idea that we are more than one thing. Writers, writing about the things they love; games, film, TV, technology and more.",
  "publisher": "Critical Hit",
  "potentialAction": {
    "@type": "SearchAction",
    "target": "https://www.criticalhit.net/?s={search_term}",
    "query-input": "required name=search_term" }
    }
</script>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "Organization",
  "url": "https://www.criticalhit.net",
  "logo": "https://www.criticalhit.net/images/Icon.png"
}
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-1473612930314813",
          enable_page_level_ads: false
     });
</script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.flexslider-min.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.eislideshow.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.placeholder.min.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.fitvids.js"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/modernizr.js"></script>
</head>
<body class="post-template-default single single-post postid-1061304 single-format-standard bdaia-boxed  of-new-article ">
<div class="page-outer bdaia-header-default sticky-nav-on  bdaia-post-template-default  bdaia-sidebar-right ">
<div class="bg-cover"></div>
<aside id="bd-MobileSiderbar">
<div id="mobile-menu"></div>
<div class="widget-social-links bdaia-social-io-colored">
<div class="sl-widget-inner">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class=" bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class=" bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class=" bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class=" bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class=" bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</aside>

<div id='div-gpt-ad-1540376831756-0' style='height:1px; width:1px;'>
<script>
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540376831756-0'); });
	</script>
</div>
<div id="page">
<div class="inner-wrapper">
<div id="warp" class="clearfix  bdaia-sidebar-right ">
<div class="header-wrapper">
<div class="bdayh-click-open">
<div class="bd-ClickOpen bd-ClickAOpen">
<span></span>
</div>
</div>
<header class="header-container">
<div class="bd-container">
<div class="logo">
<h2 class="site-title"> <a href="https://www.criticalhit.net/" rel="home" title="Critical Hit">
<img src="https://media.criticalhit.net/2016/12/Critical_Hit-Logo-Gaming.png" alt="Critical Hit" />
</a>
</h2> </div>
<div class="bdaia-header-e3-desktop"><div class="bdaia-e3-container"><div id="leaderboard-pixfuture">
<div id='div-gpt-ad-1542102676397-0' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1542102676397-0'); });
</script>
</div>
</div></div>
</div>
</header>
<div class="cfix"></div>
<nav id="navigation" class="">
<div class="navigation-wrapper">
<div class="bd-container">
<div class="primary-menu">
<a class="nav-logo" title="Critical Hit" href="https://www.criticalhit.net/">
<img src="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-Text-Only.png" width="195" height="48" alt="Critical Hit" />
</a>
<ul id="menu-primary">
<li id="menu-item-526858" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/gaming/"> <i class="fa fa fa-gamepad"></i> <span class="menu-label" style="">Games</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526854" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/entertainment/"> <i class="fa fa fa-film"></i> <span class="menu-label" style="">Entertainment</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526870" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/technology/"> <i class="fa fa fa-power-off"></i> <span class="menu-label" style="">Tech</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526876" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/comics-toys/"> <i class="fa fa fa-comment-o"></i> <span class="menu-label" style="">Comics</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526860" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/lifestyle/"> <i class="fa fa fa-heart"></i> <span class="menu-label" style="">Lifestyle</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-726070" class=" menu-item menu-item-type-post_type menu-item-object-page bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/esports/"> <i class="fa fa fa-users"></i> <span class="menu-label" style="">esports</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-881926" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/review/"> <i class="fa fa fa-book"></i> <span class="menu-label" style="">Reviews</span></a>
<div class="mega-menu-content">
</div> </ul>
</div>
<div class="nav-right-area">
<div class="bdaia-nav-search">
<span class="bdaia-ns-btn bdaia-io bdaia-io-search"></span>
<div class="bdaia-ns-wrap">
<div class="bdaia-ns-content">
<div class="bdaia-ns-inner">
<form method="get" id="searchform" action="https://www.criticalhit.net/">
<input type="text" class="bbd-search-field search-live" id="s" name="s" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}" />
<button type="submit" class="bbd-search-btn"><span class="bdaia-io bdaia-io-search"></span></button>
</form>
</div>
</div>
</div>
</div>
</div>
<div class="cfix"></div>
</div>
</div>
</nav>
<div class="cfix"></div>
</div>
<div class="bdMain">
<div class="bd-container bdaia-post-template">
<div class="bd-main bdaia-site-content" id="bdaia-primary">
<div id="content" role="main">
<div xmlns:v="http://rdf.data-vocabulary.org/#" class="bdaia-crumb-container"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://www.criticalhit.net">Home</a></span> <span class="delimiter"><span class="bdaia-io bdaia-io-angle-double-right"></span></span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://www.criticalhit.net/category/gaming/">Gaming</a></span> <span class="delimiter"><span class="bdaia-io bdaia-io-angle-double-right"></span></span> <span class="current">If you want those free games off The Epic Games Store, you&rsquo;ll need to start protecting your account</span></div><div class="bdayh-clearfix"></div>
<article id="post-1061304" class="hentry post-1061304 post type-post status-publish format-standard has-post-thumbnail category-gaming tag-epic-games tag-free-games tag-security tag-the-epic-store tag-two-factor-authentication">
<header class="bdaia-post-header">
<div class="bdaia-post-title">
<h1 class="post-title entry-title"><span>If you want those free games off The Epic Games Store, you&rsquo;ll need to start protecting your account</span></h1>
</div>

<div class="bdaia-meta-info">
<div class="bdaia-post-author-name">
By <a href="https://www.criticalhit.net/author/blang/" title="">Brad Lang </a>
<a href="https://twitter.com/IceBearlyCoping" target="_blank">
<span class="bdaia-io bdaia-io-twitter"></span>
</a>
</div>
<div class="bdaia-post-date"><span class='bdaia-io bdaia-io-calendar'></span>Posted on&nbsp;<span class="bdayh-date">April 29, 2020</span></div>
<div class="bdaia-post-time-read"><span class='bdaia-io bdaia-io-clock'></span>2&nbsp;min read</div>
<div class="bdaia-post-comment"><span class='bdaia-io bdaia-io-bubbles4'></span><a href="https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/#respond"><span class="dsq-postid" data-dsqidentifier="1061304 https://www.criticalhit.net/?p=1061304">0</span></a></div>
</div>

</header>
<div class="bdaia-post-sharing bdaia-post-sharing-top">
<ul>
<li class="facebook">
<a title="facebook" onClick="window.open('http://www.facebook.com/sharer.php?u=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/">
<span class="bdaia-io bdaia-io-facebook"></span>
<span>Share on Facebook</span>
</a>
</li>
<li class="twitter">
<a title="twitter" onClick="window.open('http://twitter.com/share?url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/&amp;text=If%20you%20want%20those%20free%20games%20off%20The%20Epic%20Games%20Store,%20you&rsquo;ll%20need%20to%20start%20protecting%20your%20account','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/&amp;text=If%20you%20want%20those%20free%20games%20off%20The%20Epic%20Games%20Store,%20you&rsquo;ll%20need%20to%20start%20protecting%20your%20account">
<span class="bdaia-io bdaia-io-twitter"></span>
<span>Share on Twitter</span>
</a>
</li>
<li class="google">
<a title="google" onClick="window.open('https://plus.google.com/share?url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/">
<span class="bdaia-io bdaia-io-google-plus"></span>
<span>Share on Google+</span>
</a>
</li>
<li class="reddit">
<a title="reddit" onClick="window.open('http://reddit.com/submit?url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/&amp;title=If%20you%20want%20those%20free%20games%20off%20The%20Epic%20Games%20Store,%20you&rsquo;ll%20need%20to%20start%20protecting%20your%20account','Reddit','width=617,height=514,left='+(screen.availWidth/2-308)+',top='+(screen.availHeight/2-257)+''); return false;" href="https://reddit.com/submit?url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/&amp;title=If%20you%20want%20those%20free%20games%20off%20The%20Epic%20Games%20Store,%20you&rsquo;ll%20need%20to%20start%20protecting%20your%20account">
<span class="bdaia-io bdaia-io-reddit"></span>
<span>Share on Reddit</span>
</a>
</li>
<li class="pinterest">
<a title="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fif-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account%2F&amp;description=If+you+want+those+free+games+off+The+Epic+Games+Store%2C+you%26rsquo%3Bll+need+to+start+protecting+your+account&amp;media=https%3A%2F%2Fmedia.criticalhit.net%2F%2F2020%2F04%2FDiesel_collections_free-games_EpicGamesStore_lg-black-1200x630-3b7faa2c648f075f126343747afa1a4fb9b6e1a8.png">
<span class="bdaia-io bdaia-io-social-pinterest"></span>
<span>Share on Pinterest</span>
</a>
</li>
<li class="linkedin">
<a title="linkedin" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/">
<span class="bdaia-io bdaia-io-linkedin2"></span>
<span>Share on Linkedin</span>
</a>
</li>
<li class="tumblr">
<a title="tumblr" onClick="window.open('http://www.tumblr.com/share/link?url=www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/&amp;name=If%20you%20want%20those%20free%20games%20off%20The%20Epic%20Games%20Store,%20you&rsquo;ll%20need%20to%20start%20protecting%20your%20account','Tumblr','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.tumblr.com/share/link?url=www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/&amp;name=If%20you%20want%20those%20free%20games%20off%20The%20Epic%20Games%20Store,%20you&rsquo;ll%20need%20to%20start%20protecting%20your%20account">
<span class="bdaia-io bdaia-io-tumblr"></span>
<span>Share on Tumblr</span>
</a>
</li>
<li class="whatsapp">
<a href="whatsapp://send?text=Starting+from+today%2C+all+users+taking+advantage+of+those+freebies+will+have+to+use+two-factor+authentication+to+redeem+them.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fif-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account%2F"><span class="bdaia-io bdaia-io-whatsapp"></span></a> </li>
<li class="telegram">
<a href="tg://msg?text=Starting+from+today%2C+all+users+taking+advantage+of+those+freebies+will+have+to+use+two-factor+authentication+to+redeem+them.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fif-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account%2F"><span class="bdaia-io bdaia-io-telegram"></span></a> </li>
</ul>
</div>

<div class="bdaia-post-content">
<figure class="wp-block-image"><img src="https://media.criticalhit.net//2020/04/2019-10-31-image-4.png" alt="2019-10-31-image-4" title="2019-10-31-image-4" /></figure>
<p>Whatever your feelings on The Epic Games Store, one thing that I doubt many people can reasonably shake their fists at in ire are the abundance of free games it dishes out. It’s pretty wild how every week there’s something new to jump into, making life a lot easier for cash-strapped or casual gamers just looking for new things to try out. While it was originally only meant to last the first year the store was active, Epic has seemingly seen so much success in the program that they’ve…just not stopped. Free games are still given out nearly every week, sometimes in bundles of two or more! They’re not even bad games, as I’ve scooped up Kingdom Come: Deliverance, Ape Out and Into The Breach all for free, among loads of others!</p>
<figure class="wp-block-image"><img src="https://media.criticalhit.net//2020/04/Diesel_collections_free-games_EpicGamesStore_lg-black-1200x630-3b7faa2c648f075f126343747afa1a4fb9b6e1a8.png" alt="Diesel_collections_free-games_EpicGamesStore_lg-black-1200x630-3b7faa2c648f075f126343747afa1a4fb9b6e1a8" title="Diesel_collections_free-games_EpicGamesStore_lg-black-1200x630-3b7faa2c648f075f126343747afa1a4fb9b6e1a8" /></figure>
<p>If you want to take advantage of all these free games in future you’ll have to be <a href="https://www.epicgames.com/store/en-US/news/two-factor-authentication-required-when-claiming-free-games" target="_blank" rel="noopener">a bit more safe</a>, according to Epic. Which is some dubious phrasing on my behalf but it’s actually not sinister at all. Epic Games has confirmed that <a href="https://www.destructoid.com/epic-has-a-new-prerequisite-for-getting-free-games-protecting-your-account-588469.phtml" target="_blank" rel="noopener">two-factor authentication is now mandatory</a> for anyone using the store, even if you’re just redeeming a free product. Which is slightly annoying, but it’s also just decent internet practice nowadays. Really, it’s just a tiny inconvenience that only helps keep your account more tightly locked down so it might be a pretty good idea to do it anyway.</p>
<p>From today through to 21 May 2020, all users will have to turn on two-factor authentication to purchase off The Epic Games Store. I assume after that date the choice is up to you but clearly Epic is just doing its best to persuade everyone to get onboard the safety train, even if it is slightly coercive. To turn on your two-factor authentication, just head on over <a href="https://www.epicgames.com/account/password?sessionInvalidated=true" target="_blank" rel="noopener">here</a> and fill in your details.</p><div class="vtusq5ea9e5e156072"><div id='div-gpt-ad-1540806613519-0' style='width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540806613519-0'); });
</script>
</div>
<div id='div-gpt-ad-1540807120663-0' tyle='margin:auto; width:320px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540807120663-0'); });
</script>
</div>
</div><style type="text/css">
.vtusq5ea9e5e156072 {
margin: 5px; padding: 0px;
}
@media screen and (min-width: 1201px) {
.vtusq5ea9e5e156072 {
display: block;
}
}
@media screen and (min-width: 993px) and (max-width: 1200px) {
.vtusq5ea9e5e156072 {
display: block;
}
}
@media screen and (min-width: 769px) and (max-width: 992px) {
.vtusq5ea9e5e156072 {
display: block;
}
}
@media screen and (min-width: 768px) and (max-width: 768px) {
.vtusq5ea9e5e156072 {
display: block;
}
}
@media screen and (max-width: 767px) {
.vtusq5ea9e5e156072 {
display: block;
}
}
</style>
<p>Last Updated: <span class="updated">April 29, 2020</span></p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-1061304" class="share-twitter sd-button share-icon" href="https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-1061304" class="share-facebook sd-button share-icon" href="https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-end"></li></ul></div></div></div>
</div>
<footer>
<div class="bdaia-post-sharing bdaia-post-sharing-bottom">
<ul>
<li class="facebook">
<a title="facebook" onClick="window.open('http://www.facebook.com/sharer.php?u=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/">
<span class="bdaia-io bdaia-io-facebook"></span>
<span>Share on Facebook</span>
</a>
</li>
<li class="twitter">
<a title="twitter" onClick="window.open('http://twitter.com/share?url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/&amp;text=If%20you%20want%20those%20free%20games%20off%20The%20Epic%20Games%20Store,%20you&rsquo;ll%20need%20to%20start%20protecting%20your%20account','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/&amp;text=If%20you%20want%20those%20free%20games%20off%20The%20Epic%20Games%20Store,%20you&rsquo;ll%20need%20to%20start%20protecting%20your%20account">
<span class="bdaia-io bdaia-io-twitter"></span>
<span>Share on Twitter</span>
</a>
</li>
<li class="google">
<a title="google" onClick="window.open('https://plus.google.com/share?url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/">
<span class="bdaia-io bdaia-io-google-plus"></span>
<span>Share on Google+</span>
</a>
</li>
<li class="reddit">
<a title="reddit" onClick="window.open('http://reddit.com/submit?url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/&amp;title=If%20you%20want%20those%20free%20games%20off%20The%20Epic%20Games%20Store,%20you&rsquo;ll%20need%20to%20start%20protecting%20your%20account','Reddit','width=617,height=514,left='+(screen.availWidth/2-308)+',top='+(screen.availHeight/2-257)+''); return false;" href="https://reddit.com/submit?url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/&amp;title=If%20you%20want%20those%20free%20games%20off%20The%20Epic%20Games%20Store,%20you&rsquo;ll%20need%20to%20start%20protecting%20your%20account">
<span class="bdaia-io bdaia-io-reddit"></span>
<span>Share on Reddit</span>
</a>
</li>
<li class="pinterest">
<a title="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fif-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account%2F&amp;description=If+you+want+those+free+games+off+The+Epic+Games+Store%2C+you%26rsquo%3Bll+need+to+start+protecting+your+account&amp;media=https%3A%2F%2Fmedia.criticalhit.net%2F%2F2020%2F04%2FDiesel_collections_free-games_EpicGamesStore_lg-black-1200x630-3b7faa2c648f075f126343747afa1a4fb9b6e1a8.png">
<span class="bdaia-io bdaia-io-social-pinterest"></span>
<span>Share on Pinterest</span>
</a>
</li>
<li class="linkedin">
<a title="linkedin" onClick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/">
<span class="bdaia-io bdaia-io-linkedin2"></span>
<span>Share on Linkedin</span>
</a>
</li>
<li class="tumblr">
<a title="tumblr" onClick="window.open('http://www.tumblr.com/share/link?url=www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/&amp;name=If%20you%20want%20those%20free%20games%20off%20The%20Epic%20Games%20Store,%20you&rsquo;ll%20need%20to%20start%20protecting%20your%20account','Tumblr','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.tumblr.com/share/link?url=www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/&amp;name=If%20you%20want%20those%20free%20games%20off%20The%20Epic%20Games%20Store,%20you&rsquo;ll%20need%20to%20start%20protecting%20your%20account">
<span class="bdaia-io bdaia-io-tumblr"></span>
<span>Share on Tumblr</span>
</a>
</li>
<li class="whatsapp">
<a href="whatsapp://send?text=Starting+from+today%2C+all+users+taking+advantage+of+those+freebies+will+have+to+use+two-factor+authentication+to+redeem+them.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fif-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account%2F"><span class="bdaia-io bdaia-io-whatsapp"></span></a> </li>
<li class="telegram">
<a href="tg://msg?text=Starting+from+today%2C+all+users+taking+advantage+of+those+freebies+will+have+to+use+two-factor+authentication+to+redeem+them.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fif-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account%2F"><span class="bdaia-io bdaia-io-telegram"></span></a> </li>
</ul>
</div>

<div class="bdaia-p-bottom-e3-desktop"><div class="bdaia-e3-container"><div id="contentad298317"></div>
<script type="text/javascript">
    (function(d) {
        var params =
        {
            id: "bdc01488-c73b-4b54-88bd-d9fd30218a86",
            d: "Y3JpdGljYWxoaXQubmV0",
            wid: "298317",
            cb: (new Date()).getTime()
        };
        var qs = Object.keys(params).reduce(function(a, k){ a.push(k + '=' + encodeURIComponent(params[k])); return a},[]).join(String.fromCharCode(38));
        var s = d.createElement('script'); s.type='text/javascript';s.async=true;
        var p = 'https:' == document.location.protocol ? 'https' : 'http';
        s.src = p + "://api.content-ad.net/Scripts/widget2.aspx?" + qs;
        d.getElementById("contentad298317").appendChild(s);
    })(document);
</script></div></div>
<div class="bdaia-post-next-prev">
<div class="bdaia-post-prev-post">
<a href="https://www.criticalhit.net/entertainment/trolls-world-tour-earns-massive-on-vod-prompts-largest-cinema-chain-in-the-world-to-ban-universal-movies/" rel="prev"><span>Previous article</span> Trolls: World Tour earns massive on VOD, prompts largest cinema chain in the world to ban Universal movies</a> </div>
<div class="bdaia-post-next-post">
<a href="https://www.criticalhit.net/technology/reddit-launches-a-new-feature-called-start-chatting/" rel="next"><span>Next article</span> Reddit launches a new feature called Start Chatting</a> </div>
</div>

<div class="bdaia-author-box">
<div class="authorBlock-avatar">
<a href="https://www.criticalhit.net/author/blang/"><img src="https://media.criticalhit.net//2018/11/Brad-150x150.jpg" width="150" height="150" alt="Brad Lang" class="avatar avatar-150 wp-user-avatar wp-user-avatar-150 alignnone photo" /></a>
</div>
<div class="authorBlock-header">
<h3 class="authorBlock-header-title">
<a href="https://www.criticalhit.net/author/blang/">Brad Lang </h3>
<p class="authorBlock-header-bio">
Spent two years completing a Master’s degree in video game storytelling just so people might one day take my opinions seriously. Sometimes I tweet funny things @IceBearlyCoping. </p>
<div class="authorBlock-meta bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-32">
<a class="bdaia-io-url-twitter" href="https://www.twitter.com/IceBearlyCoping"><span class="bdaia-io bdaia-io-twitter"></span></a>
</div>
</div>
</div>
</div>
 </footer>
<span style=display:none itemprop=author>
<meta itemprop=name content="Brad Lang">
</span>
<meta itemprop=interactionCount content="UserComments:0">
<meta itemprop=datePublished content="2020-04-29T13:30:39+00:00">
<meta itemprop=dateModified content="2020-04-29T13:30:39+00:00">
<meta itemprop=mainEntityOfPage itemid="https://www.criticalhit.net/gaming/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account/">
<span style=display:none itemprop=publisher>
<span style=display:none itemprop=logo>
<meta itemprop="url" content="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-Main.png">
</span>
<meta itemprop=name content="Critical Hit">
</span>
<meta itemprop=headline content="If you want those free games off The Epic Games Store, you&rsquo;ll need to start protecting your account">
<span style=display:none itemprop=image>
<meta itemprop=url content="https://media.criticalhit.net//2020/04/Diesel_collections_free-games_EpicGamesStore_lg-black-1200x630-3b7faa2c648f075f126343747afa1a4fb9b6e1a8.png">
<meta itemprop=width content=1240>
<meta itemprop=height content=540>
</span>
</article>
<div id="disqus_thread"></div>
<section id="bdCheckAlso" class="bdCheckAlso-right">
<h4 class="block-title">
<span>Check Also</span>
<a href="#" id="check-also-close"><span class="bdaia-io bdaia-io-cross"></span></a>
</h4>
<div class="check-also-post">
<figure class="check-also-thumb" style="background-image:url(https://media.criticalhit.net//2020/04/Zoom-320x220.jpg);"></figure>
<h2 class="post-title"><a href="https://www.criticalhit.net/technology/us-government-is-pushing-for-the-regulation-of-video-conference-apps-like-zoom/" rel="bookmark">US Government is pushing for the regulation of video conference apps like Zoom</a></h2>
<p>With all the troubles Zoom is facing, it seems the US government is starting to wake up t&#8230;</p>
</div>
</section>
</div>
</div>
<div class="bd-sidebar theia_sticky">
<div class="cfix"></div>
<div class="theiaStickySidebar">
<div id="bdaia-widget-e3-2" class="widget bdaia-widget bdaia-widget-e3 e3-trans"><div class="widget-inner">
<div class="e3-inner"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/300x250ATF', [300, 250]).display();
</script></div></div>
</div><div id="bdaia-social-links-3" class="widget bdaia-widget bdaia-social-links">
<h4 class="block-title"><span>Social</span></h4>
<div class="widget-inner">
<div class="widget-social-links bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class="none bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class="none bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class="none bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class="none bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class="none bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</div><div id="bdaia-widget-box6-2" class="widget bdaia-widget bdaia-box6"><h4 class="block-title"><span>Latest Reviews</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb6 bdaia-wb-idrtdwE bdaia-ajax-pagination-next_prev" data-box_nu="wb6" data-box_id="bdaia-wb-idrtdwE" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="5" data-tag_slug="" data-cat_uid="58" data-cat_uids="" data-max_nu="649" data-total_posts_num="3243" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="true" data-date_meta="true" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-bigsh bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/filament-review-drops-of-juniper/" class="bdaia-text-gradient">
<img width="320" height="220" src="https://media.criticalhit.net//2020/04/Filament-3-320x220.jpg" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="" data-attachment-id="1061452" data-permalink="https://www.criticalhit.net/gaming/filament-review-drops-of-juniper/attachment/filament-3-jpg-2/" data-orig-file="https://media.criticalhit.net//2020/04/Filament-3.jpg" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Filament-3.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/Filament-3-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/04/Filament-3.jpg" /> </a>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/filament-review-drops-of-juniper/"><span>Filament Review &ndash; Drops of Juniper</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">April 29, 2020</span></div>
</footer>
</div>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/gears-tactics-review-okay-boomer/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/04/Gears-Tactics-1-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" data-attachment-id="1060802" data-permalink="https://www.criticalhit.net/gaming/gears-tactics-review-okay-boomer/attachment/gears-tactics-1-jpg/" data-orig-file="https://media.criticalhit.net//2020/04/Gears-Tactics-1.jpg" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Gears-Tactics-1.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/Gears-Tactics-1-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/04/Gears-Tactics-1.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/gears-tactics-review-okay-boomer/"><span>Gears Tactics Review &#8211; Okay Boomer</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">April 27, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/convoy-review-mod-max/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/04/H2x1_NSwitchDS_ConvoyATacticalRoguelike_image1600w-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" data-attachment-id="1060302" data-permalink="https://www.criticalhit.net/gaming/convoy-review-mod-max/attachment/h2x1_nswitchds_convoyatacticalroguelike_image1600w-jpg/" data-orig-file="https://media.criticalhit.net//2020/04/H2x1_NSwitchDS_ConvoyATacticalRoguelike_image1600w.jpg" data-orig-size="918,459" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="H2x1_NSwitchDS_ConvoyATacticalRoguelike_image1600w.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/H2x1_NSwitchDS_ConvoyATacticalRoguelike_image1600w-300x150.jpg" data-large-file="https://media.criticalhit.net//2020/04/H2x1_NSwitchDS_ConvoyATacticalRoguelike_image1600w.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/convoy-review-mod-max/"><span>Convoy Review&ndash;Mod Max</span></a></h3>
 </header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/blang/" title="Posts by Brad Lang" rel="author">Brad Lang</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">April 23, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/code-8-review-great-actors-and-an-intriguing-world-with-a-predictable-sci-fi-crime-plot/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/04/Code8-6-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" data-attachment-id="1058579" data-permalink="https://www.criticalhit.net/entertainment/code-8-review-great-actors-and-an-intriguing-world-with-a-predictable-sci-fi-crime-plot/attachment/code8-6/" data-orig-file="https://media.criticalhit.net//2020/04/Code8-6.jpg" data-orig-size="800,533" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Code8-6" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/Code8-6-300x200.jpg" data-large-file="https://media.criticalhit.net//2020/04/Code8-6.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/code-8-review-great-actors-and-an-intriguing-world-with-a-predictable-sci-fi-crime-plot/"><span>Code 8 Review &#8211; Great actors and an intriguing world with a predictable sci-fi crime plot</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/craigrisi/" title="Posts by Craig Risi" rel="author">Craig Risi</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">April 15, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/primal-review-gendy-tartakovksys-new-series-is-a-savage-and-compassionate-glimpse-of-the-past/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/04/Primal-2-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" data-attachment-id="1057970" data-permalink="https://www.criticalhit.net/entertainment/primal-review-gendy-tartakovksys-new-series-is-a-savage-and-compassionate-glimpse-of-the-past/attachment/primal-2-jpg/" data-orig-file="https://media.criticalhit.net//2020/04/Primal-2.jpg" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Primal-2.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/Primal-2-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/04/Primal-2.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/primal-review-gendy-tartakovksys-new-series-is-a-savage-and-compassionate-glimpse-of-the-past/"><span>Primal Review &ndash; Genndy Tartakovksy&rsquo;s new series is a savage and compassionate glimpse of the past</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">April 8, 2020</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-idrtdwE .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'rtdwE', 'next' );
						});
						jQuery('.bdaia-wb-idrtdwE .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'rtdwE', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-e3-11" class="widget bdaia-widget bdaia-widget-e3 "><h4 class="block-title"><span>Advert</span></h4>
<div class="widget-inner">
<div class="e3-inner"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/300600mid', [300, 600]).display();
</script></div></div>
</div><div id="bdaia-widget-html-4" class="widget bdaia-widget bdaia-widget-html "><h4 class="block-title"><span>Recent Comments</span></h4>
<div class="widget-inner">
<div id="recentcomments" class="dsq-widget"><script type="text/javascript" src="https://critical-hit-net.disqus.com/recent_comments_widget.js?num_items=5&hide_avatars=1&avatar_size=0&excerpt_length=200"></script></div><a href="https://disqus.com/">Powered by Disqus</a></div>
</div><div id="bdaia-widget-box2-4" class="widget bdaia-widget bdaia-box2"><h4 class="block-title"><span>Latest Posts </span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb2 bdaia-wb-idWdbOS bdaia-ajax-pagination-next_prev" data-box_nu="wb2" data-box_id="bdaia-wb-idWdbOS" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="5" data-tag_slug="" data-cat_uid="" data-cat_uids="" data-max_nu="12312" data-total_posts_num="61558" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-big bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/assassins-creed-valhalla-an-interview-with-bosslogic-on-the-creation-of-the-iconic-reveal-art-for-ubisofts-next-historical-epic/">
<img width="320" height="220" src="https://media.criticalhit.net//2020/04/AC-Valhalla-1-320x220.jpg" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="" data-attachment-id="1061503" data-permalink="https://www.criticalhit.net/gaming/assassins-creed-valhalla-an-interview-with-bosslogic-on-the-creation-of-the-iconic-reveal-art-for-ubisofts-next-historical-epic/attachment/ac-valhalla-jpg-2/" data-orig-file="https://media.criticalhit.net//2020/04/AC-Valhalla-1.jpg" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="AC-Valhalla.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/AC-Valhalla-1-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/04/AC-Valhalla-1.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/assassins-creed-valhalla-an-interview-with-bosslogic-on-the-creation-of-the-iconic-reveal-art-for-ubisofts-next-historical-epic/"><span>Assassin&#8217;s Creed Valhalla &ndash; An interview with BossLogic on the creation of the iconic reveal art for Ubisoft&rsquo;s next historical epic</span></a></h3>
</header>
<footer>
</footer>
<p class="block-exb">At this point of the year, Ubisoft’s usually preparing to show off the next &hellip;</p>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/technology/facebook-allowing-creators-to-charge-for-livestreams/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/04/facebook-1-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" srcset="https://media.criticalhit.net/2020/04/facebook-1-104x74.jpg 104w, https://media.criticalhit.net/2020/04/facebook-1-687x485.jpg 687w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1061443" data-permalink="https://www.criticalhit.net/technology/facebook-allowing-creators-to-charge-for-livestreams/attachment/facebook-1-jpg-2/" data-orig-file="https://media.criticalhit.net//2020/04/facebook-1.jpg" data-orig-size="797,485" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="facebook-1.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/facebook-1-300x183.jpg" data-large-file="https://media.criticalhit.net//2020/04/facebook-1.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/technology/facebook-allowing-creators-to-charge-for-livestreams/"><span>Facebook allowing creators to charge for livestreams</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/comics-toys/comic-books-are-coming-back-to-shops-on-may-20/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/04/LCS-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" data-attachment-id="1061409" data-permalink="https://www.criticalhit.net/comics-toys/comic-books-are-coming-back-to-shops-on-may-20/attachment/lcs-jpg-2/" data-orig-file="https://media.criticalhit.net//2020/04/LCS.jpg" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="LCS.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/LCS-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/04/LCS.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/comics-toys/comic-books-are-coming-back-to-shops-on-may-20/"><span>Comic books are coming back to shops on May 20</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/terry-pratchetts-discworld-series-getting-absolutely-faithful-tv-adaptations/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/04/Discworld_CityWatch_1-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" srcset="https://media.criticalhit.net/2020/04/Discworld_CityWatch_1-104x74.jpg 104w, https://media.criticalhit.net/2020/04/Discworld_CityWatch_1-300x217.jpg 300w, https://media.criticalhit.net/2020/04/Discworld_CityWatch_1-768x556.jpg 768w, https://media.criticalhit.net/2020/04/Discworld_CityWatch_1.jpg 800w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1061404" data-permalink="https://www.criticalhit.net/entertainment/terry-pratchetts-discworld-series-getting-absolutely-faithful-tv-adaptations/attachment/discworld_citywatch_1/" data-orig-file="https://media.criticalhit.net//2020/04/Discworld_CityWatch_1.jpg" data-orig-size="800,579" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Discworld_CityWatch_1" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/Discworld_CityWatch_1-300x217.jpg" data-large-file="https://media.criticalhit.net//2020/04/Discworld_CityWatch_1.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/terry-pratchetts-discworld-series-getting-absolutely-faithful-tv-adaptations/"><span>Terry Pratchett&#8217;s Discworld series getting &#8220;absolutely faithful&#8221; TV adaptations</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/filament-review-drops-of-juniper/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/04/Filament-3-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" data-attachment-id="1061452" data-permalink="https://www.criticalhit.net/gaming/filament-review-drops-of-juniper/attachment/filament-3-jpg-2/" data-orig-file="https://media.criticalhit.net//2020/04/Filament-3.jpg" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Filament-3.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/Filament-3-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/04/Filament-3.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/filament-review-drops-of-juniper/"><span>Filament Review &ndash; Drops of Juniper</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-idWdbOS .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'WdbOS', 'next' );
						});
						jQuery('.bdaia-wb-idWdbOS .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'WdbOS', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-box2-2" class="widget bdaia-widget bdaia-box2"><h4 class="block-title"><span>Competitions </span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb2 bdaia-wb-idtWtOR bdaia-ajax-pagination-" data-box_nu="wb2" data-box_id="bdaia-wb-idtWtOR" data-paged="1" data-sort_order="" data-ajax_pagination="" data-num_posts="4" data-tag_slug="" data-cat_uid="34345" data-cat_uids="" data-max_nu="58" data-total_posts_num="231" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="true" data-review="">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-big bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/competitions/win-one-of-ten-free-double-tickets-to-the-rand-show-2020-and-rush/">
<img width="320" height="220" src="https://media.criticalhit.net//2020/03/Rush-Esports-b-320x220.jpg" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="" data-attachment-id="1052105" data-permalink="https://www.criticalhit.net/competitions/win-one-of-ten-free-double-tickets-to-the-rand-show-2020-and-rush/attachment/rush-esports-b/" data-orig-file="https://media.criticalhit.net//2020/03/Rush-Esports-b.jpg" data-orig-size="2048,1364" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Rush-Esports-b" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/03/Rush-Esports-b-300x200.jpg" data-large-file="https://media.criticalhit.net//2020/03/Rush-Esports-b-1024x682.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/competitions/win-one-of-ten-free-double-tickets-to-the-rand-show-2020-and-rush/"><span>Win one of ten free double tickets to The Rand Show 2020 and RUSH!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">March 12, 2020</span></div>
</footer>
<p class="block-exb">Update: The Rand Show and by extension RUSH has been postponed to a later &hellip;</p>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/and-the-winner-of-a-claptrap-cable-guy-is/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/03/Clappy-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" data-attachment-id="1049888" data-permalink="https://www.criticalhit.net/gaming/and-the-winner-of-a-claptrap-cable-guy-is/attachment/clappy/" data-orig-file="https://media.criticalhit.net//2020/03/Clappy.jpg" data-orig-size="849,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Clappy" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/03/Clappy-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/03/Clappy.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/and-the-winner-of-a-claptrap-cable-guy-is/"><span>And the winner of a Claptrap Cable Guy is&hellip;</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">March 2, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/win-one-of-three-sonic-the-hedgehog-hampers/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/02/SonicTheHedgehogFeat-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" srcset="https://media.criticalhit.net/2020/02/SonicTheHedgehogFeat-104x74.jpg 104w, https://media.criticalhit.net/2020/02/SonicTheHedgehogFeat-632x448.jpg 632w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1046757" data-permalink="https://www.criticalhit.net/entertainment/win-one-of-three-sonic-the-hedgehog-hampers/attachment/sonicthehedgehogfeat/" data-orig-file="https://media.criticalhit.net//2020/02/SonicTheHedgehogFeat.jpg" data-orig-size="850,448" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Photo Credit: Courtesy Paramount&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Sonic (Ben Schwartz) in SONIC THE HEDGEHOG from Paramount Pictures and Sega. Photo Credit: Courtesy Paramount Pictures and Sega of America.&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a9 2019 Paramount Pictures and Sega of America, Inc. All Rights Reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="SonicTheHedgehogFeat" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/02/SonicTheHedgehogFeat-300x158.jpg" data-large-file="https://media.criticalhit.net//2020/02/SonicTheHedgehogFeat.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/win-one-of-three-sonic-the-hedgehog-hampers/"><span>Win one of three Sonic the Hedgehog hampers!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">February 17, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/win-a-cable-guy-claptrap-phone-and-controller-holder/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/01/Clappy-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" data-attachment-id="1035844" data-permalink="https://www.criticalhit.net/review/cable-guy-borderlands-3-claptrap-review-if-it-fits-it-sits/attachment/clappy-jpg/" data-orig-file="https://media.criticalhit.net//2020/01/Clappy.jpg" data-orig-size="849,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Clappy.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/01/Clappy-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/01/Clappy.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/win-a-cable-guy-claptrap-phone-and-controller-holder/"><span>Win a Cable Guy Claptrap phone and controller holder!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">February 7, 2020</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
</div>
<style type="text/css">#bdaia-widget-box2-2 .entry-title a:hover{color:#e90d8c !important;}#bdaia-widget-box2-2 .sk-circle .sk-child:before{background:#e90d8c !important;}#bdaia-widget-box2-2 .bdaia-wb-mb-inner{background:#e90d8c !important;}#bdaia-widget-box2-2 h4.block-title:before{background:#e90d8c !important;}#bdaia-widget-box2-2 h4.block-title span, #bdaia-widget-box2-2 h4.block-title a{color:#e90d8c !important;}</style></div></div><div id="bdaia-widget-box3-2" class="widget bdaia-widget bdaia-box3"><h4 class="block-title"><span>Features</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb3 bdaia-wb-idU70jm bdaia-ajax-pagination-next_prev" data-box_nu="wb3" data-box_id="bdaia-wb-idU70jm" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="4" data-tag_slug="" data-cat_uid="48449" data-cat_uids="" data-max_nu="257" data-total_posts_num="1028" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="" data-review="">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-box-row">
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/assassins-creed-valhalla-an-interview-with-bosslogic-on-the-creation-of-the-iconic-reveal-art-for-ubisofts-next-historical-epic/">
<img width="320" height="220" src="https://media.criticalhit.net//2020/04/AC-Valhalla-1-320x220.jpg" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="" data-attachment-id="1061503" data-permalink="https://www.criticalhit.net/gaming/assassins-creed-valhalla-an-interview-with-bosslogic-on-the-creation-of-the-iconic-reveal-art-for-ubisofts-next-historical-epic/attachment/ac-valhalla-jpg-2/" data-orig-file="https://media.criticalhit.net//2020/04/AC-Valhalla-1.jpg" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="AC-Valhalla.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/AC-Valhalla-1-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/04/AC-Valhalla-1.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/assassins-creed-valhalla-an-interview-with-bosslogic-on-the-creation-of-the-iconic-reveal-art-for-ubisofts-next-historical-epic/"><span>Assassin&#8217;s Creed Valhalla &ndash; An interview with BossLogic on the creation of the iconic reveal art for Ubisoft&rsquo;s next historical epic</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/filament-review-drops-of-juniper/">
<img width="320" height="220" src="https://media.criticalhit.net//2020/04/Filament-3-320x220.jpg" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="" data-attachment-id="1061452" data-permalink="https://www.criticalhit.net/gaming/filament-review-drops-of-juniper/attachment/filament-3-jpg-2/" data-orig-file="https://media.criticalhit.net//2020/04/Filament-3.jpg" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Filament-3.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/Filament-3-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/04/Filament-3.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/filament-review-drops-of-juniper/"><span>Filament Review &ndash; Drops of Juniper</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
<div class="bdaia-box-row">
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/dragon-ball-z-kakarots-a-new-power-awakens-dlc-is-all-about-training-and-nothing-else/">
<img width="320" height="220" src="https://media.criticalhit.net//2020/04/DBZ-Kakarot-Path-to-Power-14-320x220.jpg" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="" data-attachment-id="1061293" data-permalink="https://www.criticalhit.net/gaming/dragon-ball-z-kakarots-a-new-power-awakens-dlc-is-all-about-training-and-nothing-else/attachment/dbz-kakarot-path-to-power-14-jpg/" data-orig-file="https://media.criticalhit.net//2020/04/DBZ-Kakarot-Path-to-Power-14.jpg" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="DBZ-Kakarot-Path-to-Power-14.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/DBZ-Kakarot-Path-to-Power-14-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/04/DBZ-Kakarot-Path-to-Power-14.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/dragon-ball-z-kakarots-a-new-power-awakens-dlc-is-all-about-training-and-nothing-else/"><span>Dragon Ball Z: Kakarot&rsquo;s A New Power Awakens DLC is all about training and nothing else</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/wwe-2k20-may-just-be-the-best-worst-thing-to-ever-happen-to-wrestling-games/">
<img width="320" height="220" src="https://media.criticalhit.net//2019/08/WWE-2K20-9-320x220.jpg" class="attachment-bdaia-widget size-bdaia-widget wp-post-image" alt="" data-attachment-id="995436" data-permalink="https://www.criticalhit.net/gaming/what-you-gonna-do-when-the-first-gameplay-trailer-for-wwe-2k20-runs-wild-all-over-you-brother/attachment/wwe-2k20-9-jpg/" data-orig-file="https://media.criticalhit.net//2019/08/WWE-2K20-9.jpg" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="WWE-2K20-9.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2019/08/WWE-2K20-9-300x169.jpg" data-large-file="https://media.criticalhit.net//2019/08/WWE-2K20-9.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/wwe-2k20-may-just-be-the-best-worst-thing-to-ever-happen-to-wrestling-games/"><span>WWE 2K20 may just be the best worst thing to ever happen to wrestling games</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-idU70jm .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'U70jm', 'next' );
						});
						jQuery('.bdaia-wb-idU70jm .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'U70jm', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-e3-13" class="widget bdaia-widget bdaia-widget-e3 "><div class="widget-inner">
<div class="e3-inner"><script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/CH300BTF', [300, 250]).display();
</script></div></div>
</div> </div>
</div>
</div>
</div>
<div class="bdaia-footer-e3-desktop"><div class="bdaia-e3-container"> <div id="leaderboard-pixfuture">
<script src='https://www.googletagservices.com/tag/js/gpt.js'>
  googletag.pubads().definePassback('/55341649/728bottom', [728, 90]).display();
</script>
</div></div></div>
<div class="bdaia-footer">
<div class="bdaia-footer-widgets">
<div class="bd-container">
<div class="bdaia-footer-widgets-area footer-col-three">
<div id="footer-first" class="footer-widget-inner">
<div id="bdaia-widget-html-2" class="widget bdaia-widget bdaia-widget-html e3-trans"><h4 class="block-title"><span>About US</span></h4>
<div class="widget-inner">
<p>
<img src="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-White-1.png" alt="" />
</p>
<p style="margin-top:25px;">
Critical Hit is built on the idea that we are more than one thing. Are you a hardcore gamer who also enjoys a night out at the movies? Perhaps you’re a professional cosplayer who is searching for the perfect burger, or maybe you’re just interested in high-end tech and Netflix binging. Covering gaming, entertainment, tech and geek, Critical Hit offers information and critique from a staff of diverse, knowledgeable and fiercely opinionated writers. </p>
</div>
</div><div id="bdaia-social-links-6" class="widget bdaia-widget bdaia-social-links">
<h4 class="block-title"><span>Follow Us</span></h4>
<div class="widget-inner">
<div class="widget-social-links bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class="none bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class="none bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class="none bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class="none bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class="none bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</div> </div>
<div id="footer-second" class="footer-widget-inner">
<div id="bdaia-widget-box1-2" class="widget bdaia-widget bdaia-box1"><h4 class="block-title"><span>Read This</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb1 bdaia-wb-idp5vfo bdaia-ajax-pagination-" data-box_nu="wb1" data-box_id="bdaia-wb-idp5vfo" data-paged="1" data-sort_order="random_7_day" data-ajax_pagination="" data-num_posts="4" data-tag_slug="" data-cat_uid="" data-cat_uids="" data-max_nu="18" data-total_posts_num="72" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="true" data-date_meta="true" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/actor-vernon-wells-talks-about-plans-of-a-commando-prequel-that-was-at-one-stage-in-development/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/04/commando_arnold_schwarzenegger-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" data-attachment-id="1060393" data-permalink="https://www.criticalhit.net/entertainment/actor-vernon-wells-talks-about-plans-of-a-commando-prequel-that-was-at-one-stage-in-development/attachment/commando_arnold_schwarzenegger/" data-orig-file="https://media.criticalhit.net//2020/04/commando_arnold_schwarzenegger.jpg" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="commando_arnold_schwarzenegger" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/commando_arnold_schwarzenegger-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/04/commando_arnold_schwarzenegger.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/actor-vernon-wells-talks-about-plans-of-a-commando-prequel-that-was-at-one-stage-in-development/"><span>A Commando prequel was once in development</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/craigrisi/" title="Posts by Craig Risi" rel="author">Craig Risi</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">April 23, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/the-crazy-turnip-economy-of-animal-crossing-new-horizons-explained/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/04/Turnips-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" data-attachment-id="1060610" data-permalink="https://www.criticalhit.net/gaming/the-crazy-turnip-economy-of-animal-crossing-new-horizons-explained/attachment/turnips/" data-orig-file="https://media.criticalhit.net//2020/04/Turnips.jpg" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Turnips" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/Turnips-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/04/Turnips.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/the-crazy-turnip-economy-of-animal-crossing-new-horizons-explained/"><span>The crazy turnip economy of Animal Crossing: New Horizons, explained</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/blang/" title="Posts by Brad Lang" rel="author">Brad Lang</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">April 24, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/martial-arts-flavoured-star-wars-show-in-development-from-russian-doll-creator/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/04/RogueOne_DonnieYen-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" srcset="https://media.criticalhit.net/2020/04/RogueOne_DonnieYen-104x74.jpg 104w, https://media.criticalhit.net/2020/04/RogueOne_DonnieYen-687x482.jpg 687w" sizes="(max-width: 104px) 100vw, 104px" data-attachment-id="1060259" data-permalink="https://www.criticalhit.net/entertainment/martial-arts-flavoured-star-wars-show-in-development-from-russian-doll-creator/attachment/null-110/" data-orig-file="https://media.criticalhit.net//2020/04/RogueOne_DonnieYen.jpg" data-orig-size="850,482" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;null&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Rogue One: A Star Wars Story..Chirrut (Donnie Yen)..Photo credit: Lucasfilm\/ILM..\u00a92016 Lucasfilm Ltd. All Rights Reserved.&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;Copyright 2016 Industrial Light &amp; Magic, a division of Lucasfilm Entertainment Company Ltd., All Rights Reserved&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;null&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="RogueOne_DonnieYen" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/RogueOne_DonnieYen-300x170.jpg" data-large-file="https://media.criticalhit.net//2020/04/RogueOne_DonnieYen.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/martial-arts-flavoured-star-wars-show-in-development-from-russian-doll-creator/"><span>Martial arts flavoured Star Wars show in development from Russian Doll creator</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/reaver/" title="Posts by Kervyn Cloete" rel="author">Kervyn Cloete</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">April 23, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/its-official-there-wont-be-a-wwe-2k-game-in-2020/">
<img width="104" height="74" src="https://media.criticalhit.net//2020/04/WWE-2K-104x74.jpg" class="attachment-bdaia-small size-bdaia-small wp-post-image" alt="" data-attachment-id="1060485" data-permalink="https://www.criticalhit.net/gaming/its-official-there-wont-be-a-wwe-2k-game-in-2020/attachment/wwe-2k-jpg/" data-orig-file="https://media.criticalhit.net//2020/04/WWE-2K.jpg" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="WWE-2K.jpg" data-image-description="" data-medium-file="https://media.criticalhit.net//2020/04/WWE-2K-300x169.jpg" data-large-file="https://media.criticalhit.net//2020/04/WWE-2K.jpg" /> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/its-official-there-wont-be-a-wwe-2k-game-in-2020/"><span>It&rsquo;s official, there won&rsquo;t be a WWE 2K game in 2020</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">April 24, 2020</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
</div>
</div></div> </div>
<div id="footer-third" class="footer-widget-inner">
<div id="bdaia-widget-timeline-2" class="widget bdaia-widget bdaia-widget-timeline">
<h4 class="block-title"><span>Timeline</span></h4>
<div class="widget-inner">
<ul>
<li>
<a href="https://www.criticalhit.net/gaming/assassins-creed-valhalla-an-interview-with-bosslogic-on-the-creation-of-the-iconic-reveal-art-for-ubisofts-next-historical-epic/">
<span class="bdayh-date">April 29, 2020</span> <h3>Assassin&#8217;s Creed Valhalla &ndash; An interview with BossLogic on the creation of the iconic reveal art for Ubisoft&rsquo;s next historical epic</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/technology/facebook-allowing-creators-to-charge-for-livestreams/">
<span class="bdayh-date">April 29, 2020</span> <h3>Facebook allowing creators to charge for livestreams</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/comics-toys/comic-books-are-coming-back-to-shops-on-may-20/">
<span class="bdayh-date">April 29, 2020</span> <h3>Comic books are coming back to shops on May 20</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/entertainment/terry-pratchetts-discworld-series-getting-absolutely-faithful-tv-adaptations/">
<span class="bdayh-date">April 29, 2020</span> <h3>Terry Pratchett&#8217;s Discworld series getting &#8220;absolutely faithful&#8221; TV adaptations</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/gaming/filament-review-drops-of-juniper/">
<span class="bdayh-date">April 29, 2020</span> <h3>Filament Review &ndash; Drops of Juniper</h3>
</a>
</li>
</ul>
</div>
</div> </div>
</div>
</div>
</div>
<div class="woohoo-footer-top-area" style="background-color:#000000;">
<div class="bd-container">
<div class="woohoo-footer-menu">
<div class="menu-footer-container"><ul id="menu-footer" class="footer-bottom-menu"><li id="menu-item-573845" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-573845"><a href="https://www.criticalhit.net/">Critical Hit</a></li>
<li id="menu-item-574303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574303"><a href="https://www.criticalhit.net/contact/">Contact</a></li>
<li id="menu-item-573839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-573839"><a href="https://www.criticalhit.net/advertise/">Advertise</a></li>
<li id="menu-item-574736" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574736"><a href="https://www.criticalhit.net/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-574795" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574795"><a href="https://www.criticalhit.net/privacy-policy/">Privacy Policy</a></li>
</ul></div> </div>
</div>
</div>
<div class="bdaia-footer-area" style="background-color:#000000;">
<div class="bd-container">
<div class="bdaia-footer-area-l">
</div>
<div class="bdaia-footer-area-r">
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

<noscript><iframe src=\"https://www.googletagmanager.com/ns.html?id=GTM-5GNB24P\"
height=\"0\" width=\"0\" style=\"display:none;visibility:hidden\"></iframe></noscript>

<div class="gotop" title="Go Top"><span class="bdaia-io bdaia-io-chevron-up"></span></div><div id="reading-position-indicator"></div>
<script>
    </script>
<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.criticalhit.net\/gaming\/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account\/":1061304};
	</script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"critical-hit-net"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/disqus-comment-system/public/js/comment_count.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"1061304 https:\/\/www.criticalhit.net\/?p=1061304","disqusShortname":"critical-hit-net","disqusTitle":"If you want those free games off The Epic Games Store, you\u2019ll need to start protecting your account","disqusUrl":"https:\/\/www.criticalhit.net\/gaming\/if-you-want-those-free-games-off-the-epic-store-youll-need-to-start-protecting-your-account\/","postId":"1061304"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var JQLBSettings = {"fitToScreen":"0","resizeSpeed":"400","displayDownloadLink":"0","navbarOnTop":"0","loopImages":"","resizeCenter":"","marginSize":"","linkTarget":"","help":"","prevLinkTitle":"previous image","nextLinkTitle":"next image","prevLinkText":"\u00ab Previous","nextLinkText":"Next \u00bb","closeTitle":"close image gallery","image":"Image ","of":" of ","download":"Download","jqlb_overlay_opacity":"80","jqlb_overlay_color":"#000000","jqlb_overlay_close":"1","jqlb_border_width":"10","jqlb_border_color":"#ffffff","jqlb_border_radius":"0","jqlb_image_info_background_transparency":"100","jqlb_image_info_bg_color":"#ffffff","jqlb_image_info_text_color":"#000000","jqlb_image_info_text_fontsize":"10","jqlb_show_text_for_image":"1","jqlb_next_image_title":"next image","jqlb_previous_image_title":"previous image","jqlb_next_button_image":"https:\/\/www.criticalhit.net\/wp-content\/plugins\/wp-lightbox-2\/styles\/images\/next.gif","jqlb_previous_button_image":"https:\/\/www.criticalhit.net\/wp-content\/plugins\/wp-lightbox-2\/styles\/images\/prev.gif","jqlb_maximum_width":"","jqlb_maximum_height":"","jqlb_show_close_button":"1","jqlb_close_image_title":"close image gallery","jqlb_close_image_max_heght":"22","jqlb_image_for_close_lightbox":"https:\/\/www.criticalhit.net\/wp-content\/plugins\/wp-lightbox-2\/styles\/images\/closelabel.gif","jqlb_keyboard_navigation":"1","jqlb_popup_size_fix":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/wp-lightbox-2/wp-lightbox-2.min.js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/plugins/easy-table/js/easy-table-script.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var bd = "{\"nonce\":\"e95bec7c45\",\"ajaxurl\":\"https:\\\/\\\/www.criticalhit.net\\\/wp-admin\\\/admin-ajax.php\",\"is_singular\":true,\"has_lazy_load\":false,\"bd_lazyload\":false,\"mobile_topmenu\":true,\"sticky_sidebar\":true,\"all_lightbox\":true,\"click_to_comments\":false,\"post_reading_position_indicator\":\"1\"}";
/* ]]> */
</script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/themes/woohoo/js/main.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://www.criticalhit.net/wp-content/themes/woohoo/js/search.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.4.2/_inc/build/spin.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.4.2/_inc/build/jquery.spin.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","nonce":"057a5af9a4","display_exif":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"white","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.criticalhit.net\/wp-login.php?redirect_to=https%3A%2F%2Fwww.criticalhit.net%2Fgaming%2Fassassins-creed-valhalla-an-interview-with-bosslogic-on-the-creation-of-the-iconic-reveal-art-for-ubisofts-next-historical-epic%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.4.2/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.4.2/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202018.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.4.2',blog:'122131268',post:'1061304',tz:'2',srv:'www.criticalhit.net'} ]);
	_stq.push([ 'clickTrackerInit', '122131268', '1061304' ]);
</script>
</body>
</html>