<!DOCTYPE html>
<html lang="en-GB" prefix="og: https://ogp.me/ns#" prefix="og: http://ogp.me/ns#">
<head>

<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="10f54106f69c6db055441066-text/javascript" charset="UTF-8" data-domain-script="6a9e0b5d-495a-45f8-95da-3962f059fa4e"></script>
<script type="10f54106f69c6db055441066-text/javascript">
function OptanonWrapper() { }
</script>

<meta property="fb:pages" content="161755108961" />
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.criticalhit.net/xmlrpc.php" />

<meta name="google-site-verification" content="1vFejJFCT-gTHbz4YXtJrlWGHn4iBz-VmX1lyaF2QQ4" />

<title>AMD announces new, more powerful Ryzen processors</title>
<meta name="description" content="AMD has delivered on its promise of new chip based on its Zen 3 architecture that promises greater performance and impressive battery life." />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/" />
<meta property="og:locale" content="en_GB">
<meta property="og:type" content="article">
<meta property="og:title" content="AMD announces new, more powerful Ryzen processors">
<meta property="og:description" content="AMD has delivered on its promise of new chip based on its Zen 3 architecture that promises greater performance and impressive battery life.">
<meta property="og:url" content="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/">
<meta property="og:site_name" content="Critical Hit">
<meta property="article:publisher" content="https://facebook.com/criticalhit.net">
<meta property="article:author" content="https://www.facebook.com/craig.risi">
<meta property="article:tag" content="AMD">
<meta property="article:tag" content="Ryzen">
<meta property="article:tag" content="Ryzen 5000 series">
<meta property="article:tag" content="Zen 3 Architecture">
<meta property="article:section" content="Technology">
<meta property="og:updated_time" content="2021-01-13T10:36:41+02:00">
<meta property="og:image" content="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg">
<meta property="og:image:secure_url" content="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg">
<meta property="og:image:width" content="800">
<meta property="og:image:height" content="450">
<meta property="og:image:alt" content="AMD announces new, more powerful Ryzen processors">
<meta property="og:image:type" content="image/jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="AMD announces new, more powerful Ryzen processors">
<meta name="twitter:description" content="AMD has delivered on its promise of new chip based on its Zen 3 architecture that promises greater performance and impressive battery life.">
<meta name="twitter:site" content="@CriticalHitNet">
<meta name="twitter:creator" content="@RisiCraig">
<meta name="twitter:image" content="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg">
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.criticalhit.net/#organization","name":"Critical Hit","url":"https://www.criticalhit.net","email":"info@criticalhit.net","logo":{"@type":"ImageObject","url":"https://media.criticalhit.net//2019/03/Critical_Hit-Logo-Icon.png"}},{"@type":"WebSite","@id":"https://www.criticalhit.net/#website","url":"https://www.criticalhit.net","name":"Critical Hit","publisher":{"@id":"https://www.criticalhit.net/#organization"},"inLanguage":"en-GB","potentialAction":{"@type":"SearchAction","target":"https://www.criticalhit.net/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/#primaryImage","url":"https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?fit=800%2C450&ssl=1","width":800,"height":450},{"@type":"WebPage","@id":"https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/#webpage","url":"https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/","name":"AMD announces new, more powerful Ryzen processors","datePublished":"2021-01-13T12:45:00+02:00","dateModified":"2021-01-13T10:36:41+02:00","isPartOf":{"@id":"https://www.criticalhit.net/#website"},"primaryImageOfPage":{"@id":"https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/#primaryImage"},"inLanguage":"en-GB"},{"@type":"NewsArticle","headline":"AMD announces new, more powerful Ryzen processors","datePublished":"2021-01-13T12:45:00+02:00","dateModified":"2021-01-13T10:36:41+02:00","author":{"@type":"Person","name":"Craig Risi"},"publisher":{"@id":"https://www.criticalhit.net/#organization"},"description":"AMD has delivered on its promise of new chip based on its Zen 3 architecture that promises greater performance and impressive battery life.","@id":"https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/#richSnippet","isPartOf":{"@id":"https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/#webpage"},"image":{"@id":"https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/#primaryImage"},"inLanguage":"en-GB","mainEntityOfPage":{"@id":"https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/#webpage"}}]}</script>

<link rel='dns-prefetch' href='//www.criticalhit.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; Feed" href="https://www.criticalhit.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; Comments Feed" href="https://www.criticalhit.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Critical Hit &raquo; AMD announces new, more powerful Ryzen processors Comments Feed" href="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/feed/" />
<script type="10f54106f69c6db055441066-text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.criticalhit.net\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='bdaia_shorty-style-css' href='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='formidable-css' href='https://www.criticalhit.net/wp-content/plugins/formidable/css/formidableforms.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.6/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://c0.wp.com/c/5.6/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='bdaia_shorty_stylesheet-css' href='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/shortcodes.css' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='theme-child-style-css' href='https://www.criticalhit.net/wp-content/themes/woohoo-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='woohoo-google-fonts-css' href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C300%2C700%7CLato%3A400%2C300%2C700%2C900%7CWork+Sans%3A400%2C300%2C500%2C600%2C700%2C800%2C900%7COpen+Sans%3A400%2C600%2C700%2C800%7CPlayfair+Display%3A400%2C700%2C900%2C400italic%7CRaleway%3A400%2C300%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A400%2C300%2C100%2C700%7CMontserrat%3A400%2C700&#038;subset=latin%2Cgreek%2Cgreek-ext%2Cvietnamese%2Ccyrillic-ext%2Clatin-ext%2Ccyrillic' type='text/css' media='all' />
<link rel='stylesheet' id='easy_table_style-css' href='https://www.criticalhit.net/wp-content/plugins/easy-table/themes/default/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='woohoo-default-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/style.css' type='text/css' media='all' />
<style id='woohoo-default-inline-css' type='text/css'>
body.category-41989 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-5 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-33983 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-41988 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-34107 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-58 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-41990 div.bdaia-blocks div.bdaia-post-view{display: none !important;}body.category-38 div.bdaia-blocks div.bdaia-post-view{display: none !important;}
</style>
<link rel='stylesheet' id='wooohoo-ilightbox-skin-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='wooohoo-ilightbox-skin-black-css' href='https://www.criticalhit.net/wp-content/themes/woohoo/css/ilightbox/metro-black-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://c0.wp.com/p/jetpack/9.3/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/9.3/css/jetpack.css' type='text/css' media='all' />
<script type="10f54106f69c6db055441066-text/javascript" id='jquery-core-js-extra'>
/* <![CDATA[ */
var bd_w_blocks = {"bdaia_w_ajax_url":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","bdaia_w_ajax_nonce":"728caf6159"};
var bd_blocks = {"bdaia_ajax_url":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","bdaia_ajaxnonce":"728caf6159"};
var bd_script = {"post_id":"1123668","ajaxurl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://c0.wp.com/c/5.6/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://c0.wp.com/c/5.6/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/js/scripts.js' id='bdaia_shorty_scripts-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://www.criticalhit.net/wp-content/plugins/bdaia-shortcodes/assets/js/shorty-min.js' id='bdaia_shorty_min-js'></script>
<link rel="https://api.w.org/" href="https://www.criticalhit.net/wp-json/" /><link rel="alternate" type="application/json" href="https://www.criticalhit.net/wp-json/wp/v2/posts/1123668" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.criticalhit.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.criticalhit.net/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.6" />
<link rel='shortlink' href='https://www.criticalhit.net/?p=1123668' />
<link rel="alternate" type="application/json+oembed" href="https://www.criticalhit.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.criticalhit.net%2Ftechnology%2Famd-announces-new-more-powerful-ryzen-processors%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.criticalhit.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.criticalhit.net%2Ftechnology%2Famd-announces-new-more-powerful-ryzen-processors%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.23.0" /><style type='text/css'>img#wpstats{display:none}</style> <script type="10f54106f69c6db055441066-text/javascript">
            /* <![CDATA[ */
            var sf_position = '0';
            var sf_templates = "<a href=\"{search_url_escaped}\"><span class=\"sf_text\">View All Results<\/span><\/a>";
            var sf_input = '.search-live';
            jQuery(document).ready(function(){
                jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/www.criticalhit.net\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","rtl":0});
                jQuery(".live-search_ajaxy-selective-input").keyup(function() {
                    var width = jQuery(this).val().length * 8;
                    if(width < 50) {
                        width = 50;
                    }
                    jQuery(this).width(width);
                });
                jQuery(".live-search_ajaxy-selective-search").click(function() {
                    jQuery(this).find(".live-search_ajaxy-selective-input").focus();
                });
                jQuery(".live-search_ajaxy-selective-close").click(function() {
                    jQuery(this).parent().remove();
                });
            });
            /* ]]> */
        </script>
<link rel="shortcut icon" href="https://media.criticalhit.net/2018/12/favicon.png" type="image/x-icon" />
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-89232854-1" type="10f54106f69c6db055441066-text/javascript"></script>
<script type="10f54106f69c6db055441066-text/javascript">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-89232854-1');
</script>
<script data-ad-client="ca-pub-1473612930314813" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="10f54106f69c6db055441066-text/javascript"></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js" type="10f54106f69c6db055441066-text/javascript"></script>
<style>

@media all and (min-device-width: 700px) and (max-device-width: 728px) {#leaderboard-pixfuture {transform: scale(0.9);}} @media all and (min-device-width: 671px) and (max-device-width: 699px) {#leaderboard-pixfuture {transform: scale(0.9);transform-origin: 0 0;}} @media all and (min-device-width: 651px) and (max-device-width: 670px) {#leaderboard-pixfuture {transform: scale(0.88);transform-origin: 0 0;}} @media all and (min-device-width: 631px) and (max-device-width: 650px) {#leaderboard-pixfuture {transform: scale(0.85);transform-origin: 0 0;}} @media all and (min-device-width: 601px) and (max-device-width: 630px) {#leaderboard-pixfuture {transform: scale(0.8);transform-origin: 0 0;}} @media all and (min-device-width: 601px) and (max-device-width: 630px) {#leaderboard-pixfuture {transform: scale(0.8);transform-origin: 0 0;}} @media all and (min-device-width: 560px) and (max-device-width: 600px) {#leaderboard-pixfuture {transform: scale(0.75);transform-origin: 0 0;}} @media all and (min-device-width: 520px) and (max-device-width: 559px) {#leaderboard-pixfuture {transform: scale(0.7);transform-origin: 0 0;}} @media all and (min-device-width: 491px) and (max-device-width: 519px) {#leaderboard-pixfuture {transform: scale(0.65);transform-origin: 0 0;}} @media all and (min-device-width: 451px) and (max-device-width: 490px) {#leaderboard-pixfuture {transform: scale(0.6);transform-origin: 0 0;}} @media all and (min-device-width: 401px) and (max-device-width: 450px) {#leaderboard-pixfuture {transform: scale(0.55);transform-origin: 0 0;}} @media all and (min-device-width: 371px) and (max-device-width: 400px) {#leaderboard-pixfuture {transform: scale(0.5);transform-origin: 0 0;}} @media all and (min-device-width: 341px) and (max-device-width: 370px) {#leaderboard-pixfuture {transform: scale(0.46);transform-origin: 0 0;}} @media all and (min-device-width: 301px) and (max-device-width: 340px) {#leaderboard-pixfuture {transform: scale(0.42);transform-origin: 0 0;}} @media all and (max-device-width: 300px) {#leaderboard-pixfuture {transform: scale(0.4);transform-origin: 0 0;}}

</style>
<script type="10f54106f69c6db055441066-text/javascript">
/* <![CDATA[ */
var userRating = {"ajaxurl":"https://www.criticalhit.net/wp-admin/admin-ajax.php" , "your_rating":"" , "nonce":"728caf6159"};
var userLike = {"ajaxurl":"https://www.criticalhit.net/wp-admin/admin-ajax.php" , "nonce":"728caf6159"};
/* ]]> */
var bdaia_theme_uri = 'https://www.criticalhit.net/wp-content/themes/woohoo';
</script>
<style type="text/css">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</style><meta name="google-site-verification" content="oaOpgh_1OG0g963kfPRsU8QMMrkWBD1cAC_zyhXnAvc"><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/media.criticalhit.net//2017/01/cropped-Critical_Hit-Logo-Icon.png?fit=270%2C270&#038;ssl=1" />
<style type="text/css" id="wp-custom-css">
				.bdaia-post-content blockquote p,
blockquote p  {
  font-size: 20px !important;
  background: #f9f9f9 !important;
  border-left: 10px solid #ccc !important;
  margin: .5em 10px !important;
  padding: 0 10px !important;
  quotes: "\201C""\201D""\2018""\2019" !important;
  padding: 10px 20px !important;
  line-height: 1.4 !important;
	text-transform: none !important;
	color: grey  !important;
	text-align: left !important;
	font-weight: 300 !important;
}

.bdaia-post-content blockquote, blockquote {
    margin: 20px 5px 10px 0px !important;
	    padding-left: 0px !important;
    border-left: none !important;
}

.wp-block-jetpack-gif .wp-block-jetpack-gif-caption {
    color: #ffffff !important;
    font-weight: bold;
}			</style>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js' type="10f54106f69c6db055441066-text/javascript"></script>
<script type="10f54106f69c6db055441066-text/javascript">
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<meta name="msvalidate.01" content="2408EBF25A6FABECCCF3EC45230C1258" /> 
<script type="10f54106f69c6db055441066-text/javascript">
!function(a){var b=/iPhone/i,c=/iPod/i,d=/iPad/i,e=/(?=.*\bAndroid\b)(?=.*\bMobile\b)/i,f=/Android/i,g=/(?=.*\bAndroid\b)(?=.*\bSD4930UR\b)/i,h=/(?=.*\bAndroid\b)(?=.*\b(?:KFOT|KFTT|KFJWI|KFJWA|KFSOWI|KFTHWI|KFTHWA|KFAPWI|KFAPWA|KFARWI|KFASWI|KFSAWI|KFSAWA)\b)/i,i=/IEMobile/i,j=/(?=.*\bWindows\b)(?=.*\bARM\b)/i,k=/BlackBerry/i,l=/BB10/i,m=/Opera Mini/i,n=/(CriOS|Chrome)(?=.*\bMobile\b)/i,o=/(?=.*\bFirefox\b)(?=.*\bMobile\b)/i,p=new RegExp("(?:Nexus 7|BNTV250|Kindle Fire|Silk|GT-P1000)","i"),q=function(a,b){return a.test(b)},r=function(a){var r=a||navigator.userAgent,s=r.split("[FBAN");return"undefined"!=typeof s[1]&&(r=s[0]),s=r.split("Twitter"),"undefined"!=typeof s[1]&&(r=s[0]),this.apple={phone:q(b,r),ipod:q(c,r),tablet:!q(b,r)&&q(d,r),device:q(b,r)||q(c,r)||q(d,r)},this.amazon={phone:q(g,r),tablet:!q(g,r)&&q(h,r),device:q(g,r)||q(h,r)},this.android={phone:q(g,r)||q(e,r),tablet:!q(g,r)&&!q(e,r)&&(q(h,r)||q(f,r)),device:q(g,r)||q(h,r)||q(e,r)||q(f,r)},this.windows={phone:q(i,r),tablet:q(j,r),device:q(i,r)||q(j,r)},this.other={blackberry:q(k,r),blackberry10:q(l,r),opera:q(m,r),firefox:q(o,r),chrome:q(n,r),device:q(k,r)||q(l,r)||q(m,r)||q(o,r)||q(n,r)},this.seven_inch=q(p,r),this.any=this.apple.device||this.android.device||this.windows.device||this.other.device||this.seven_inch,this.phone=this.apple.phone||this.android.phone||this.windows.phone,this.tablet=this.apple.tablet||this.android.tablet||this.windows.tablet,"undefined"==typeof window?this:void 0},s=function(){var a=new r;return a.Class=r,a};"undefined"!=typeof module&&module.exports&&"undefined"==typeof window?module.exports=r:"undefined"!=typeof module&&module.exports&&"undefined"!=typeof window?module.exports=s():"function"==typeof define&&define.amd?define("isMobile",[],a.isMobile=s()):a.isMobile=s()}(this);
  googletag.cmd.push(function() {
	if(isMobile.any) {
	googletag.defineSlot('/55341649/300250MidarticleMobile', [300, 250],
		'div-gpt-ad-1540807120663-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/300x250ACmobile', [300, 250],
	    'div-gpt-ad-1540807963183-0').addService(googletag.pubads());
			googletag.defineSlot('/55341649/MastheadTop', [728, 90],
			'div-gpt-ad-1542102676397-0').addService(googletag.pubads());

	} else {
	googletag.defineSlot('/55341649/MastheadTop', [728, 90],
	'div-gpt-ad-1542102676397-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/728MidArticle', [728, 90],
			'div-gpt-ad-1540806613519-0').addService(googletag.pubads());
  googletag.defineSlot('/55341649/728Comments', [728, 90],
	    'div-gpt-ad-1540808126586-0').addService(googletag.pubads());
	googletag.defineSlot('/55341649/Background', [1, 1],
		'div-gpt-ad-1540376831756-0').addService(googletag.pubads());

    }
	googletag.enableServices();
  });
</script>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "WebSite",
  "url": "https://www.criticalhit.net/",
  "name": "Critical Hit",
  "description": "Critical Hit is a website built on the idea that we are more than one thing. Writers, writing about the things they love; games, film, TV, technology and more.",
  "publisher": "Critical Hit",
  "potentialAction": {
    "@type": "SearchAction",
    "target": "https://www.criticalhit.net/?s={search_term}",
    "query-input": "required name=search_term" }
    }
</script>
<script type="application/ld+json">
{
  "@context": "https://schema.org",
  "@type": "Organization",
  "url": "https://www.criticalhit.net",
  "logo": "https://www.criticalhit.net/images/Icon.png"
}
</script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="10f54106f69c6db055441066-text/javascript"></script>
<script type="10f54106f69c6db055441066-text/javascript">
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-1473612930314813",
          enable_page_level_ads: false
     });
</script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.flexslider-min.js" type="10f54106f69c6db055441066-text/javascript"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.eislideshow.js" type="10f54106f69c6db055441066-text/javascript"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.placeholder.min.js" type="10f54106f69c6db055441066-text/javascript"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/jquery.fitvids.js" type="10f54106f69c6db055441066-text/javascript"></script>
<script src="https://www.criticalhit.net/wp-content/themes/woohoo/js/modernizr.js" type="10f54106f69c6db055441066-text/javascript"></script>
<script type="10f54106f69c6db055441066-text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/criticalhit/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
</head>
<body class="post-template-default single single-post postid-1123668 single-format-standard wp-embed-responsive bdaia-boxed  of-new-article  has-lazy-load" itemscope itemtype="http://schema.org/WebPage">
<div class="page-outer bdaia-header-default bdaia-lazyload  sticky-nav-on  bdaia-post-template-default  bdaia-sidebar-right ">
<div class="bg-cover"></div>
<aside id="bd-MobileSiderbar">
<div id="mobile-menu"></div>
<div class="widget-social-links bdaia-social-io-colored">
<div class="sl-widget-inner">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class=" bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class=" bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class=" bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class=" bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class=" bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</aside>

<div id='div-gpt-ad-1540376831756-0' style='height:1px; width:1px;'>
<script type="10f54106f69c6db055441066-text/javascript">
	googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540376831756-0'); });
	</script>
</div>
<div id="page">
<div class="inner-wrapper">
<div id="warp" class="clearfix  bdaia-sidebar-right ">
<div class="header-wrapper">
<div class="bdayh-click-open">
<div class="bd-ClickOpen bd-ClickAOpen">
<span></span>
</div>
</div>
<header class="header-container">
<div class="bd-container">
<div class="logo site--logo">
<h2 class="site-title"> <a href="https://www.criticalhit.net/" rel="home" title="Critical Hit">
<img src="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-Technology.png" alt="Critical Hit" />
</a>
</h2> </div>
<div class="bdaia-header-e3-desktop"><div class="bdaia-e3-container"> <div id="leaderboard-pixfuture" style="width:728px; margin:0 auto;">
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js" type="10f54106f69c6db055441066-text/javascript"></script>
<div id="gpt-passback">
<script type="10f54106f69c6db055441066-text/javascript">
    window.googletag = window.googletag || {cmd: []};
    googletag.cmd.push(function() {
    googletag.defineSlot('/55341649/MastheadTop', [728, 90], 'gpt-passback').addService(googletag.pubads());
    googletag.enableServices();
    googletag.display('gpt-passback');
    });
  </script>
</div>
</div></div></div>
</div>
</header>
<div class="cfix"></div>
<nav id="navigation" class="">
<div class="navigation-wrapper">
<div class="bd-container">
<div class="primary-menu">
<a class="nav-logo" title="Critical Hit" href="https://www.criticalhit.net/">
<img src="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-Text-Only.png" width="195" height="48" alt="Critical Hit" />
</a>
<ul id="menu-primary">
<li id="menu-item-526858" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/gaming/"> <i class="fa fa fa-gamepad"></i> <span class="menu-label" style="">Games</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526854" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/entertainment/"> <i class="fa fa fa-film"></i> <span class="menu-label" style="">Entertainment</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526870" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/technology/"> <i class="fa fa fa-power-off"></i> <span class="menu-label" style="">Tech</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526876" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/comics-toys/"> <i class="fa fa fa-comment-o"></i> <span class="menu-label" style="">Comics</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-526860" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/lifestyle/"> <i class="fa fa fa-heart"></i> <span class="menu-label" style="">Lifestyle</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-726070" class=" menu-item menu-item-type-post_type menu-item-object-page bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/esports/"> <i class="fa fa fa-users"></i> <span class="menu-label" style="">esports</span></a>
<div class="mega-menu-content">
</div><li id="menu-item-881926" class=" menu-item menu-item-type-taxonomy menu-item-object-category bd_depth- bd_menu_item "><a href="https://www.criticalhit.net/category/review/"> <i class="fa fa fa-book"></i> <span class="menu-label" style="">Reviews</span></a>
<div class="mega-menu-content">
</div> </ul>
</div>
<div class="nav-right-area">
<div class="bdaia-nav-search">
<span class="bdaia-ns-btn bdaia-io bdaia-io-search"></span>
<div class="bdaia-ns-wrap">
<div class="bdaia-ns-content">
<div class="bdaia-ns-inner">
<form method="get" id="searchform" action="https://www.criticalhit.net/">
<input type="text" class="bbd-search-field search-live" id="s" name="s" value="Search" onfocus="if (!window.__cfRLUnblockHandlers) return false; if (this.value == 'Search') {this.value = '';}" onblur="if (!window.__cfRLUnblockHandlers) return false; if (this.value == '') {this.value = 'Search';}" data-cf-modified-10f54106f69c6db055441066-="" />
<button type="submit" class="bbd-search-btn"><span class="bdaia-io bdaia-io-search"></span></button>
</form>
</div>
</div>
</div>
</div>
</div>
<div class="cfix"></div>
</div>
</div>
</nav>
<div class="cfix"></div>
</div>
<div class="bdMain">
<div class="bd-container bdaia-post-template">
<div class="bd-main bdaia-site-content" id="bdaia-primary">
<div id="content" role="main">
<div class="bdaia-crumb-container"><span><a class="crumbs-home" href="https://www.criticalhit.net">Home</a></span> <span class="delimiter"><span class="bdaia-io bdaia-io-angle-double-right"></span></span> <span><a href="https://www.criticalhit.net/category/technology/">Technology</a></span> <span class="delimiter"><span class="bdaia-io bdaia-io-angle-double-right"></span></span> <span class="current">AMD announces new, more powerful Ryzen processors</span></div><div class="bdayh-clearfix"></div>
<article id="post-1123668" class="hentry post-1123668 post type-post status-publish format-standard has-post-thumbnail category-technology tag-amd tag-ryzen tag-ryzen-5000-series tag-zen-3-architecture" itemscope itemtype="https://schema.org/Article">
<header class="bdaia-post-header">
<div class="bdaia-post-title">
<h1 class="post-title entry-title"><span>AMD announces new, more powerful Ryzen processors</span></h1>
</div>

<div class="bdaia-meta-info">
<div class="bdaia-post-author-name">
By <a href="https://www.criticalhit.net/author/craigrisi/" title="">Craig Risi </a>
<a href="https://twitter.com/RisiCraig" target="_blank">
<span class="bdaia-io bdaia-io-twitter"></span>
</a>
</div>
<div class="bdaia-post-date"><span class='bdaia-io bdaia-io-calendar'></span>Posted on&nbsp;<span class="bdayh-date">18 seconds ago</span></div>
<div class="bdaia-post-time-read"><span class='bdaia-io bdaia-io-clock'></span>3&nbsp;min read</div>
<div class="bdaia-post-comment"><span class='bdaia-io bdaia-io-bubbles4'></span><a href="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/#respond"><span class="dsq-postid" data-dsqidentifier="1123668 https://www.criticalhit.net/?p=1123668">0</span></a></div>
</div>

 </header>
<div class="bdaia-post-sharing bdaia-post-sharing-top">
<ul>
<li class="facebook">
<a title="facebook" onClick="if (!window.__cfRLUnblockHandlers) return false; window.open('http://www.facebook.com/sharer.php?u=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/" data-cf-modified-10f54106f69c6db055441066-="">
<span class="bdaia-io bdaia-io-facebook"></span>
<span>Share on Facebook</span>
</a>
</li>
<li class="twitter">
<a title="twitter" onClick="if (!window.__cfRLUnblockHandlers) return false; window.open('http://twitter.com/share?url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/&amp;text=AMD%20announces%20new,%20more%20powerful%20Ryzen%20processors','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/&amp;text=AMD%20announces%20new,%20more%20powerful%20Ryzen%20processors" data-cf-modified-10f54106f69c6db055441066-="">
<span class="bdaia-io bdaia-io-twitter"></span>
<span>Share on Twitter</span>
</a>
</li>
<li class="google">
<a title="google" onClick="if (!window.__cfRLUnblockHandlers) return false; window.open('https://plus.google.com/share?url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/" data-cf-modified-10f54106f69c6db055441066-="">
<span class="bdaia-io bdaia-io-google-plus"></span>
<span>Share on Google+</span>
</a>
</li>
<li class="reddit">
<a title="reddit" onClick="if (!window.__cfRLUnblockHandlers) return false; window.open('http://reddit.com/submit?url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/&amp;title=AMD%20announces%20new,%20more%20powerful%20Ryzen%20processors','Reddit','width=617,height=514,left='+(screen.availWidth/2-308)+',top='+(screen.availHeight/2-257)+''); return false;" href="https://reddit.com/submit?url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/&amp;title=AMD%20announces%20new,%20more%20powerful%20Ryzen%20processors" data-cf-modified-10f54106f69c6db055441066-="">
<span class="bdaia-io bdaia-io-reddit"></span>
<span>Share on Reddit</span>
</a>
</li>
<li class="pinterest">
<a title="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.criticalhit.net%2Ftechnology%2Famd-announces-new-more-powerful-ryzen-processors%2F&amp;description=AMD+announces+new%2C+more+powerful+Ryzen+processors&amp;media=https%3A%2F%2Fi2.wp.com%2Fmedia.criticalhit.net%2F%2F2021%2F01%2Famd-ryzen-5000.jpg%3Ffit%3D800%252C450%26ssl%3D1">
<span class="bdaia-io bdaia-io-social-pinterest"></span>
<span>Share on Pinterest</span>
</a>
</li>
<li class="linkedin">
<a title="linkedin" onClick="if (!window.__cfRLUnblockHandlers) return false; window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/" data-cf-modified-10f54106f69c6db055441066-="">
<span class="bdaia-io bdaia-io-linkedin2"></span>
<span>Share on Linkedin</span>
</a>
</li>
<li class="tumblr">
<a title="tumblr" onClick="if (!window.__cfRLUnblockHandlers) return false; window.open('http://www.tumblr.com/share/link?url=www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/&amp;name=AMD%20announces%20new,%20more%20powerful%20Ryzen%20processors','Tumblr','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.tumblr.com/share/link?url=www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/&amp;name=AMD%20announces%20new,%20more%20powerful%20Ryzen%20processors" data-cf-modified-10f54106f69c6db055441066-="">
<span class="bdaia-io bdaia-io-tumblr"></span>
<span>Share on Tumblr</span>
</a>
</li>
<li class="whatsapp">
<a href="whatsapp://send?text=AMD+has+delivered+on+its+promise+of+new+chip+based+on+its+Zen+3+architecture+that+promises+greater+performance+and+impressive+battery+life.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Ftechnology%2Famd-announces-new-more-powerful-ryzen-processors%2F"><span class="bdaia-io bdaia-io-whatsapp"></span></a> </li>
<li class="telegram">
<a href="tg://msg?text=AMD+has+delivered+on+its+promise+of+new+chip+based+on+its+Zen+3+architecture+that+promises+greater+performance+and+impressive+battery+life.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Ftechnology%2Famd-announces-new-more-powerful-ryzen-processors%2F"><span class="bdaia-io bdaia-io-telegram"></span></a> </li>
</ul>
</div>

<div class="bdaia-post-content">
<figure class="wp-block-image size-large is-style-default"><img data-attachment-id="1123675" data-permalink="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/attachment/amd-ryzen/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2021/01/AMD-Ryzen.jpg?fit=800%2C450&amp;ssl=1" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="AMD-Ryzen" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2021/01/AMD-Ryzen.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2021/01/AMD-Ryzen.jpg?fit=800%2C450&amp;ssl=1" loading="lazy" width="800" height="450" src="https://i0.wp.com/media.criticalhit.net//2021/01/AMD-Ryzen.jpg?resize=800%2C450&#038;ssl=1" alt="AMD announces new, more powerful Ryzen processors 4" class="wp-image-1123675" srcset="https://i0.wp.com/media.criticalhit.net//2021/01/AMD-Ryzen.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/media.criticalhit.net//2021/01/AMD-Ryzen.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/media.criticalhit.net//2021/01/AMD-Ryzen.jpg?resize=768%2C432&amp;ssl=1 768w" sizes="(max-width: 800px) 100vw, 800px" title="AMD announces new, more powerful Ryzen processors 4" data-recalc-dims="1"></figure>
<p>Intel may have just <a href="https://www.criticalhit.net/technology/intel-unveil-new-11th-and-12th-gen-processors/" class="rank-math-link">shown off</a> some of its plans for new powerful 10nm processors, but its competitor AMD has long since been doing a better job at making more compact processors. AMD has announced a new range of 7nm Ryzen 5000 mobile processors, that are based on the company’s previously announced<a href="https://www.criticalhit.net/technology/intel-announces-new-fastest-gaming-cpu-ryzen-5000-processors/" class="rank-math-link"> Zen 3 architecture</a>. I guess much like every other processor company, they&#8217;ll claim that it&#8217;ll be “the most powerful PC processor ever built.” Claims that both Apple and Intel have both made, so the proof will need to be in the pudding on this one.</p>
<p>As with the previous generation, the 5000 range will also be split into two categories: The H-series for laptops aimed at providing a little more juice and the U-series, aimed at the ultraportable market for improved battery life. Both series will come in the traditional Ryzen 3, Ryzen 5, Ryzen 7, and Ryzen 9 tiers respectively.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-large"><img data-attachment-id="1123676" data-permalink="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/attachment/amd-ryzen-5000/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?fit=800%2C450&amp;ssl=1" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="amd-ryzen-5000" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?fit=800%2C450&amp;ssl=1" loading="lazy" width="800" height="450" src="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?resize=800%2C450&#038;ssl=1" alt="AMD announces new, more powerful Ryzen processors 5" class="wp-image-1123676" srcset="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?w=800&amp;ssl=1 800w, https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?resize=768%2C432&amp;ssl=1 768w" sizes="(max-width: 800px) 100vw, 800px" title="AMD announces new, more powerful Ryzen processors 5" data-recalc-dims="1"></figure></div>
<p>Headlining the U-series is the eight-core, 16-thread Ryzen 7 5800U, with 1.9GHz clock speeds that can boost up to 4.4 GHz – a remarkable boosted speed though one that it wouldn’t likely be able to maintain for very long. Not only is this enough to provide any ultrathin notebook with some impressive power, but the company claims it can deliver up to 17.5 hours of general-usage battery life and 21 hours of movie playback, which is remarkable battery life for a processor as powerful as they claim it will be.</p>
<p>For the H-series, the range is headed up by the Ryzen 9 5980HS, which also features eight cores and 16 threads, but with 3.0Ghz clock speeds boosting up to 4.8GHz. The company claims that it beats the Intel processors in benchmark tests, but this doesn’t include Intel’s new range of processors and these tests are also largely dependent on the rest of the hardware components used, so I wouldn’t read too much into them just yet though AMD definitely had the better performance in last’ year’s chips and so I am inclined to believe them again.</p>
<div class="wp-block-image is-style-default"><figure class="aligncenter size-large"><img data-attachment-id="1123678" data-permalink="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/attachment/amd-zen-3/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/01/AMD-Zen-3.jpg?fit=800%2C450&amp;ssl=1" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="AMD-Zen-3" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/01/AMD-Zen-3.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/01/AMD-Zen-3.jpg?fit=800%2C450&amp;ssl=1" loading="lazy" width="800" height="450" src="https://i2.wp.com/media.criticalhit.net//2021/01/AMD-Zen-3.jpg?resize=800%2C450&#038;ssl=1" alt="AMD announces new, more powerful Ryzen processors 6" class="wp-image-1123678" srcset="https://i2.wp.com/media.criticalhit.net//2021/01/AMD-Zen-3.jpg?w=800&amp;ssl=1 800w, https://i2.wp.com/media.criticalhit.net//2021/01/AMD-Zen-3.jpg?resize=300%2C169&amp;ssl=1 300w, https://i2.wp.com/media.criticalhit.net//2021/01/AMD-Zen-3.jpg?resize=768%2C432&amp;ssl=1 768w" sizes="(max-width: 800px) 100vw, 800px" title="AMD announces new, more powerful Ryzen processors 6" data-recalc-dims="1"></figure></div>
<p>New to the H-series though are the HX chips which are aimed at the gaming market and increase the chip&#8217;s power to 45W, though these don’t have the same powerful integrated graphics as the Intel chips and you would be expected to have a graphics cards exclusively if you want to take gaming seriously.</p><div class="sbuhz5ffecf3e477bc"><div id='div-gpt-ad-1540806613519-0' style='width:728px;'>
<script type="10f54106f69c6db055441066-text/javascript">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540806613519-0'); });
</script>
</div>
<div id='div-gpt-ad-1540807120663-0' tyle='margin:auto; width:320px;'>
<script type="10f54106f69c6db055441066-text/javascript">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1540807120663-0'); });
</script>
</div>
</div><style type="text/css">
.sbuhz5ffecf3e477bc {
margin: 5px; padding: 0px;
}
@media screen and (min-width: 1201px) {
.sbuhz5ffecf3e477bc {
display: block;
}
}
@media screen and (min-width: 993px) and (max-width: 1200px) {
.sbuhz5ffecf3e477bc {
display: block;
}
}
@media screen and (min-width: 769px) and (max-width: 992px) {
.sbuhz5ffecf3e477bc {
display: block;
}
}
@media screen and (min-width: 768px) and (max-width: 768px) {
.sbuhz5ffecf3e477bc {
display: block;
}
}
@media screen and (max-width: 767px) {
.sbuhz5ffecf3e477bc {
display: block;
}
}
</style>
<p>A breakdown of different chip available are detailed below, sans pricing and release details which AMD has yet to announce:</p>
<h2>AMD RYZEN 5000</h2>
<figure class="wp-block-table"><table><thead><tr><td>Model</td><td>Cores / Threads</td><td>TDP (Watts)</td><td>Boost / Base Frequency (GHz)</td><td>Cache (MB)</td></tr></thead><tbody><tr><td></td><td></td><td></td><td></td><td></td></tr><tr><td>AMD Ryzen 9 5980HX</td><td>8C / 16T</td><td>45W+</td><td>Up to 4.8 / 3.3 GHz</td><td>20</td></tr><tr><td>AMD Ryzen 9 5980HS</td><td>8C / 16T</td><td>35W</td><td>Up to 4.8 / 3.0 GHz</td><td>20</td></tr><tr><td>AMD Ryzen 9 5900HX</td><td>8C / 16T</td><td>45W+</td><td>Up to 4.6 / 3.3 GHz</td><td>20</td></tr><tr><td>AMD Ryzen 9 5900HS</td><td>8C / 16T</td><td>35W</td><td>Up to 4.6 / 3.0 GHz</td><td>20</td></tr><tr><td>AMD Ryzen 7 5800H</td><td>8C / 16T</td><td>45W</td><td>Up to 4.4 / 3.2 GHz</td><td>20</td></tr><tr><td>AMD Ryzen 7 5800HS</td><td>8C / 16T</td><td>35W</td><td>Up to 4.4 / 2.8 GHz</td><td>20</td></tr><tr><td>AMD Ryzen 5 5600H</td><td>6C / 12T</td><td>45W</td><td>Up to 4.2 / 3.3 GHz</td><td>19</td></tr><tr><td>AMD Ryzen 5 5600HS</td><td>6C / 12T</td><td>35W</td><td>Up to 4.2 / 3.0 GHz</td><td>19</td></tr><tr><td>AMD Ryzen 7 5800U</td><td>8C / 16T</td><td>15W</td><td>Up to 4.4 / 1.9 GHz</td><td>20</td></tr><tr><td>AMD Ryzen 7 5700U</td><td>8C / 16T</td><td>15W</td><td>Up to 4.3 / 1.8 GHz</td><td>8</td></tr><tr><td>AMD Ryzen 5 5600U</td><td>6C / 12T</td><td>15W</td><td>Up to 4.2 / 2.3 GHz</td><td>19</td></tr><tr><td>AMD Ryzen 5 5500U</td><td>6C / 12T</td><td>15W</td><td>Up to 4.0 / 2.1 GHz</td><td>8</td></tr><tr><td>AMD Ryzen 3 5300U</td><td>4C / 8T</td><td>15W</td><td>Up to 3.8 / 2.6 GHz</td><td>6</td></tr></tbody></table></figure>
<p>While consoles clearly have their generations, with the PC chips improving every year, they will continue to always be well ahead in terms of performance provided you have the bank balance to afford these and the myriad of other new components that keep on coming out.</p>
<p>Last Updated: <span class="updated">January 13, 2021</span></p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-1123668" class="share-twitter sd-button share-icon" href="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-1123668" class="share-facebook sd-button share-icon" href="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon" href="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon" href="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon" href="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span>WhatsApp</span></a></li><li class="share-end"></li></ul></div></div></div>
</div>
<footer>
<div class="bdaia-post-sharing bdaia-post-sharing-bottom">
<ul>
<li class="facebook">
<a title="facebook" onClick="if (!window.__cfRLUnblockHandlers) return false; window.open('http://www.facebook.com/sharer.php?u=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/','Facebook','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.facebook.com/sharer.php?u=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/" data-cf-modified-10f54106f69c6db055441066-="">
<span class="bdaia-io bdaia-io-facebook"></span>
<span>Share on Facebook</span>
</a>
</li>
<li class="twitter">
<a title="twitter" onClick="if (!window.__cfRLUnblockHandlers) return false; window.open('http://twitter.com/share?url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/&amp;text=AMD%20announces%20new,%20more%20powerful%20Ryzen%20processors','Twitter share','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://twitter.com/share?url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/&amp;text=AMD%20announces%20new,%20more%20powerful%20Ryzen%20processors" data-cf-modified-10f54106f69c6db055441066-="">
<span class="bdaia-io bdaia-io-twitter"></span>
<span>Share on Twitter</span>
</a>
</li>
<li class="google">
<a title="google" onClick="if (!window.__cfRLUnblockHandlers) return false; window.open('https://plus.google.com/share?url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/','Google plus','width=585,height=666,left='+(screen.availWidth/2-292)+',top='+(screen.availHeight/2-333)+''); return false;" href="https://plus.google.com/share?url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/" data-cf-modified-10f54106f69c6db055441066-="">
<span class="bdaia-io bdaia-io-google-plus"></span>
<span>Share on Google+</span>
</a>
</li>
<li class="reddit">
<a title="reddit" onClick="if (!window.__cfRLUnblockHandlers) return false; window.open('http://reddit.com/submit?url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/&amp;title=AMD%20announces%20new,%20more%20powerful%20Ryzen%20processors','Reddit','width=617,height=514,left='+(screen.availWidth/2-308)+',top='+(screen.availHeight/2-257)+''); return false;" href="https://reddit.com/submit?url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/&amp;title=AMD%20announces%20new,%20more%20powerful%20Ryzen%20processors" data-cf-modified-10f54106f69c6db055441066-="">
<span class="bdaia-io bdaia-io-reddit"></span>
<span>Share on Reddit</span>
</a>
</li>
<li class="pinterest">
<a title="pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.criticalhit.net%2Ftechnology%2Famd-announces-new-more-powerful-ryzen-processors%2F&amp;description=AMD+announces+new%2C+more+powerful+Ryzen+processors&amp;media=https%3A%2F%2Fi2.wp.com%2Fmedia.criticalhit.net%2F%2F2021%2F01%2Famd-ryzen-5000.jpg%3Ffit%3D800%252C450%26ssl%3D1">
<span class="bdaia-io bdaia-io-social-pinterest"></span>
<span>Share on Pinterest</span>
</a>
</li>
<li class="linkedin">
<a title="linkedin" onClick="if (!window.__cfRLUnblockHandlers) return false; window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/','Linkedin','width=863,height=500,left='+(screen.availWidth/2-431)+',top='+(screen.availHeight/2-250)+''); return false;" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/" data-cf-modified-10f54106f69c6db055441066-="">
<span class="bdaia-io bdaia-io-linkedin2"></span>
<span>Share on Linkedin</span>
</a>
</li>
<li class="tumblr">
<a title="tumblr" onClick="if (!window.__cfRLUnblockHandlers) return false; window.open('http://www.tumblr.com/share/link?url=www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/&amp;name=AMD%20announces%20new,%20more%20powerful%20Ryzen%20processors','Tumblr','width=600,height=300,left='+(screen.availWidth/2-300)+',top='+(screen.availHeight/2-150)+''); return false;" href="https://www.tumblr.com/share/link?url=www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/&amp;name=AMD%20announces%20new,%20more%20powerful%20Ryzen%20processors" data-cf-modified-10f54106f69c6db055441066-="">
<span class="bdaia-io bdaia-io-tumblr"></span>
<span>Share on Tumblr</span>
</a>
</li>
<li class="whatsapp">
<a href="whatsapp://send?text=AMD+has+delivered+on+its+promise+of+new+chip+based+on+its+Zen+3+architecture+that+promises+greater+performance+and+impressive+battery+life.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Ftechnology%2Famd-announces-new-more-powerful-ryzen-processors%2F"><span class="bdaia-io bdaia-io-whatsapp"></span></a> </li>
<li class="telegram">
<a href="tg://msg?text=AMD+has+delivered+on+its+promise+of+new+chip+based+on+its+Zen+3+architecture+that+promises+greater+performance+and+impressive+battery+life.%20-%20https%3A%2F%2Fwww.criticalhit.net%2Ftechnology%2Famd-announces-new-more-powerful-ryzen-processors%2F"><span class="bdaia-io bdaia-io-telegram"></span></a> </li>
</ul>
</div>

<div id="taboola-below-article-thumbnails"></div>
<script type="10f54106f69c6db055441066-text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'alternating-thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>
<div class="bdaia-author-box">
<div class="authorBlock-avatar">
<a href="https://www.criticalhit.net/author/craigrisi/"><img src="https://secure.gravatar.com/avatar/a31e3cf46ff23ca15ce0606a22e673d5?s=150&#038;d=mm&#038;r=pg" width="150" height="150" alt="Avatar" class="avatar avatar-150 wp-user-avatar wp-user-avatar-150 photo avatar-default" /></a>
</div>
<div class="authorBlock-header">
<h3 class="authorBlock-header-title">
<a href="https://www.criticalhit.net/author/craigrisi/">Craig Risi </h3>
<p class="authorBlock-header-bio">
A man of many talents, but no sense how to use them. I could be out changing the world, but I'd rather be running, watching movies, playing games and writing here instead. </p>
<div class="authorBlock-meta bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-32">
<a class="bdaia-io-url-twitter" href="https://www.twitter.com/RisiCraig"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class="bdaia-io-url-facebook" href="https://www.facebook.com/craig.risi"><span class="bdaia-io bdaia-io-facebook"></span></a>
</div>
</div>
</div>
</div>
 </footer>
<span style=display:none itemprop=author itemscope itemtype="https://schema.org/Person">
<meta itemprop=name content="Craig Risi">
</span>
<meta itemprop=interactionCount content="UserComments:0">
<meta itemprop=datePublished content="2021-01-13T12:45:00+00:00">
<meta itemprop=dateModified content="2021-01-13T12:45:00+00:00">
<meta itemscope itemprop=mainEntityOfPage itemtype="https://schema.org/WebPage" itemid="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/">
<span style=display:none itemprop=publisher itemscope itemtype="https://schema.org/Organization">
<span style=display:none itemprop=logo itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-Main.png">
</span>
<meta itemprop=name content="Critical Hit">
</span>
<meta itemprop=headline content="AMD announces new, more powerful Ryzen processors">
<span style=display:none itemprop=image itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop=url content="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?fit=800%2C450&#038;ssl=1">
<meta itemprop=width content=1240>
<meta itemprop=height content=540>
</span>
</article>
<div id="disqus_thread"></div>
<section id="bdCheckAlso" class="bdCheckAlso-right">
<h4 class="block-title">
<span>Check Also</span>
<a href="#" id="check-also-close"><span class="bdaia-io bdaia-io-cross"></span></a>
</h4>
<div class="check-also-post">
<figure class="check-also-thumb" style="background-image:url(https://i1.wp.com/media.criticalhit.net//2020/10/AMD_Ryzen_5000_Series_DeLidded_6.jpg?resize=320%2C220&ssl=1);"></figure>
<h2 class="post-title"><a href="https://www.criticalhit.net/technology/intel-announces-new-fastest-gaming-cpu-ryzen-5000-processors/" rel="bookmark">AMD announces new &#8220;fastest gaming CPU&#8221; Ryzen 5000 processors</a></h2>
<p>AMD is taking the game to Intel by announcing a new series of next-generation CPU chips. &#8230;</p>
</div>
</section>
</div>
</div>
<div class="bd-sidebar theia_sticky">
<div class="cfix"></div>
<div class="theiaStickySidebar">
<div id="bdaia-widget-e3-2" class="widget bdaia-widget bdaia-widget-e3 e3-trans"><div class="widget-inner">
<div class="e3-inner"><script src='https://www.googletagservices.com/tag/js/gpt.js' type="10f54106f69c6db055441066-text/javascript">
  googletag.pubads().definePassback('/55341649/300x250ATF', [300, 250]).display();
</script></div></div>
</div><div id="bdaia-social-links-3" class="widget bdaia-widget bdaia-social-links">
<h4 class="block-title"><span>Social</span></h4>
<div class="widget-inner">
<div class="widget-social-links bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class="none bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class="none bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class="none bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class="none bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class="none bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</div><div id="bdaia-widget-box6-2" class="widget bdaia-widget bdaia-box6"><h4 class="block-title"><span>Latest Reviews</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb6 bdaia-wb-idIojbA bdaia-ajax-pagination-next_prev" data-box_nu="wb6" data-box_id="bdaia-wb-idIojbA" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="5" data-tag_slug="" data-cat_uid="58" data-cat_uids="" data-max_nu="682" data-total_posts_num="3408" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="true" data-date_meta="true" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-bigsh bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/the-hong-kong-massacre-switch-review-horde-boiled/" class="bdaia-text-gradient">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="The Hong Kong Massacre Switch Review &ndash; Horde boiled 7" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2021/01/Hong-Kong-Massacre-6.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1121821" data-permalink="https://www.criticalhit.net/gaming/the-hong-kong-massacre-switch-review-horde-boiled/attachment/hong-kong-massacre-6-jpg/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2021/01/Hong-Kong-Massacre-6.jpg?fit=850%2C477&amp;ssl=1" data-orig-size="850,477" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Hong-Kong-Massacre-6.jpg" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2021/01/Hong-Kong-Massacre-6.jpg?fit=300%2C168&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2021/01/Hong-Kong-Massacre-6.jpg?fit=850%2C477&amp;ssl=1" title="The Hong Kong Massacre Switch Review &ndash; Horde boiled 7"> </a>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/the-hong-kong-massacre-switch-review-horde-boiled/"><span>The Hong Kong Massacre Switch Review &ndash; Horde boiled</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">7 days ago</span></div>
</footer>
</div>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/review/wonder-woman-1984-review/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Wonder Woman 1984 review - The superhero movie to save us from 2020 8" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2020/12/wonder-woman-1984-1280.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1120490" data-permalink="https://www.criticalhit.net/review/wonder-woman-1984-review/attachment/wonder-woman-1984-1280/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/12/wonder-woman-1984-1280.jpg?fit=1280%2C871&amp;ssl=1" data-orig-size="1280,871" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="wonder-woman-1984-1280" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/12/wonder-woman-1984-1280.jpg?fit=300%2C204&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/12/wonder-woman-1984-1280.jpg?fit=850%2C579&amp;ssl=1" title="Wonder Woman 1984 review - The superhero movie to save us from 2020 8"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/review/wonder-woman-1984-review/"><span>Wonder Woman 1984 review &#8211; The superhero movie to save us from 2020</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/reaver/" title="Posts by Kervyn Cloete" rel="author">Kervyn Cloete</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">4 weeks ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/review/taotronic-soundsurge-90-review-budget-price-surprisingly-nice/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Taotronic SoundSurge 90 Review &ndash; Budget price, surprisingly nice 9" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2020/12/IMG_20201218_104427.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1120422" data-permalink="https://www.criticalhit.net/review/taotronic-soundsurge-90-review-budget-price-surprisingly-nice/attachment/img_20201218_104427-jpg/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/12/IMG_20201218_104427.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="IMG_20201218_104427.jpg" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/12/IMG_20201218_104427.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/12/IMG_20201218_104427.jpg?fit=850%2C478&amp;ssl=1" title="Taotronic SoundSurge 90 Review &ndash; Budget price, surprisingly nice 9"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/review/taotronic-soundsurge-90-review-budget-price-surprisingly-nice/"><span>Taotronic SoundSurge 90 Review &ndash; Budget price, surprisingly nice</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">4 weeks ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/review/lego-star-wars-at-at-walker-review/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Lego Star Wars AT-AT Walker review - Hoth damn! 10" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2020/12/IMG_4679.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1119749" data-permalink="https://www.criticalhit.net/review/lego-star-wars-at-at-walker-review/attachment/img_4679/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/12/IMG_4679.jpg?fit=850%2C638&amp;ssl=1" data-orig-size="850,638" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2&quot;,&quot;credit&quot;:&quot;8&quot;,&quot;camera&quot;:&quot;Canon PowerShot G9 X&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1608065513&quot;,&quot;copyright&quot;:&quot;\u00f1&quot;,&quot;focal_length&quot;:&quot;10.2&quot;,&quot;iso&quot;:&quot;800&quot;,&quot;shutter_speed&quot;:&quot;0.05&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="IMG_4679" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/12/IMG_4679.jpg?fit=300%2C225&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/12/IMG_4679.jpg?fit=850%2C638&amp;ssl=1" title="Lego Star Wars AT-AT Walker review - Hoth damn! 10"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/review/lego-star-wars-at-at-walker-review/"><span>Lego Star Wars AT-AT Walker review &#8211; Hoth damn!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/reaver/" title="Posts by Kervyn Cloete" rel="author">Kervyn Cloete</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">4 weeks ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/review/mank-review-a-meticulous-love-letter-to-1940s-filmmaking/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Mank Review – A meticulous love letter to 1940s filmmaking 11" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2020/12/Mank_1280xl_feat.jpeg?resize=104%2C74&amp;ssl=1" data-attachment-id="1119954" data-permalink="https://www.criticalhit.net/review/mank-review-a-meticulous-love-letter-to-1940s-filmmaking/attachment/mank_1280xl_feat/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/12/Mank_1280xl_feat.jpeg?fit=1280%2C862&amp;ssl=1" data-orig-size="1280,862" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Mank_1280xl_feat" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/12/Mank_1280xl_feat.jpeg?fit=300%2C202&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/12/Mank_1280xl_feat.jpeg?fit=850%2C573&amp;ssl=1" title="Mank Review – A meticulous love letter to 1940s filmmaking 11"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/review/mank-review-a-meticulous-love-letter-to-1940s-filmmaking/"><span>Mank Review – A meticulous love letter to 1940s filmmaking</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/craigrisi/" title="Posts by Craig Risi" rel="author">Craig Risi</a>  </div>
<div class="bdaia-post-date"><span class="bdayh-date">4 weeks ago</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="10f54106f69c6db055441066-text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-idIojbA .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'IojbA', 'next' );
						});
						jQuery('.bdaia-wb-idIojbA .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'IojbA', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-e3-11" class="widget bdaia-widget bdaia-widget-e3 "><h4 class="block-title"><span>Advert</span></h4>
<div class="widget-inner">
<div class="e3-inner"><script src='https://www.googletagservices.com/tag/js/gpt.js' type="10f54106f69c6db055441066-text/javascript">
  googletag.pubads().definePassback('/55341649/300600mid', [300, 600]).display();
</script></div></div>
</div><div id="bdaia-widget-html-4" class="widget bdaia-widget bdaia-widget-html "><h4 class="block-title"><span>Recent Comments</span></h4>
<div class="widget-inner">
<div id="recentcomments" class="dsq-widget"><script type="10f54106f69c6db055441066-text/javascript" src="https://critical-hit-net.disqus.com/recent_comments_widget.js?num_items=5&hide_avatars=1&avatar_size=0&excerpt_length=200"></script></div><a href="https://disqus.com/">Powered by Disqus</a></div>
</div><div id="bdaia-widget-box2-4" class="widget bdaia-widget bdaia-box2"><h4 class="block-title"><span>Latest Posts </span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb2 bdaia-wb-idhJAzp bdaia-ajax-pagination-next_prev" data-box_nu="wb2" data-box_id="bdaia-wb-idhJAzp" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="5" data-tag_slug="" data-cat_uid="" data-cat_uids="" data-max_nu="12816" data-total_posts_num="64077" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-big bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="AMD announces new, more powerful Ryzen processors 12" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1123676" data-permalink="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/attachment/amd-ryzen-5000/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?fit=800%2C450&amp;ssl=1" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="amd-ryzen-5000" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?fit=800%2C450&amp;ssl=1" title="AMD announces new, more powerful Ryzen processors 12"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/"><span>AMD announces new, more powerful Ryzen processors</span></a></h3>
</header>
<footer>
</footer>
<p class="block-exb">AMD has delivered on its promise of new chip based on its Zen 3 architecture that promises greater performance and impressive battery life.</p>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/nintendo-is-throwing-copyright-claims-at-game-watch-hacking-videos/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Nintendo is throwing copyright claims at Game &amp; Watch hacking videos 13" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/01/No-Souper-Mario-Bros.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1123687" data-permalink="https://www.criticalhit.net/gaming/nintendo-is-throwing-copyright-claims-at-game-watch-hacking-videos/attachment/no-souper-mario-bros-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/01/No-Souper-Mario-Bros.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="No-Souper-Mario-Bros.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/01/No-Souper-Mario-Bros.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/01/No-Souper-Mario-Bros.jpg?fit=850%2C478&amp;ssl=1" title="Nintendo is throwing copyright claims at Game &amp; Watch hacking videos 13"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/nintendo-is-throwing-copyright-claims-at-game-watch-hacking-videos/"><span>Nintendo is throwing copyright claims at Game &amp; Watch hacking videos</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/razers-project-brooklyn-looks-so-dumb-its-awesome/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Razer&rsquo;s Project Brooklyn looks expensively awesome 14" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/01/razer-project-brooklyn-OGimage.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1123512" data-permalink="https://www.criticalhit.net/gaming/razers-project-brooklyn-looks-so-dumb-its-awesome/attachment/razer-project-brooklyn-ogimage-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/01/razer-project-brooklyn-OGimage.jpg?fit=918%2C482&amp;ssl=1" data-orig-size="918,482" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="razer-project-brooklyn-OGimage.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/01/razer-project-brooklyn-OGimage.jpg?fit=300%2C158&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/01/razer-project-brooklyn-OGimage.jpg?fit=850%2C446&amp;ssl=1" title="Razer&rsquo;s Project Brooklyn looks expensively awesome 14"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/razers-project-brooklyn-looks-so-dumb-its-awesome/"><span>Razer&rsquo;s Project Brooklyn looks expensively awesome</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/nvidia-reveals-new-entry-level-geforce-rtx-3060-card/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Nvidia reveals new entry-level GeForce RTX 3060 card 15" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/01/RTX-3060.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1123595" data-permalink="https://www.criticalhit.net/gaming/nvidia-reveals-new-entry-level-geforce-rtx-3060-card/attachment/rtx-3060-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/01/RTX-3060.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RTX-3060.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/01/RTX-3060.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/01/RTX-3060.jpg?fit=850%2C478&amp;ssl=1" title="Nvidia reveals new entry-level GeForce RTX 3060 card 15"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/nvidia-reveals-new-entry-level-geforce-rtx-3060-card/"><span>Nvidia reveals new entry-level GeForce RTX 3060 card</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/watch-netflix-tease-70-new-movies-for-2021-including-first-footage-for-dont-look-up-red-notice-army-of-the-dead-and-more/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Watch: Netflix tease 70 new movies for 2021, including first footage for Don&#039;t Look Up, Red Notice, Army of the Dead, and more 16" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2021/01/netflix-2021-movies-dont-look-up1.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1123569" data-permalink="https://www.criticalhit.net/entertainment/watch-netflix-tease-70-new-movies-for-2021-including-first-footage-for-dont-look-up-red-notice-army-of-the-dead-and-more/attachment/netflix-2021-movies-dont-look-up1/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2021/01/netflix-2021-movies-dont-look-up1.jpg?fit=850%2C567&amp;ssl=1" data-orig-size="850,567" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="netflix-2021-movies-dont-look-up1" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2021/01/netflix-2021-movies-dont-look-up1.jpg?fit=300%2C200&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2021/01/netflix-2021-movies-dont-look-up1.jpg?fit=850%2C567&amp;ssl=1" title="Watch: Netflix tease 70 new movies for 2021, including first footage for Don&#039;t Look Up, Red Notice, Army of the Dead, and more 16"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/watch-netflix-tease-70-new-movies-for-2021-including-first-footage-for-dont-look-up-red-notice-army-of-the-dead-and-more/"><span>Watch: Netflix tease 70 new movies for 2021, including first footage for Don&#8217;t Look Up, Red Notice, Army of the Dead, and more</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="10f54106f69c6db055441066-text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-idhJAzp .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'hJAzp', 'next' );
						});
						jQuery('.bdaia-wb-idhJAzp .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'hJAzp', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-box2-2" class="widget bdaia-widget bdaia-box2"><h4 class="block-title"><span>Competitions </span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb2 bdaia-wb-idaapUY bdaia-ajax-pagination-" data-box_nu="wb2" data-box_id="bdaia-wb-idaapUY" data-paged="1" data-sort_order="" data-ajax_pagination="" data-num_posts="4" data-tag_slug="" data-cat_uid="34345" data-cat_uids="" data-max_nu="60" data-total_posts_num="240" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="true" data-review="">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-big bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/competitions/and-the-winner-of-our-lego-star-wars-set-is/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="And the winner of our Lego Star Wars set is... 17" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2020/12/LegoStarWars_ATAT_Build_Rev_1280xl-1.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1119793" data-permalink="https://www.criticalhit.net/review/lego-star-wars-at-at-walker-review/attachment/legostarwars_atat_build_rev_1280xl-2/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2020/12/LegoStarWars_ATAT_Build_Rev_1280xl-1.jpg?fit=1200%2C788&amp;ssl=1" data-orig-size="1200,788" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="LegoStarWars_ATAT_Build_Rev_1280xl" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2020/12/LegoStarWars_ATAT_Build_Rev_1280xl-1.jpg?fit=300%2C197&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2020/12/LegoStarWars_ATAT_Build_Rev_1280xl-1.jpg?fit=850%2C558&amp;ssl=1" title="And the winner of our Lego Star Wars set is... 17"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/competitions/and-the-winner-of-our-lego-star-wars-set-is/"><span>And the winner of our Lego Star Wars set is&#8230;</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">4 weeks ago</span></div>
</footer>
<p class="block-exb">One lucky person is about to have an amazing Christmas thanks to this incredible Lego Star Wars set worth R3000!</p>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/competitions/win-a-lego-star-wars-kit-worth-r3000/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Win a Lego Star Wars kit worth R3000 18" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2020/12/lego-star-wars-at-at-0x.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1118803" data-permalink="https://www.criticalhit.net/competitions/win-a-lego-star-wars-kit-worth-r3000/attachment/created-by-mdkgraphicsengine-licensed-to-lego-production/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2020/12/lego-star-wars-at-at-0x.jpg?fit=850%2C650&amp;ssl=1" data-orig-size="850,650" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Created by MDKGraphicsEngine - Licensed to LEGO Production&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;Created by MDKGraphicsEngine - Licensed to LEGO Production&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="LegoStarWarsATAT" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2020/12/lego-star-wars-at-at-0x.jpg?fit=300%2C229&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2020/12/lego-star-wars-at-at-0x.jpg?fit=850%2C650&amp;ssl=1" title="Win a Lego Star Wars kit worth R3000 18"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/competitions/win-a-lego-star-wars-kit-worth-r3000/"><span>Win a Lego Star Wars kit worth R3000</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">4 weeks ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/win-a-copy-of-devil-may-cry-5-special-edition/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Win a copy of Devil May Cry 5: Special Edition! 19" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2019/12/Devil-May-Cry-V.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1032800" data-permalink="https://www.criticalhit.net/gaming/the-critical-hit-best-of-the-year-awards-2019-game-of-the-year/attachment/devil-may-cry-v-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2019/12/Devil-May-Cry-V.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Devil-May-Cry-V.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2019/12/Devil-May-Cry-V.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2019/12/Devil-May-Cry-V.jpg?fit=850%2C478&amp;ssl=1" title="Win a copy of Devil May Cry 5: Special Edition! 19"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/win-a-copy-of-devil-may-cry-5-special-edition/"><span>Win a copy of Devil May Cry 5: Special Edition!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">December 3, 2020</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/competitions/win-one-of-five-cadbury-tastetheaction-football-hampers/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Win one of five Cadbury #TasteTheAction football hampers! 20" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2020/10/Cadbury-1.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1105975" data-permalink="https://www.criticalhit.net/competitions/win-one-of-five-cadbury-tastetheaction-football-hampers/attachment/cadbury-1-jpg/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2020/10/Cadbury-1.jpg?fit=850%2C638&amp;ssl=1" data-orig-size="850,638" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Cadbury-1.jpg" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2020/10/Cadbury-1.jpg?fit=300%2C225&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2020/10/Cadbury-1.jpg?fit=850%2C638&amp;ssl=1" title="Win one of five Cadbury #TasteTheAction football hampers! 20"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/competitions/win-one-of-five-cadbury-tastetheaction-football-hampers/"><span>Win one of five Cadbury #TasteTheAction football hampers!</span></a></h3>
</header>
<footer>
<div class="bdaia-post-date"><span class="bdayh-date">October 20, 2020</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
</div>
<style type="text/css">#bdaia-widget-box2-2 .entry-title a:hover{color:#e90d8c !important;}#bdaia-widget-box2-2 .sk-circle .sk-child:before{background:#e90d8c !important;}#bdaia-widget-box2-2 .bdaia-wb-mb-inner{background:#e90d8c !important;}#bdaia-widget-box2-2 h4.block-title:before{background:#e90d8c !important;}#bdaia-widget-box2-2 h4.block-title span, #bdaia-widget-box2-2 h4.block-title a{color:#e90d8c !important;}</style></div></div><div id="bdaia-widget-box3-2" class="widget bdaia-widget bdaia-box3"><h4 class="block-title"><span>Features</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb3 bdaia-wb-ido8jww bdaia-ajax-pagination-next_prev" data-box_nu="wb3" data-box_id="bdaia-wb-ido8jww" data-paged="1" data-sort_order="" data-ajax_pagination="next_prev" data-num_posts="4" data-tag_slug="" data-cat_uid="48449" data-cat_uids="" data-max_nu="311" data-total_posts_num="1243" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="" data-date_meta="" data-review="">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-box-row">
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/entertainment/a-knights-tale-20-years-later-how-pasta-and-real-jousting-created-a-medieval-rock-n-roll-classic/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="A Knight&rsquo;s Tale 20 years later&ndash;How pasta and real jousting created a medieval rock &lsquo;n roll classic 21" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/01/Knights-Tale-6-1.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1122174" data-permalink="https://www.criticalhit.net/entertainment/a-knights-tale-20-years-later-how-pasta-and-real-jousting-created-a-medieval-rock-n-roll-classic/attachment/knights-tale-6-jpg-2/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/01/Knights-Tale-6-1.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Knights-Tale-6.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/01/Knights-Tale-6-1.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/01/Knights-Tale-6-1.jpg?fit=850%2C478&amp;ssl=1" title="A Knight&rsquo;s Tale 20 years later&ndash;How pasta and real jousting created a medieval rock &lsquo;n roll classic 21"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/entertainment/a-knights-tale-20-years-later-how-pasta-and-real-jousting-created-a-medieval-rock-n-roll-classic/"><span>A Knight&rsquo;s Tale 20 years later&ndash;How pasta and real jousting created a medieval rock &lsquo;n roll classic</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/the-hong-kong-massacre-switch-review-horde-boiled/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="The Hong Kong Massacre Switch Review &ndash; Horde boiled 22" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2021/01/Hong-Kong-Massacre-6.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1121821" data-permalink="https://www.criticalhit.net/gaming/the-hong-kong-massacre-switch-review-horde-boiled/attachment/hong-kong-massacre-6-jpg/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2021/01/Hong-Kong-Massacre-6.jpg?fit=850%2C477&amp;ssl=1" data-orig-size="850,477" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Hong-Kong-Massacre-6.jpg" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2021/01/Hong-Kong-Massacre-6.jpg?fit=300%2C168&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2021/01/Hong-Kong-Massacre-6.jpg?fit=850%2C477&amp;ssl=1" title="The Hong Kong Massacre Switch Review &ndash; Horde boiled 22"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/the-hong-kong-massacre-switch-review-horde-boiled/"><span>The Hong Kong Massacre Switch Review &ndash; Horde boiled</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
<div class="bdaia-box-row">
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/20-games-big-games-that-we-cant-wait-to-play-in-2021/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="20 big games that we can&rsquo;t wait to play in 2021 23" loading="lazy" data-src="https://i0.wp.com/media.criticalhit.net//2021/01/2020-games.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1121555" data-permalink="https://www.criticalhit.net/gaming/20-games-big-games-that-we-cant-wait-to-play-in-2021/attachment/2020-games-jpg-2/" data-orig-file="https://i0.wp.com/media.criticalhit.net//2021/01/2020-games.jpg?fit=849%2C478&amp;ssl=1" data-orig-size="849,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="2020-games.jpg" data-image-description data-medium-file="https://i0.wp.com/media.criticalhit.net//2021/01/2020-games.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/media.criticalhit.net//2021/01/2020-games.jpg?fit=849%2C478&amp;ssl=1" title="20 big games that we can&rsquo;t wait to play in 2021 23"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/20-games-big-games-that-we-cant-wait-to-play-in-2021/"><span>20 big games that we can&rsquo;t wait to play in 2021</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-bigs bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/comics-toys/the-100-best-comic-book-covers-of-2020/">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="The 100 best comic book covers of 2020 24" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2021/01/Best-covers-2020.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1121241" data-permalink="https://www.criticalhit.net/comics-toys/the-100-best-comic-book-covers-of-2020/attachment/best-covers-2020/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2021/01/Best-covers-2020.jpg?fit=850%2C479&amp;ssl=1" data-orig-size="850,479" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Best-covers-2020" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2021/01/Best-covers-2020.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2021/01/Best-covers-2020.jpg?fit=850%2C479&amp;ssl=1" title="The 100 best comic book covers of 2020 24"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/comics-toys/the-100-best-comic-book-covers-of-2020/"><span>The 100 best comic book covers of 2020</span></a></h3>
</header>
<footer>
</footer>
</div>
</article>
</div>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="10f54106f69c6db055441066-text/javascript">
					jQuery(document).ready(function() {
																		jQuery('.bdaia-wb-ido8jww .carousel-nav .mo-next').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'o8jww', 'next' );
						});
						jQuery('.bdaia-wb-ido8jww .carousel-nav .mo-prev').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'o8jww', 'prev' );
						});
											});
				</script>
<div class="carousel-nav">
<a href="#" class="mo-prev ajax-page-disabled"><span class="bdaia-io bdaia-io-angle-left"></span></a>
<a href="#" class="mo-next"><span class="bdaia-io bdaia-io-angle-right"></span></a>
</div>
</div>
</div></div><div id="bdaia-widget-e3-13" class="widget bdaia-widget bdaia-widget-e3 "><div class="widget-inner">
<div class="e3-inner"><script src='https://www.googletagservices.com/tag/js/gpt.js' type="10f54106f69c6db055441066-text/javascript">
  googletag.pubads().definePassback('/55341649/CH300BTF', [300, 250]).display();
</script></div></div>
</div><div id="bdaia-widget-box6-6" class="widget bdaia-widget bdaia-box6"><h4 class="block-title"><span>Most Recent</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb6 bdaia-wb-idPQvjy bdaia-ajax-pagination-load_more" data-box_nu="wb6" data-box_id="bdaia-wb-idPQvjy" data-paged="1" data-sort_order="" data-ajax_pagination="load_more" data-num_posts="3" data-tag_slug="" data-cat_uid="" data-cat_uids="" data-max_nu="21359" data-total_posts_num="64077" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="true" data-date_meta="true" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-bigsh bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/" class="bdaia-text-gradient">
<img width="320" height="220" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty.png" class="attachment-bdaia-widget size-bdaia-widget img-lazy wp-post-image" alt="AMD announces new, more powerful Ryzen processors 25" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?resize=320%2C220&amp;ssl=1" data-attachment-id="1123676" data-permalink="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/attachment/amd-ryzen-5000/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?fit=800%2C450&amp;ssl=1" data-orig-size="800,450" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="amd-ryzen-5000" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/01/amd-ryzen-5000.jpg?fit=800%2C450&amp;ssl=1" title="AMD announces new, more powerful Ryzen processors 25"> </a>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/"><span>AMD announces new, more powerful Ryzen processors</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/craigrisi/" title="Posts by Craig Risi" rel="author">Craig Risi</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">18 seconds ago</span></div>
</footer>
</div>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/nintendo-is-throwing-copyright-claims-at-game-watch-hacking-videos/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Nintendo is throwing copyright claims at Game &amp; Watch hacking videos 26" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/01/No-Souper-Mario-Bros.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1123687" data-permalink="https://www.criticalhit.net/gaming/nintendo-is-throwing-copyright-claims-at-game-watch-hacking-videos/attachment/no-souper-mario-bros-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/01/No-Souper-Mario-Bros.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="No-Souper-Mario-Bros.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/01/No-Souper-Mario-Bros.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/01/No-Souper-Mario-Bros.jpg?fit=850%2C478&amp;ssl=1" title="Nintendo is throwing copyright claims at Game &amp; Watch hacking videos 26"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/nintendo-is-throwing-copyright-claims-at-game-watch-hacking-videos/"><span>Nintendo is throwing copyright claims at Game &amp; Watch hacking videos</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">45 mins ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/razers-project-brooklyn-looks-so-dumb-its-awesome/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Razer&rsquo;s Project Brooklyn looks expensively awesome 27" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/01/razer-project-brooklyn-OGimage.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1123512" data-permalink="https://www.criticalhit.net/gaming/razers-project-brooklyn-looks-so-dumb-its-awesome/attachment/razer-project-brooklyn-ogimage-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/01/razer-project-brooklyn-OGimage.jpg?fit=918%2C482&amp;ssl=1" data-orig-size="918,482" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="razer-project-brooklyn-OGimage.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/01/razer-project-brooklyn-OGimage.jpg?fit=300%2C158&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/01/razer-project-brooklyn-OGimage.jpg?fit=850%2C446&amp;ssl=1" title="Razer&rsquo;s Project Brooklyn looks expensively awesome 27"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/razers-project-brooklyn-looks-so-dumb-its-awesome/"><span>Razer&rsquo;s Project Brooklyn looks expensively awesome</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/blang/" title="Posts by Brad Lang" rel="author">Brad Lang</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">1 hour ago</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
<div class="cfix"></div>
<script type="10f54106f69c6db055441066-text/javascript">
					jQuery(document).ready(function() {
																		jQuery('#bdaia-more-PQvjy .bdaia-wb-mb-inner').click(function(event){ event.preventDefault();
							woohoo_wb_ajax_js( 'PQvjy', '' );
						});
																	});
				</script>
<div class="bdaia-wb-more-btn" id="bdaia-more-PQvjy">
<div class="bdaia-wb-mb-inner">
Load more<span class="bdaia-io bdaia-io-angle-down"></span>
</div>
</div>
</div>
<style type="text/css">#bdaia-widget-box6-6 .entry-title a:hover{color:#E6A602 !important;}#bdaia-widget-box6-6 .sk-circle .sk-child:before{background:#E6A602 !important;}#bdaia-widget-box6-6 .bdaia-wb-mb-inner{background:#E6A602 !important;}#bdaia-widget-box6-6 h4.block-title:before{background:#E6A602 !important;}#bdaia-widget-box6-6 h4.block-title span, #bdaia-widget-box6-6 h4.block-title a{color:#E6A602 !important;}</style></div></div> </div>
</div>
</div>
</div>
<div class="bdaia-footer-e3-desktop"><div class="bdaia-e3-container"><script src='https://www.googletagservices.com/tag/js/gpt.js' type="10f54106f69c6db055441066-text/javascript">
  googletag.pubads().definePassback('/55341649/728bottom', [728, 90]).display();
</script>
</div></div>
<div class="bdaia-footer">
<div class="bdaia-footer-widgets">
<div class="bd-container">
<div class="bdaia-footer-widgets-area footer-col-three">
<div id="footer-first" class="footer-widget-inner">
<div id="bdaia-widget-html-2" class="widget bdaia-widget bdaia-widget-html e3-trans"><h4 class="block-title"><span>About US</span></h4>
<div class="widget-inner">
<p>
<img src="https://media.criticalhit.net/2017/01/Critical_Hit-Logo-White-1.png" alt="" />
</p>
<p style="margin-top:25px;">
Critical Hit is built on the idea that we are more than one thing. Are you a hardcore gamer who also enjoys a night out at the movies? Perhaps you’re a professional cosplayer who is searching for the perfect burger, or maybe you’re just interested in high-end tech and Netflix binging. Covering gaming, entertainment, tech and geek, Critical Hit offers information and critique from a staff of diverse, knowledgeable and fiercely opinionated writers. </p>
</div>
</div><div id="bdaia-social-links-6" class="widget bdaia-widget bdaia-social-links">
<h4 class="block-title"><span>Follow Us</span></h4>
<div class="widget-inner">
<div class="widget-social-links bdaia-social-io-colored">
<div class="bdaia-social-io bdaia-social-io-size-35">
<a class="none bdaia-io-url-facebook" title="Facebook" href="https://www.facebook.com/criticalhit.net" target="_blank"><span class="bdaia-io bdaia-io-facebook"></span></a>
<a class="none bdaia-io-url-twitter" title="Twitter" href="https://twitter.com/criticalhitnet" target="_blank"><span class="bdaia-io bdaia-io-twitter"></span></a>
<a class="none bdaia-io-url-google-plus" title="Google+" href="https://plus.google.com/u/0/115124556395184587688" target="_blank"><span class="bdaia-io bdaia-io-google-plus"></span></a>
<a class="none bdaia-io-url-youtube" title="Youtube" href="https://www.youtube.com/c/CriticalhitNet" target="_blank"><span class="bdaia-io bdaia-io-youtube"></span></a>
<a class="none bdaia-io-url-rss" title="Rss" href="/feed" target="_blank"><span class="bdaia-io bdaia-io-rss"></span></a>
</div> </div>
</div>
</div> </div>
<div id="footer-second" class="footer-widget-inner">
<div id="bdaia-widget-box1-2" class="widget bdaia-widget bdaia-box1"><h4 class="block-title"><span>Read This</span></h4><div class="widget-inner">
<div class="bdaia-wb-wrap bdaia-wb1 bdaia-wb-idYuwOq bdaia-ajax-pagination-" data-box_nu="wb1" data-box_id="bdaia-wb-idYuwOq" data-paged="1" data-sort_order="random_7_day" data-ajax_pagination="" data-num_posts="4" data-tag_slug="" data-cat_uid="" data-cat_uids="" data-max_nu="16" data-total_posts_num="61" data-posts="" data-com_meta="" data-thumbnail="" data-author_meta="true" data-date_meta="true" data-review="true">
<div class="bdaia-wb-content">
<div class="bdaia-wb-inner">
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/technology/asus-new-rog-strix-scar-and-zephyrus-duo-laptops-are-all-about-fast-screens-and-quicker-gaming-results/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Asus&#039; new ROG Strix, SCAR, and Zephyrus Duo laptops are all about fast screens and quicker gaming results 28" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2021/01/Asus-Strix.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1123417" data-permalink="https://www.criticalhit.net/technology/asus-new-rog-strix-scar-and-zephyrus-duo-laptops-are-all-about-fast-screens-and-quicker-gaming-results/attachment/asus-strix/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2021/01/Asus-Strix.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Asus-Strix" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2021/01/Asus-Strix.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2021/01/Asus-Strix.jpg?fit=850%2C478&amp;ssl=1" title="Asus&#039; new ROG Strix, SCAR, and Zephyrus Duo laptops are all about fast screens and quicker gaming results 28"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/technology/asus-new-rog-strix-scar-and-zephyrus-duo-laptops-are-all-about-fast-screens-and-quicker-gaming-results/"><span>Asus&#8217; new ROG Strix, SCAR, and Zephyrus Duo laptops are all about fast screens and quicker gaming results</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">16 hours ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/aews-video-game-will-blend-arcade-speed-with-simulation-mechanics-according-to-kenny-omega/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="AEW&rsquo;s video game will blend arcade speed with simulation mechanics according to Kenny Omega 29" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/01/AEW-Game-2.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1122366" data-permalink="https://www.criticalhit.net/gaming/aews-video-game-will-blend-arcade-speed-with-simulation-mechanics-according-to-kenny-omega/attachment/aew-game-2-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/01/AEW-Game-2.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="AEW-Game-2.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/01/AEW-Game-2.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/01/AEW-Game-2.jpg?fit=850%2C478&amp;ssl=1" title="AEW&rsquo;s video game will blend arcade speed with simulation mechanics according to Kenny Omega 29"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/aews-video-game-will-blend-arcade-speed-with-simulation-mechanics-according-to-kenny-omega/"><span>AEW&rsquo;s video game will blend arcade speed with simulation mechanics according to Kenny Omega</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">5 days ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/looks-like-ghostwire-tokyo-is-out-this-october/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="GhostWire: Tokyo is out this October 30" loading="lazy" data-src="https://i2.wp.com/media.criticalhit.net//2021/01/ghostwire-tokyo-1.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1123132" data-permalink="https://www.criticalhit.net/gaming/looks-like-ghostwire-tokyo-is-out-this-october/attachment/ghostwire-tokyo-1-jpg/" data-orig-file="https://i2.wp.com/media.criticalhit.net//2021/01/ghostwire-tokyo-1.jpg?fit=918%2C516&amp;ssl=1" data-orig-size="918,516" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ghostwire-tokyo-1.jpg" data-image-description data-medium-file="https://i2.wp.com/media.criticalhit.net//2021/01/ghostwire-tokyo-1.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i2.wp.com/media.criticalhit.net//2021/01/ghostwire-tokyo-1.jpg?fit=850%2C478&amp;ssl=1" title="GhostWire: Tokyo is out this October 30"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/looks-like-ghostwire-tokyo-is-out-this-october/"><span>GhostWire: Tokyo is out this October</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/blang/" title="Posts by Brad Lang" rel="author">Brad Lang</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">1 day ago</span></div>
</footer>
</div>
</article>
</div>
<div class="bdaia-wb-article bdaia-wba-small bdaiaFadeIn">
<article class="with-thumb">
<div class="bwb-article-img-container">
<a href="https://www.criticalhit.net/gaming/friday-debate-what-does-your-dream-mandalorian-video-game-look-like/">
<img width="104" height="74" src="https://www.criticalhit.net/wp-content/themes/woohoo/images/img-empty-small.png" class="attachment-bdaia-small size-bdaia-small img-lazy wp-post-image" alt="Friday Debate: What does your dream Mandalorian video game look like? 31" loading="lazy" data-src="https://i1.wp.com/media.criticalhit.net//2021/01/Mando-debate-2.jpg?resize=104%2C74&amp;ssl=1" data-attachment-id="1122447" data-permalink="https://www.criticalhit.net/gaming/friday-debate-what-does-your-dream-mandalorian-video-game-look-like/attachment/mando-debate-2-jpg/" data-orig-file="https://i1.wp.com/media.criticalhit.net//2021/01/Mando-debate-2.jpg?fit=850%2C478&amp;ssl=1" data-orig-size="850,478" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Mando-debate-2.jpg" data-image-description data-medium-file="https://i1.wp.com/media.criticalhit.net//2021/01/Mando-debate-2.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i1.wp.com/media.criticalhit.net//2021/01/Mando-debate-2.jpg?fit=850%2C478&amp;ssl=1" title="Friday Debate: What does your dream Mandalorian video game look like? 31"> </a>
</div>
<div class="bwb-article-content-wrapper">
<header>
<h3 class="entry-title"><a href="https://www.criticalhit.net/gaming/friday-debate-what-does-your-dream-mandalorian-video-game-look-like/"><span>Friday Debate: What does your dream Mandalorian video game look like?</span></a></h3>
</header>
<footer>
<div class="bdaia-post-author-name">
<a href="https://www.criticalhit.net/author/dbonthuys/" title="Posts by Darryn Bonthuys" rel="author">Darryn Bonthuys</a> </div>
<div class="bdaia-post-date"><span class="bdayh-date">5 days ago</span></div>
</footer>
</div>
</article>
</div>
</div>
<div class="bdayh-posts-load-wait">
<div class="sk-circle"><div class="sk-circle1 sk-child"></div><div class="sk-circle2 sk-child"></div><div class="sk-circle3 sk-child"></div><div class="sk-circle4 sk-child"></div><div class="sk-circle5 sk-child"></div><div class="sk-circle6 sk-child"></div><div class="sk-circle7 sk-child"></div><div class="sk-circle8 sk-child"></div><div class="sk-circle9 sk-child"></div><div class="sk-circle10 sk-child"></div><div class="sk-circle11 sk-child"></div><div class="sk-circle12 sk-child"></div></div>
</div>
</div>
</div>
</div></div> </div>
<div id="footer-third" class="footer-widget-inner">
<div id="bdaia-widget-timeline-2" class="widget bdaia-widget bdaia-widget-timeline">
<h4 class="block-title"><span>Timeline</span></h4>
<div class="widget-inner">
<ul>
<li>
<a href="https://www.criticalhit.net/technology/amd-announces-new-more-powerful-ryzen-processors/">
<span class="bdayh-date">18 seconds ago</span> <h3>AMD announces new, more powerful Ryzen processors</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/gaming/nintendo-is-throwing-copyright-claims-at-game-watch-hacking-videos/">
<span class="bdayh-date">45 mins ago</span> <h3>Nintendo is throwing copyright claims at Game &amp; Watch hacking videos</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/gaming/razers-project-brooklyn-looks-so-dumb-its-awesome/">
<span class="bdayh-date">1 hour ago</span> <h3>Razer&rsquo;s Project Brooklyn looks expensively awesome</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/gaming/nvidia-reveals-new-entry-level-geforce-rtx-3060-card/">
<span class="bdayh-date">2 hours ago</span> <h3>Nvidia reveals new entry-level GeForce RTX 3060 card</h3>
</a>
</li>
<li>
<a href="https://www.criticalhit.net/entertainment/watch-netflix-tease-70-new-movies-for-2021-including-first-footage-for-dont-look-up-red-notice-army-of-the-dead-and-more/">
<span class="bdayh-date">3 hours ago</span> <h3>Watch: Netflix tease 70 new movies for 2021, including first footage for Don&#8217;t Look Up, Red Notice, Army of the Dead, and more</h3>
</a>
</li>
</ul>
</div>
</div> </div>
</div>
</div>
</div>
<div class="woohoo-footer-top-area" style="background-color:#000000;">
<div class="bd-container">
<div class="woohoo-footer-menu">
<div class="menu-footer-container"><ul id="menu-footer" class="footer-bottom-menu"><li id="menu-item-573845" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-573845"><a href="https://www.criticalhit.net/">Critical Hit</a></li>
<li id="menu-item-574303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574303"><a href="https://www.criticalhit.net/contact/">Contact</a></li>
<li id="menu-item-573839" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-573839"><a href="https://www.criticalhit.net/advertise/">Advertise</a></li>
<li id="menu-item-574736" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574736"><a href="https://www.criticalhit.net/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-574795" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-574795"><a href="https://www.criticalhit.net/privacy-policy/">Privacy Policy</a></li>
</ul></div>  </div>
</div>
</div>
<div class="bdaia-footer-area" style="background-color:#000000;">
<div class="bd-container">
<div class="bdaia-footer-area-l">
</div>
<div class="bdaia-footer-area-r">
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<script type=\"text/javascript\">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
<div class="gotop" title="Go Top"><span class="bdaia-io bdaia-io-chevron-up"></span></div><div id="reading-position-indicator"></div>
<script type="10f54106f69c6db055441066-text/javascript">
    </script>
<script type="10f54106f69c6db055441066-text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.criticalhit.net\/technology\/amd-announces-new-more-powerful-ryzen-processors\/":1123668};
	</script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://c0.wp.com/p/jetpack/9.3/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"critical-hit-net"};
/* ]]> */
</script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://www.criticalhit.net/wp-content/plugins/disqus-comment-system/public/js/comment_count.js' id='disqus_count-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.19"},"disqusIdentifier":"1123668 https:\/\/www.criticalhit.net\/?p=1123668","disqusShortname":"critical-hit-net","disqusTitle":"AMD announces new, more powerful Ryzen processors","disqusUrl":"https:\/\/www.criticalhit.net\/technology\/amd-announces-new-more-powerful-ryzen-processors\/","postId":"1123668"};
/* ]]> */
</script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://www.criticalhit.net/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js' id='disqus_embed-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://www.criticalhit.net/wp-content/plugins/easy-table/js/easy-table-script.js' id='easy_table_script-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" id='woohoo-main-js-extra'>
/* <![CDATA[ */
var bd = {"nonce":"728caf6159","ajaxurl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","is_singular":"1","has_lazy_load":"1","bd_lazyload":"1","mobile_topmenu":"1","sticky_sidebar":"1","all_lightbox":"1","click_to_comments":"","post_reading_position_indicator":"1"};
/* ]]> */
</script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://www.criticalhit.net/wp-content/themes/woohoo-child/js/main.js' id='woohoo-main-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://www.criticalhit.net/wp-content/themes/woohoo-child/js/js-cookie.js' id='js-cookie-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://c0.wp.com/c/5.6/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://c0.wp.com/c/5.6/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://www.criticalhit.net/wp-content/themes/woohoo/js/search.js' id='bd-search-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.criticalhit.net\/wp-admin\/admin-ajax.php","nonce":"da9bf0ffa7","display_exif":"0","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"white","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.criticalhit.net\/wp-login.php?redirect_to=https%3A%2F%2Fwww.criticalhit.net%2Ftechnology%2Famd-announces-new-more-powerful-ryzen-processors%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://c0.wp.com/p/jetpack/9.3/_inc/build/carousel/jetpack-carousel.min.js' id='jetpack-carousel-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type="10f54106f69c6db055441066-text/javascript" src='https://c0.wp.com/p/jetpack/9.3/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type="10f54106f69c6db055441066-text/javascript" id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script src='https://stats.wp.com/e-202102.js' defer type="10f54106f69c6db055441066-text/javascript"></script>
<script type="10f54106f69c6db055441066-text/javascript">
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.3',blog:'122131268',post:'1123668',tz:'2',srv:'www.criticalhit.net'} ]);
	_stq.push([ 'clickTrackerInit', '122131268', '1123668' ]);
</script>
<script src="https://ajax.cloudflare.com/cdn-cgi/scripts/7089c43e/cloudflare-static/rocket-loader.min.js" data-cf-settings="10f54106f69c6db055441066-|49" defer=""></script></body>
</html>